Tool/script to uninstall ESS

Discussion in 'ESET Smart Security v3 Beta Forum' started by lu_chin, Apr 6, 2007.

Thread Status:
Not open for further replies.
  1. lu_chin

    lu_chin Registered Member

    Joined:
    Oct 27, 2005
    Posts:
    294
    Hi, is there any standalone tool or script that can uninstall ESS in XP safe mode? It will be handy in case the test user has problems with ESS but can only boot into safe mode (where the MSI service is not running).

    Thanks.
     
  2. Sjoeii

    Sjoeii Registered Member

    Joined:
    Aug 26, 2006
    Posts:
    1,240
    Location:
    52?18'51.59"N + 4?56'32.13"O
    Try it it is very simple to uninstall.:thumb:
     
  3. lu_chin

    lu_chin Registered Member

    Joined:
    Oct 27, 2005
    Posts:
    294
    Hi Sjoeii, I understand the installer is quite good but the problem is that I cannot uninstall it inside XP safe mode because the installer does not run there. :( It will be nice to have a standalone utility or script that can uninstall ESS inside XP safe mode.

     
  4. ASpace

    ASpace Guest

    I am sure that if you have problems , ESET support (BETA support) will be able to help you .
     
  5. lu_chin

    lu_chin Registered Member

    Joined:
    Oct 27, 2005
    Posts:
    294
    Yes I think Eset's support is quite good. I had managed to uninstall another conflicting security application in XP safe mode, then rebooted, uninstalled ESS and then reinstalled the conflicting security application again (since it is one of the programs I use routinely and I was only experimenting with ESS). Still, an uninstall tool/script would have saved me (and perhaps others) quite sometime.

     
  6. Mascot

    Mascot Registered Member

    Joined:
    Apr 6, 2005
    Posts:
    64
    Unfortunately the uninstaller seems a bit flaky. I uninstalled it once. It took a long time but it did eventually uninstall ok.

    Just now though, I left it for 10-15 minutes and it showed no progress at all. Progress bar was stuck at about 20%. Clicking cancel didn't help much. I finally just hit restart and tried in safe mode, but found that it had removed itself from add/remove programs. Not that it would have made a difference since the installer Eset has chosen does not function in safe mode.

    Upon reboot after that it complained it wasn't able to communicate with kernel. I tried to reinstall, and that at least got the icon back, though with components corrupted, and trying another uninstall now since it's back in add/remove. Hopefully this will be the magic bullet. Either way, I'm going to bed :p
     
  7. Sjoeii

    Sjoeii Registered Member

    Joined:
    Aug 26, 2006
    Posts:
    1,240
    Location:
    52?18'51.59"N + 4?56'32.13"O
    Strange thing.
    Uninstalling here took less than one minute.

    How did you try to uninstall?
     
  8. cupez80

    cupez80 Registered Member

    Joined:
    Jun 28, 2005
    Posts:
    605
    Location:
    Surabaya Indonesia
    uninstall work ok here :D
     
  9. bugsy_pal

    bugsy_pal Registered Member

    Joined:
    Sep 25, 2006
    Posts:
    76
    I had a similar problem to mascot - uninstall hung part way through and I had to kill it.

    Luckily, I was able to reinstall. I think I then rebooted and tried uninstalling again, and this time it worked fine, and took just a few seconds.
     
  10. Mascot

    Mascot Registered Member

    Joined:
    Apr 6, 2005
    Posts:
    64
    Uninstall went ok the first time I did it. Though it did take a very long time (a minute or so without any change in the progress bar).

    If I was to venture a guess, I'd say either something deadlocked, or it was waiting for the core of ESS to finish off something it never intended to finish off.

    Safe mode uninstall has saved me a few times in the past, which is one reason I absolutely loath this installer since it depends on a service that won't start in safe mode.

    Luckily, reinstalling and then uninstalling did sort out the corrupted uninstall, so I'm happily back on 2.7 now.
     
  11. Sjoeii

    Sjoeii Registered Member

    Joined:
    Aug 26, 2006
    Posts:
    1,240
    Location:
    52?18'51.59"N + 4?56'32.13"O
    I uninstalled in normal mode. Safe mode didn't work for me either.
     
Thread Status:
Not open for further replies.