TI9 Build 3854 and Mustang's BartPE plugin

Discussion in 'Acronis True Image Product Line' started by K0LO, Dec 16, 2006.

Thread Status:
Not open for further replies.
  1. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Has anyone gotten the newest build 3854 of Acronis TrueImage Home 9.0 working with Mustang's BartPE plugin "Acronis True Image 9 Home Plugin Builds 3625 and Up"?

    Procedure:
    1. From TrueImageHome9 plugin folder run "RESET-PLUG.cmd" and then "TIH9-Get_Files+Lic.cmd". These commands appear to complete successfully.
    2. Run PEBuilder being sure to enable the TI9 plugin.
    3. Run PE2USB to copy the build to a bootable USB flash drive. The resultant drive includes a TrueImageH9 folder with what looks like the necessary TI executable files.
    4. Test

    In the BartPE environment there is indeed an entry on the Programs menu for Acronis True Image 9 Home. Selecting it does absolutely nothing. No feedback, nothing. The same build of BartPE also includes Acronis Disk Director 10 and it works fine in the BartPE environment.

    The last time I did this was with TI9 build 3677 and it worked fine. Has anyone else done this successfully?
     
  2. Peter2150

    Peter2150 Global Moderator

    Joined:
    Sep 20, 2003
    Posts:
    17,059
    I haven't tried a bartpe version with this build. Just curious what I'd gain with this build?

    Pete
     
    Last edited by a moderator: Dec 16, 2006
  3. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Some further information. I tried starting TI9 Home by double-clicking on the executable file in the BartPE file manager program and got the following error message:
    Code:
    Application failed to start because MSVCP71.dll was not found
    As a debugging test I copied this file from C:\Windows\System32 and placed in on the BartPE USB drive at \minint\System32 and retested. Then I got another error message but this time for the file MSVCR71.dll. After copying over both files to the BartPE build, TI9 Home Build 3854 works just fine.

    So it appears that the new build of TI requires a couple of dlls that aren't automatically installed by PEBuilder (or Mustang's plug-in). A temporary work-around is to copy the following two files:
    Code:
    msvcp71.dll
    msvcr71.dll
    to X:\minint\system32 on the BartPE installation. You can do this after running PEBuilder if your BartPE installation is on a USB flash drive. If you're building a CD, copy them to the BartPE\i386\system32 folder before burning the CD.

    I'm new at BartPE so I'm not sure if my workaround is a good solution. Perhaps Mustang or someone knowledgeable with BartPE can chime in and offer a better solution.
     
  4. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Pete:

    I'm not exactly sure either. From reading posts on the forum, Acronis seems to have fixed a couple of bugs with build 3677, but exactly which ones is still open to debate. In any event, build 3854 is the most recent version of TrueImage Home 9.
     
  5. mustang

    mustang Developer

    Joined:
    Apr 12, 2005
    Posts:
    905
    Last edited by a moderator: Dec 16, 2006
  6. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Mustang:

    Thanks for the info. Sorry to be re-inventing the wheel here.
     
Thread Status:
Not open for further replies.