TI Server 9.1 - error installing on linux Fedora 7 kernel 2.6.22.1-27.FC7 x86_64

Discussion in 'Acronis True Image Product Line' started by Urbokz, Jul 24, 2007.

Thread Status:
Not open for further replies.
  1. Urbokz

    Urbokz Registered Member

    Joined:
    Jul 24, 2007
    Posts:
    1
    Please help. I've 3 Acronis Linux Server licences regularly buyed.
    I've installed today a new HP quad core server DL360G5.
    In this server I've placed a linux fedora core 7 OS x86_64

    when I try to install the latest TI9 server for linux I obtain this error:


    Acronis True Image Server Setup failed to build
    kernel modules. Consult /var/log/trueimage-setup.log
    and /var/lib/dkms/snapapi26/0.7.16/build/make.log for
    error messages.

    here is the 2 log files:

    /var/log/trueimage-setup.log
    --------------
    Detected mdk10: 0x0000

    Detected mdk10: 0x0000

    Detected mdk: 0x0000

    Detected mdk: 0x0000

    Detected deb: 0x0000

    Detected deb: 0x0000

    Detected suse91: 0x0000

    Detected suse92: 0x0000

    Detected suse93: 0x0000

    Detected fc4: 0x0000

    Detected fc5: 0x0000

    Detected virtuozzo: 0x0000

    Detected virtuozzo: 0x0000

    Running 'rpm -U --percent --force --nodeps /tmp/RPMS.Czg02L/dkms-2.0.4-2.noarch.rpm':
    finished
    Running 'rpm -U --percent --force --nodeps /tmp/RPMS.Czg02L/snapapi26_modules-0.7.16-1.noarch.rpm':
    finished
    Running 'rpm -U --percent --force --nodeps /tmp/RPMS.Czg02L/MediaBuilder-9.1.3883-1.i386.rpm':
    finished
    Running 'rpm -e trueimage':
    error: package trueimage is not installed
    finished
    Running 'rpm -U --percent --force --nodeps /tmp/RPMS.Czg02L/TrueImageClient-9.1.3883-1.i386.rpm':
    ln: creating symbolic link `/root/Desktop/TrueImage.desktop': No such file or directory
    finished
    Launching '/usr/sbin/dkms install -m snapapi26 -v 0.7.16 2>&1'.

    Error! DKMS tree does not contain: snapapi26-0.7.16
    Build cannot continue without the proper tree.

    Launching '/usr/sbin/dkms ldtarball --force --archive /usr/lib/Acronis/kernel_modules/snapapi26-0.7.16-all.tar.gz 2>&1'.

    Warning! This tarball was created with dkms < 2.0 and contains
    no arch info. DKMS will assume the arch: x86_64

    Loading tarball for module: snapapi26 / version: 0.7.16

    Loading /usr/src/snapapi26-0.7.16...
    Creating /var/lib/dkms/snapapi26/0.7.16/source symlink...

    DKMS: ldtarball Completed.

    Launching '/usr/sbin/dkms install -m snapapi26 -v 0.7.16 2>&1'.

    Error! Could not locate snapapi26.ko for module snapapi26 in the DKMS tree.
    You must run a dkms build for kernel 2.6.21-1.3194.fc7 (x86_64) first.


    Preparing kernel 2.6.21-1.3194.fc7 for module build:
    (This is not compiling a kernel, only just preparing kernel symbols)
    Storing current .config to be restored when complete
    using presented .config
    make oldconfig.....
    make prepare-all....(bad exit status: 2)

    Building module:
    cleaning build area....
    make KERNELRELEASE=2.6.21-1.3194.fc7 -C /lib/modules/2.6.21-1.3194.fc7/build SUBDIRS=/var/lib/dkms/snapapi26/0.7.16/build modules....(bad exit status: 2)

    Error! Bad return status for module build on kernel: 2.6.21-1.3194.fc7 (x86_64)
    Consult the make.log in the build directory
    /var/lib/dkms/snapapi26/0.7.16/build/ for more information.
    exited with status 10.
    AcronisÂ*TrueÂ*ImageÂ*Server Setup failed to build kernel modules.
    ----------------------------------------
    and the other log file /var/lib/dkms/snapapi26/0.7.16/build/make.log
    ----------------------------------------

    DKMS make.log for snapapi26-0.7.16 for kernel 2.6.22.1-27.fc7 (x86_64)
    mar lug 24 12:57:13 CEST 2007
    make: Entering directory `/usr/src/kernels/2.6.22.1-27.fc7-x86_64'
    find: /linux: No such file or directory
    CC [M] /var/lib/dkms/snapapi26/0.7.16/build/snapapi26.o
    /var/lib/dkms/snapapi26/0.7.16/build/snapapi26.c:36:27: error: linux/ioctl32.h: No such file or directory
    /var/lib/dkms/snapapi26/0.7.16/build/snapapi26.c:205: warning: âkmem_cache_tâ is deprecated
    /var/lib/dkms/snapapi26/0.7.16/build/snapapi26.c: In function âsa_cache_emlist_initâ:
    /var/lib/dkms/snapapi26/0.7.16/build/snapapi26.c:785: error: âSLAB_KERNELâ undeclared (first use in this function)
    /var/lib/dkms/snapapi26/0.7.16/build/snapapi26.c:785: error: (Each undeclared identifier is reported only once
    /var/lib/dkms/snapapi26/0.7.16/build/snapapi26.c:785: error: for each function it appears in.)
    /var/lib/dkms/snapapi26/0.7.16/build/snapapi26.c: In function âsa_cache_emgetâ:
    /var/lib/dkms/snapapi26/0.7.16/build/snapapi26.c:819: error: âSLAB_ATOMICâ undeclared (first use in this function)
    make[1]: *** [/var/lib/dkms/snapapi26/0.7.16/build/snapapi26.o] Error 1
    make: *** [_module_/var/lib/dkms/snapapi26/0.7.16/build] Error 2
    make: Leaving directory `/usr/src/kernels/2.6.22.1-27.fc7-x86_64'


    HEEEELP
     
  2. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello Urbokz,

    Thank you for choosing Acronis Linux Server Disk Backup Software.

    Please try compiling snapapi modules manually. You should have the sources of your kernel or at least kernel headers installed to do that. Generally, the snapapi kernel module should be built and
    installed with the "dkms" command. It can be done with the following
    commands:
    # dkms build -m <MODULE_NAME> -v <MODULE_VERSION> \
    -k <KERNEL_VERSRION> --config <CONFIG_FILE> --arch <KERNEL_ARCH> \
    --kernelsourcedir <PATH_TO_KERNEL_SOURCES>

    # dkms install -m <MODULE_NAME> -v <MODULE_VERSION> \
    -k <KERNEL_VERSRION> --config <CONFIG_FILE> --arch <KERNEL_ARCH> \
    --kernelsourcedir <PATH_TO_KERNEL_SOURCES>

    <MODULE_NAME> must be "snapapi" for 2.4.x kernels or
    "snapapi26" for 2.6.x kernels.

    <KERNEL_VERSION> is the version of your running kernel. You can
    find it using
    # uname -r
    command

    <MODULE_VERSION> can be detected by
    # ls /usr/src/snapapi*

    <CONFIG_FILE> is your kernel config filename. Usually
    this file can be found in the /boot directory.

    <KERNEL_ARCH> can be detected by
    # rpm -q --queryformat "%{ARCH}\n" kernel
    for RPM based distributions or by
    # uname -m
    for non-RPM based distributions.

    For details please refer to dkms man page (man dkms).

    Then proceed with normal installation route. Please refer to HOWTO.INSTALL file that comes with Acronis True Image 9.1 Server for Linux installation package for instructions.

    If the issue persists, please collect Linux system report as described in this post.

    Then submit a request for technical support. Attach all the collected files and information to your request along with the step-by-step description of the actions taken before the problem appears and the link to this thread. We will investigate the problem and try to provide you with a solution.

    Thank you.
    --
    Marat Setdikov
     
  3. borice

    borice Registered Member

    Joined:
    Aug 18, 2007
    Posts:
    1
    I have the same problem and have tried doing a manual install as well but I ended up having exactly the same error message as the first poster.

    Is there a solution for installation on Fedora 7 with kernel 2.6.22.1?

    Thank you
     
Thread Status:
Not open for further replies.