Thunderbird and IMAP in version NOD32 4 !

Discussion in 'ESET NOD32 Antivirus' started by SwissSteph, Mar 5, 2009.

Thread Status:
Not open for further replies.
  1. SwissSteph

    SwissSteph Registered Member

    Joined:
    Mar 5, 2009
    Posts:
    20
    Hello,

    I am a customer since version 2.7, then 3, then 4 ... and I find it totally unacceptable that the version 4 (final) has a huge bug with "thunderbird-IMAP" which led to the irretrievable loss of 170 professional email!

    http://img25.imageshack.us/img25/5707/thunderbirdl.png

    What to do now ... I lost very important messages!

    Stephane

    Sorry for my bad english :cautious:

    EDIT: I have (more) lost messages now ... is unacceptable, I go back to version 3, and when my license will be out I would see in competitor ...

    loss of professional posts is now asking me enormous problems. THANK YOU

    No reply to my message to "support"!
     
  2. princ

    princ Registered Member

    Joined:
    Nov 25, 2008
    Posts:
    9
    I can confirm, it is a bug which will be fixed in next release. I will write a guide, how to restore your emails.
     
  3. princ

    princ Registered Member

    Joined:
    Nov 25, 2008
    Posts:
    9
    1. turn off Thunderbird and locate your Imap account in C:\...\Thunderbird\Data\profile\ImapMail\”your account name”
    2. make an copy of that folder
    3. Run Thunderbird – create an new POP3 accout /for example FIX/ and unmark checkbox :Use Global Inbox (Store in Local Folders)”
    4. turn off your Thunderbird and copy from C:\...\Thunderbird\Data\profile\ImapMail\”account name” file usually named as INBOX /it is without extension/ to C:\...\Thunderbird\Data\profile\ImapMail\”FIX”
    5. start your Thunderbird and all messages should be in your FIX account
    6. if you want to sent messages back to your IMAP server, you can simple check them and with right mouse click select COPY to – IMAP server

    note: it works only in cached mode, on Thunderbird and on ThunderbirdPortable too
     
  4. princ

    princ Registered Member

    Joined:
    Nov 25, 2008
    Posts:
    9
    which email server do you use? Exchange, Kerio, Postfix...
     
  5. SwissSteph

    SwissSteph Registered Member

    Joined:
    Mar 5, 2009
    Posts:
    20

    Exchange = certainly not

    probably "open source"? ... but I do not know what, I work in a big administration and I am not in charge of the "mail servers service". I do not know what to answer.

    For the moment I removed Intregration your software (v4.0.314.0) in my thunderbird, and new messages appear to arrive without disappearing !?

    I am still very disappointed with everything that happened, I installed version 4 with the default settings.

    Stephane
     
  6. princ

    princ Registered Member

    Joined:
    Nov 25, 2008
    Posts:
    9
    of course, I forgot to mention that you should remove Intregrate into Mozilla Thunderbird in Advanced settings - Miscellaneous - Email client integration (v4.0.314.0)

    I found an mistake in my guide -POP3 account "Fix" isn't located in :"C:\...\Thunderbird\Data\profile\ImapMail\”FIX” but in C:\...\Thunderbird\Data\profile\Mail\”FIX”

    ....
    4. turn off your Thunderbird and copy from C:\...\Thunderbird\Data\profile\ImapMail\”account name” file usually named as INBOX /it is without extension/ to C:\...\Thunderbird\Data\profile\Mail\”FIX”
     
  7. SwissSteph

    SwissSteph Registered Member

    Joined:
    Mar 5, 2009
    Posts:
    20
    YES is already done! in order to avoid further damage :rolleyes:
     
  8. funkydude

    funkydude Registered Member

    Joined:
    Apr 5, 2004
    Posts:
    6,852
    This is odd as my problem went away. Were you using the default mail scanning settings or did you change them?
     
  9. SwissSteph

    SwissSteph Registered Member

    Joined:
    Mar 5, 2009
    Posts:
    20
    if I understood your question:

    Yes default and IMAP
     
  10. princ

    princ Registered Member

    Joined:
    Nov 25, 2008
    Posts:
    9
    I have info, that this bug was comming only in combination Thunderbird + EAV/ESS 3.0.314 + IMAP on Kerio mail server, but I need more infos about your server version
     
  11. estbird

    estbird Eset Staff

    Joined:
    Feb 19, 2009
    Posts:
    97
    I try to reproduce problem.

    Please can you publish your account settings in Thunderbird of account where were you messages destroyed?
    Just give screenshots to one picture and blur your username and parts you don't want to publish.

    These information can be helpful.

    Thx.
     
  12. SwissSteph

    SwissSteph Registered Member

    Joined:
    Mar 5, 2009
    Posts:
    20
    I have yet to answer this question, I hope to meet you in the next week ?

    Here:

    http://img3.imageshack.us/img3/154/94613462.png
    http://img3.imageshack.us/img3/4682/72415828.png
    http://img3.imageshack.us/img3/7108/18795315.png
    http://img3.imageshack.us/img3/1647/70762506.png
    http://img3.imageshack.us/img3/9610/67252986.png
    http://img3.imageshack.us/img3/5070/52005422.png
    http://img3.imageshack.us/img3/7286/84302131.png
    http://img3.imageshack.us/img3/7721/72899271.png
     
  13. estbird

    estbird Eset Staff

    Joined:
    Feb 19, 2009
    Posts:
    97
    More question:
    Do you have single-core or multicore CPU?
    Does your CPU supports HyperThreading?
    If your CPU supports HyperThreading is it enabled?
     
  14. SwissSteph

    SwissSteph Registered Member

    Joined:
    Mar 5, 2009
    Posts:
    20
    CPU-Z
    09.03.png
     
  15. EnGenie

    EnGenie Registered Member

    Joined:
    Jul 17, 2004
    Posts:
    182
    Location:
    Hampshire, England
    I am using Thunderbird with my Sky email account which is a re-badged version of Google Mail (Gmail).

    It uses secure IMAP protocol.

    I have had no problems with ESS 3.0.684, but ever since upgrading to ESS 4.0.314, I have had problems with emails "disappearing" from my local Inbox folder.
    An email will briefly appear for about 1 second, disappear, then re-appear for another 1 second, then disappear again.

    Fortunately the message has not been lost because it is still on the Google Mail server and can be read from Thunderbird by navigating to the "All Mail" folder under "Google Mail".

    If you try and copy the message by dragging and dropping it on your local Inbox folder then it "disappears" again (but fortunately a copy still remains on the Google Mail server).

    Curiously, if you create a new sub-folder below your local Inbox, then it is possible to drag and drop the message there without it disappearing.

    The way I solved this problem was to turn off the "Integrate into Mozilla Thunderbird" option under Miscellaneous > Email client integration in the ESS settings.
    It was not necessary to remove Thunderbird from the list of email clients in ESS.

    I'm sure that the above workaround is equally valid for NOD32 as well as ESS.

    It is definitely a bug and I hope that Eset fix it as soon as possible. :(
     

    Attached Files:

  16. chanart

    chanart Registered Member

    Joined:
    Mar 20, 2009
    Posts:
    2
    I am a user for years now, since version 1 and I am totally disappointed. This is an unacceptable bug!
    I have experienced more or less what is described here immediately after the upgrade to 4.
    My solution, however was to disable the "stamping" of the messages, so there is no more "scanned by nod32 bla bla" line on messages. But the thunderbird integration is intact, and no problems occurred since.
    The reply from eset's support was that "the only work around is to do what (I) have done, or to roll back to version 3.
     
  17. funkydude

    funkydude Registered Member

    Joined:
    Apr 5, 2004
    Posts:
    6,852
    I have contact with devs that are working closely on this bug, hopefully the next release should contain the fix.
     
  18. chanart

    chanart Registered Member

    Joined:
    Mar 20, 2009
    Posts:
    2
    And that would be... ahmm... version 5?
     
  19. funkydude

    funkydude Registered Member

    Joined:
    Apr 5, 2004
    Posts:
    6,852
    What? Why would it be version 5?
     
  20. ltmayonnaise

    ltmayonnaise Registered Member

    Joined:
    Apr 1, 2009
    Posts:
    2
    Same problem here on Thunderbird. Oddly, it does not appear to affect Postbox, which is based on the same codebase as Thunderbird. I am lucky enough to not have lost any email permanently, but every time new mail arrives in my Thunderbird inbox for either of my IMAP accounts it appears, then disappears, then appears, then disappears and then finally appears and stays. Also, it appears that some of my Gmail has also not been getting through. Neither of these issues occurs when NOD32 4 email protection is disabled. I'm on Windows 7 just in case that makes a difference.
     
  21. SwissSteph

    SwissSteph Registered Member

    Joined:
    Mar 5, 2009
    Posts:
    20
    I just saw (by chance) that a new version 4.0.417 is here

    WHY does my 4.0.317 warns me not a new version is there?

    WHY should I go to "eset.com" if just for a version is not out?
     
  22. ltmayonnaise

    ltmayonnaise Registered Member

    Joined:
    Apr 1, 2009
    Posts:
    2
    I too was not automatically upgraded to the most recent version. However, after manually downloading the most recent version (4.0.417) from eset.com and reinstalling it appears my problems with Thunderbird have been resolved. I need to do further testing, but from my quick tests today it looks good.
     
Thread Status:
Not open for further replies.