The screen toolbar icon is always yellow

Discussion in 'Returnil releases' started by Robin A., Jan 31, 2011.

Thread Status:
Not open for further replies.
  1. Robin A.

    Robin A. Registered Member

    Joined:
    Feb 25, 2006
    Posts:
    2,278
    In RSS Free with Virus Guard disabled, the screen toolbar icon is always yellow, whether or not the virtual mode is enabled. The know the status, it is necessary to put the cursor over the toolbar and read the information that appears.

    If the purpose of the toolbar is to provide o visual and permanent indication of the protection status, the color should change to green when the virtual mode is enabled, as I think it happens in other versions of the program.

    Windows 7, MSE.
     
    Last edited: Jan 31, 2011
  2. cm1971

    cm1971 Registered Member

    Joined:
    Oct 22, 2010
    Posts:
    727
    The default is to notify the status of the AV. You can change it under preferences to change color when virtual mode is active/inactive. It is under the administration tab.
     
  3. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
    Hi there,

    I have a PRO version and have set it as you have suggested above. But, I am not sure, why it turns "yellow" even when the Virus Guard is off and communication is set to "weekly, monthly or never" for automatic updates of virus definitions.

    I am not sure why it need to communicate, "hourly or daily".

    Best regards,

    KOR!
     
  4. cm1971

    cm1971 Registered Member

    Joined:
    Oct 22, 2010
    Posts:
    727
    With it set to notify when the virtual mode is active/inactive and not the AV you should get a green icon when the virtual mode is off and a red icon when it is active. You may need to check some of your other settings as I have not had that issue.
     
  5. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
    Hi cm197,

    The above is the default option. But, I have changed in "administration" to "virtual mode is active". So, my default color is "red icon" when the virtually mode is off and a "green icon" when the virtual mode is on (active) as I have set the Virus Guard to off.

    Now it will stay as above. But if I change the communications to more than "hourly or daily" than after few days it will turn to "yellow icon". It is stay as such until such time I update the AV definitions and turn the communication to either "hourly" or "daily". The "yellow icon" is for out of date definitions.

    So, the question is why it need to communicate so often if the Virus Guard is set to off?

    Best regards,

    KOR!
     
  6. cm1971

    cm1971 Registered Member

    Joined:
    Oct 22, 2010
    Posts:
    727
    It does update the virus scanner even if you have it disabled. That may be part of the reason. You also get messages every now and then about the product so it needs to communicate to do that. I just got one notifying me a new build of the product is available to download. I'm not sure if you can completely cut all that out as I haven't seen anything in the options for some of this.
     
  7. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
    Wouldn't weekly be enough?

    Why hourly or daily?

    Then, why have the options, "weekly, monthly or never"?

    The "yellow icon" stays yellow even I enter the virtual mode, so it defeats the purpose of having different color icon for virtual model is active or inactive.

    Best regards,

    KOR!
     
  8. cm1971

    cm1971 Registered Member

    Joined:
    Oct 22, 2010
    Posts:
    727
    It sounds like there may be other issues. Maybe try installing it again. My icon is green when virtual mode is off and red when it is on. It never turns yellow with my settings. As far as the update problem maybe a re-installation would help that too. A new build just came out anyway. I would try that and see if it helps.
     
  9. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
    Thank you for your suggestions. It is not installation problems and I have the new build installed, which came out yesterday.

    Yours is the default option. My is the option as following for a very long time as I have the Virus Guard off:

    Thus, when the virtual Mode is off the icon is red and when the virtual mode is on the icon is green, which is how it supposed to be if the above is implemented.

    The "yellow icon" is definitely a bug!

    Best regards,

    KOR!
     
  10. cm1971

    cm1971 Registered Member

    Joined:
    Oct 22, 2010
    Posts:
    727
    I'm all out of ideas so maybe Coldmoon can help. I don't have that issue so it's hard to say exactly what is causing it without being there to see it.
     
  11. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
    Agreed!

    The "yellow icon" doesn't show up after few days when the definitions are old and doesn't go away until the definitions are updated.

    Many thanks for all your help!

    Best regards,

    KOR!
     
  12. cm1971

    cm1971 Registered Member

    Joined:
    Oct 22, 2010
    Posts:
    727
    Your welcome and sorry I couldn't help more.
     
  13. Coldmoon

    Coldmoon Returnil Moderator

    Joined:
    Sep 18, 2006
    Posts:
    2,981
    Location:
    USA
    Hi all,
    Couple of things to check:

    1. Check your Home Overview tab. What does the warning panel show? If it details some form of unprotected state and/or a message about the system requiring attention, you can hide that warning to the immediate right of the panel as there should be a "hide" link.

    2. Check your messages and make sure there are no unread notices or alerts. If they exist, simply mark as read and/or delete. This includes any Virus Guard log messages as AE blocks will be listed here even if the VG is turned off.

    As for the updates, there are two types of updating:

    1. General AV signature updates
    2. Returnil Cloud and policy updates that come from our research and server based analysis

    What you see during the day are the immediate updates from #2 with #1 being less frequent. In other words, the multiple daily updates are smaller in size with a tighter focus, but come more frequently.

    Mike
     
  14. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
    Dear Mike,

    Thank you for your response. In all honesty, the yellow icon doesn't bother me, as I have gotten rid of it by setting the updates to "daily".

    I have the PRO version which was given to me on one of those giveaways, so I am grateful for this.

    Kind regards,

    KOR!

    P.S. My only participation is to help the guy in the OP!
     
  15. Robin A.

    Robin A. Registered Member

    Joined:
    Feb 25, 2006
    Posts:
    2,278
    I hid the warning and this changed the icon color from yellow to red, with virtual mode disabled. Then I started the virtual mode and the icon changed to green, as expected. I will keep checking this.
     
  16. Coldmoon

    Coldmoon Returnil Moderator

    Joined:
    Sep 18, 2006
    Posts:
    2,981
    Location:
    USA
    Hi Robin,
    The yellow color means something is not quite right and may need your attention and/or review. Just be sure to check your settings now and then after hiding the warning panel alert to remind yourself of what they are...

    Mike
     
Thread Status:
Not open for further replies.