Terminate nod32krn.exe/Program conflicts

Discussion in 'NOD32 version 2 Forum' started by Celerity, Apr 28, 2005.

Thread Status:
Not open for further replies.
  1. Celerity

    Celerity Registered Member

    Joined:
    Mar 21, 2005
    Posts:
    7
    Hi,

    I found a conflict between the game 'Age of Mythology' and NOD32. When I'm trying to change a chat channel, my game crashes. I tryed to uninstall NOD32 from my PC (AMD 1700+, 256, Win 2k with latest updates) and my game worked again (so I'm sure it was NOD32).

    Ofcource I don't want to do that all the time when I want to play, so I tryed to simply quit NOD32 before I start the game. Unfortunately this didn't worked either. I found a NOD32 process called 'nod32krn.exe' in my taskmanager, even if I have quitted my AV. I tryed to kill that process, but I got the error message 'Access is denied'.

    So my question is,

    1) Is there a way to make NOD32 conformable with the game Age of Mytology?

    2) If I'm right I cannot terminate 'nod32krn.exe' because of security reasons, but how do I entire disable my AV system, if I got a problem like this?

    Thanks,
     
  2. alglove

    alglove Registered Member

    Joined:
    Jan 17, 2005
    Posts:
    904
    Location:
    Houston, Texas, USA
    You are right. You are not allowed to terminate "nod32krn.exe" because of security reasons. The good news is, you will probably not have to. First, let me jot down some links to Microsoft's website relating to Age of Mythology and multiplayer issues:

    http://support.microsoft.com/default.aspx?scid=kb;en-us;819836
    http://support.microsoft.com/kb/331406
    http://support.microsoft.com/kb/331410

    According to the third link, the ports required to connect to Ensembe Studios in order to start multiplayer games are TCP 80, UDP 2300, and TCP 28800-28805. It's OK if that does not make sense, but the important part is that TCP 80 is scanned by the IMON module of NOD32. In the NOD32 configuration, highlight IMON, and on the right side, uncheck "Internet Monitor (IMON) enabled". Now try playing AOM.

    Assuming this works, there are other tricks you can try so you do not have to disable/enable IMON everytime you play. Go to the IMON setup. Go to the HTTP tab and look for the Compatability setup. Hit the Setup button and look for any of these four files in the following list. If you do see these files, make sure they are set to "Higher compatability":

    C:\Program Files\Microsoft Games\Age of Mythology\aom.exe
    C:\Program Files\Microsoft Games\Age of Mythology\aomx.exe
    C:\Program Files\Microsoft Games\Age of Mythology\autopatcher.exe
    C:\Program Files\Microsoft Games\Age of Mythology\autopatcherx.exe

    If this does not work, go to the Miscellaneous tab and hit the Repair Now button. If that does not work, go to the Exclusions button and add the 4 files shown above to the list.

    Let me know if this gets you anywhere. If need be, I can dig the game out of the closet and see how it works on my machine.
     
  3. Celerity

    Celerity Registered Member

    Joined:
    Mar 21, 2005
    Posts:
    7
    It worked!!! :D

    Thanks a lot!
     
Thread Status:
Not open for further replies.