tcpsvcs.exe at 100%

Discussion in 'NOD32 version 2 Forum' started by WindBlade, Oct 30, 2003.

Thread Status:
Not open for further replies.
  1. WindBlade

    WindBlade Guest

    Hi! After installing the latest version of NOD2.0 and rebooting my computer, my comp seem very sluggish. Looking at the processes, I discover that tcpsvcs.exe is running at 100% CPU load. Only when I disable Simple TCP/IP Services did the problem go away. I tried disablign other TCP/IP related services like TCP/IP NetBIOS Helper IPv6 Helper services but the problem still remain.

    Looking at the isntallation log, NOD32 2.o seem to install Winsock 2.0 Non-IFS Service Provider Support Environment (W32IFSL.sys) into the system and I suspect that is causing the error?

    Please look into he problem
  2. Marcos

    Marcos Eset Staff Account

    Nov 22, 2002

    I recommend that you contact NOD32 support at and provide more detailed information, such as what operating system you use, what service packs you have installed, information about your NOD32 (CC - NOD32 System Tools - Information), or other special programs you might have installed. Also, please let the support know if turning IMON off solves the problem.
  3. WindBlade

    WindBlade Guest

    I am using Windows XP with all the latest service packs and update rollups... ..
    No special programs except microsoft IPv6 installed...
    turning off IMON does not solve hte problem..
  4. I have the same problem after upgrading to NOD32 ver 2 on W2K Professional with all MS updates and fixes installed. Task Manager shows tcpsvcs 50% CPU and svchost 50%. DHCP does not work. W2K ipconfig /renew says:

    "The following error occurred when renewing adapter Local Area Connection: An operation was attempted on something that is not a socket."

    Disabling AMON and IMON doesn't help. Uninstalling NOD32 does.

    Thanks/Mikael :(
  5. Marcos

    Marcos Eset Staff Account

    Nov 22, 2002
    Hi all,
    a new program component update is going to be released on Monday, so I suggest that you give it a try first. If no avail, let us know either on this forum, or send a message to support.

    Just to make sure, did you turn off IMON by clicking the Stop button and restarted the computer? (the same goes for AMON)
  6. rumpstah

    rumpstah Registered Member

    Mar 19, 2003
    I would first try running the winsockfix. A program could have either through its installation or uninstallation process corrupted the TCP/IP settings in the registry.
  7. WindBlade

    WindBlade Guest

    Yeap! I STOPPED both AMONa nd IMON.. and restarted my comp thereafter..
    buit seems to be no help...
    I did a installation log of NOD32 and HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WinSock2\Parameters\Protocol_Catalog9\Catalog_Entries seems to be the problem..
    what do you think?

    waiting for the monday update..
  8. ???

    ??? Guest

  9. puff-m-d

    puff-m-d Registered Member

    Feb 13, 2002
    North Carolina, USA
    I would again suggest you run this fix. It have solved several similar problems with NOD32. After running the fix, you may have to reactivate IMON through your contol panel....
  10. Merlinox

    Merlinox Guest

  11. The Kid

    The Kid Guest

    I found the fix to your problem should say ours here's the link

    good luck
  12. Gauthreau

    Gauthreau Guest

    Others have had this problem as well. From what I've read - I've never experienced the problem - you can set IMON to exclude tcpsvcs.exe via - IMON >Setup>MiscellaneousTab>Exclusion>Edit and see if that does the trick for you.

    Others may be able to make recommendations as to possible security risks by doing so. I am not familiar with them.

Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.