TCGINA error: "Truecrypt not available"

Discussion in 'privacy technology' started by bla707, Aug 13, 2010.

Thread Status:
Not open for further replies.
  1. bla707

    bla707 Registered Member

    Joined:
    Aug 13, 2010
    Posts:
    3
    (Solved) TCGINA error: "Truecrypt not available"

    Hello everybody,

    I got the impression that questions not allowed on the 'official' TC forum might have a chance here. Since TCGINA (now) is 'third-party' software, it's off-limits there.
    My problem is that I cannot log on to Windows with my main user account anymore, because TCGINA gives me the error in the subject.

    The details:

    I've been using TC 6.2a together with TCGINA (1.26) on Windows XP (SP2, later SP3) for a while, encrypting a single user profile on my machine, while leaving others unencrypted. It's exactly the solution I need, for several reasons.

    I used this combination for about a year, my profile located on an external 2.5" USB-connected hard drive (500 GB, 3 partitions, the middle one encrypted with TC). Everything went flawlessly.
    Unfortunately, that hard drive died about a week ago, so I had to resort to my backup drive. Since that drive wasn't encrypted, I started transferring everything to a freshly partitioned and formatted (single encrypted partition, b/c the drive was a bit smaller than the original one) third external drive. I partitioned, formatted and transfered everything via internal S-ATA connections instead of external USB to save some time. All this was done from a separate user account on the same machine. Later, the encrypted drive was put back into an external USB housing.

    But when I wanted to log on using my main user profile (which is an admin account, btw), all I got was the error message "TrueCrypt not available". I could still log on using the alternate profile and mount the encrypted drive from there (just as I had done for the copying job), but I couldn't log on w/ the regular account which the encrypted partition (on the external drive) belongs to.

    It's strange that the TCGINA logon doesn't work, given TC *is* obviously working (from the other user account), TCGINA logon has been working fine in the same constellation before I switched the drive, and there's nothing wrong with the encrypted drive itself (AFAICT). Windows XP does recognize the drive, just not the partition on it (until mounting).

    I couldn't find anything about this problem on the web, nor in the official TC forum, nor here. I know there are some TC experts here, so can anyone help me?

    TIA

    (Edit: Problem solved, edited Subject.)
     
    Last edited: Aug 15, 2010
  2. Countermail

    Countermail Registered Member

    Joined:
    Aug 7, 2009
    Posts:
    167
    Location:
    Sweden
    You need to login to your working account and start regedit, go to:

    [HKEY_LOCAL_MACHINE\SOFTWARE\TCGINA DLL\{D47DF546-F16B-490b-A6D8-523603A5594D}\login_name]

    And change the partition# (and maybe the harddisk#):
    "TCFileName"="\\Device\\Harddisk1\\Partition1"
     
  3. bla707

    bla707 Registered Member

    Joined:
    Aug 13, 2010
    Posts:
    3
    Hi Countermail,

    thank you for your answer and sorry for not coming back to this earlier. I was away for a while and don't have 24/7 access to the machine anyway.

    Unfortunately, this solution did not work. The first thing I noticed when looking for those registry values was that there wasn't any TCFileName entry at all. So TCGINA seems to have worked fine without it before. I always understood TCGINA in the way that it would look for any TC volume/device it could find, and try to mount it with the provided (Windows logon) password, otherwise with a password it gets from an additional password prompt (as in my case).

    I then added a TCFileName entry to the registry (as a string, right?) and tried it both with double backslashes and with single backslashes (not sure those double backslashes are right when I type directly into regedit and don't use a .reg file where I've seen the double backslashes before).

    Both versions of TCFileName values produce the same result as no TCFileName entry at all.

    I also tried something I read in another forum (maybe related to Vista, can't remember): Log on as an unencrypted user, mount the TC volume that holds the encrypted user profile, log off and try to log on as the the encryted user. Didn't work, either.

    To my surprise, I noticed that I had installed the debug version of TCGINA 1.26, so I have a log. However, from looking at it, I don't really get any clues.

    I'll attach the log to this post.
    For privacy reasons, I replaced my user names (encrypted 'main' account and unencrypted additional account), computer name and the localized name of my "documents and settings" directory with "<USER_ENCRYPTED>", "<USER_UNENCRYPTED>", "<COMPUTERNAME>" and "<DOCUMENTS AND SETTINGS>" and also edited out the time.

    The most interesting part of the log is probably close to the beginning:
    Code:
    WlxNegotiate
    WlxInitialize
    WlxGetOption
    WlxGetOption
    TCSYS_Open
    TCSYS_Open: Cannot access device driver!
    TCSYS_Close
    The "TCSYS_Open: Cannot access device driver!" is repeated shortly after the first occurrence.

    And I don't have any idea where the "TCDrive = U:\" line comes from. There is no U: drive. The TC drive/partition is supposed to mount as the F: drive.

    b.
     

    Attached Files:

  4. bla707

    bla707 Registered Member

    Joined:
    Aug 13, 2010
    Posts:
    3
    Thanks to the direct help from Racoon, the problem could be solved.
    The TC service had mysteriously disappeared from the registry.

    After reinstall, everything is back to normal.
     
Loading...
Thread Status:
Not open for further replies.