suddenly 'general compiler error' on updating NOD 64bit 4.2.40 @ WIN 7 64bit

Discussion in 'ESET NOD32 Antivirus' started by vtol, May 28, 2010.

Thread Status:
Not open for further replies.
  1. vtol

    vtol Registered Member

    Joined:
    Apr 8, 2010
    Posts:
    774
    Location:
    just around the next corner
    just started - could the signature update on eset server be corrupt? already cleared the update cache...

    28-05-2010 18-25-10.png

    28-05-2010 19-42-29.png
     
    Last edited: May 28, 2010
  2. Rmuffler

    Rmuffler Former Eset Moderator

    Joined:
    Jun 26, 2008
    Posts:
    995
    Location:
    San Diego, CA USA
  3. vtol

    vtol Registered Member

    Joined:
    Apr 8, 2010
    Posts:
    774
    Location:
    just around the next corner
    how about preventing the Eset server to deliver corrupted code? perhaps a re-install? the matter went away shortly after, say 1 - 2 hours after reported here.

    better never than late, but what is the achievement of posting as Eset mod after almost 2 weeks?
     
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    It's a problem with incompatible modules. Should you come across the error in the future, we'll need to get the following stuff for perusal to troubleshoot general compiler errors:
    - dat files from the ESET install folder
    - the content of the "C:\Documents and Settings\All Users\Application Data\ESET\ESET NOD32 Antivirus\updfiles\" folder

    The fastest fix for this would be a complete uninstallation and installation from scratch if clearing the update cache makes no difference.
     
  5. vtol

    vtol Registered Member

    Joined:
    Apr 8, 2010
    Posts:
    774
    Location:
    just around the next corner
    happening again today, last successful update yesterday

    28-06-2010 17-04-46.png

    check pm for the dl link of the files requested
     
  6. Rmuffler

    Rmuffler Former Eset Moderator

    Joined:
    Jun 26, 2008
    Posts:
    995
    Location:
    San Diego, CA USA
  7. cybercomp

    cybercomp Registered Member

    Joined:
    Aug 17, 2007
    Posts:
    7
    I now have this on my machine. running EAV 64 bit on win 7.

    In my opinion uninstalling and re-installing is not a satisfactory solution, it's a work around.

    Happy to provide what ever information is required to resolve this.

    Nathan
     
  8. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    In order for us to look at the issue it is important that you are able to reproduce this problem after a computer restart. If so, compress the required files mentioned above, upload it somewhere and PM me the link. With the file Vtol has supplied we couldn't reproduce the problem on our side and the update went fine. He also confirmed that he couldn't reproduce the problem after a restart either.
     
Thread Status:
Not open for further replies.