SpyShelter 12

Discussion in 'other anti-malware software' started by mood, Oct 21, 2019.

  1. ichito

    ichito Registered Member

    Joined:
    Jan 14, 2011
    Posts:
    1,973
    Location:
    Poland - Cracow
    The same practice is mine...no auto-uptade of installed apps. You asked about SS test...do you mean this?
    https://www.wilderssecurity.com/threads/avlab-test-of-software-for-online-banking-protection.414737/
    BTW here is some info about SS also
    https://avlab.pl/the-best-recommended-specialized-antivirus-suites-from-avlab/
     
  2. Wendi

    Wendi Registered Member

    Joined:
    Aug 8, 2008
    Posts:
    630
    Location:
    USA
    @ichito, @Surt - I started using SpyShelter Free about 2 weeks ago. I notice that it doesn't seem to load (i.e., it's icon doesn't appear in taskbar's notification area) until my boot process has completed. So I'm assuming that SS (at least the free version) does not provide any protection during bootup; is that correct?
     
    Last edited: Oct 31, 2020
  3. ichito

    ichito Registered Member

    Joined:
    Jan 14, 2011
    Posts:
    1,973
    Location:
    Poland - Cracow
    @Wendi
    I don't remember how is in the free version but there is an option "launch as a service" in Settings/General in paid version. Check it...as I remember default is disabled so switch it on.
     
  4. Wendi

    Wendi Registered Member

    Joined:
    Aug 8, 2008
    Posts:
    630
    Location:
    USA
    Hi ichito. Although that checkbox appears within SS Free's settings, for some reason it does not allow me to check it (there is no mention of that setting being restricted to paid versions)?
     
  5. pvsurfer

    pvsurfer Registered Member

    Joined:
    Sep 1, 2004
    Posts:
    1,545
    Location:
    USA
    Wendi, it looks as if we have the same security setup, and I can confirm your assumption is correct. However I wouldn't be concerned about that potential security hole in SS Free because WVSX has us covered in that regard. :thumb:
     
    Last edited: Nov 2, 2020
  6. ichito

    ichito Registered Member

    Joined:
    Jan 14, 2011
    Posts:
    1,973
    Location:
    Poland - Cracow
    @Wendi @pvsurfer
    You can normaly enable this option...I've checked it on my instance of SS12.3 Free. First you have such option greyed so should enble autostart with system (picture on top) and after that you will have option "early start" open (bottom).
    ssfree autostart.jpg
     
  7. pvsurfer

    pvsurfer Registered Member

    Joined:
    Sep 1, 2004
    Posts:
    1,545
    Location:
    USA
    That is incorrect. After enabling Program autostart in SS-Free the "Launch the program from the service (early start)" checkbox does not accept a check entry (even though it is no longer greyed-out)!
     
    Last edited: Nov 3, 2020
  8. ichito

    ichito Registered Member

    Joined:
    Jan 14, 2011
    Posts:
    1,973
    Location:
    Poland - Cracow
    I don't know what are you telling...realy...I've restarted system few times after saving such settings and always saw the same result - enabled. I've checked list of services using diferent tools to be sure and still the same - service is running and loaded at system boot.
    This is an entry of FSRT log/section "services"
    R2 SpyShelterSrv; C:\Program Files (x86)\SpyShelter Free\SpyShelterSrv.exe [54752 2020-10-13] (Datpol Janusz Siemienowicz -> Datpol)
     
  9. pvsurfer

    pvsurfer Registered Member

    Joined:
    Sep 1, 2004
    Posts:
    1,545
    Location:
    USA
    I don't understand why you are able to enter a check into that 'early autostart' checkbox when my installation of SS-Free v12.3 (on Windows 10 x64) will not accept a check in that checkbox?
     
  10. ichito

    ichito Registered Member

    Joined:
    Jan 14, 2011
    Posts:
    1,973
    Location:
    Poland - Cracow
    @pvsurfer
    SS according to changelog for v. 12.3 is compatibile to Win10 Update 20H2. Do you have some newer?
     
  11. pvsurfer

    pvsurfer Registered Member

    Joined:
    Sep 1, 2004
    Posts:
    1,545
    Location:
    USA
    I'm running Windows 10 Pro v2004. As a free user I am unable to report this issue to the developer. Would you kindly do that?
     
  12. ichito

    ichito Registered Member

    Joined:
    Jan 14, 2011
    Posts:
    1,973
    Location:
    Poland - Cracow
    OK...I'll do this :)
     
  13. Wendi

    Wendi Registered Member

    Joined:
    Aug 8, 2008
    Posts:
    630
    Location:
    USA
    @ichito - Like @pvsurfer I have SS Free 12.3 running on Win10 Pro x64 2004 and I am also unable to enter a check in that Early Start checkbox (Program autostart is enabled). When I click on that checkbox nothing happens!

    Edit: Thinking that the problem might be caused by my other anti-malware programs I disabled both WD and WVSX. After doing that the Early Start checkbox still refuses to accept a check entry!!!
     
    Last edited: Nov 3, 2020
  14. puff-m-d

    puff-m-d Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    5,602
    Location:
    North Carolina, USA
    Hello,
    I had this issue several years ago. I remember it had to do with whether you installed SS for the currently logged in user or for all users. SS installed one way will allow you to run the service and the other way will not. I am getting old and this is where my memory fails me. I am not sure which way SS needs to be installed in order to run the service. I do remember you only get the choice of currently logged in user or all users during the initial installation. In order to change it, you must uninstall SS and install again choosing which way you want to install. I hope this helps as I wish I could help more by remembering the exact way to install in order to be able to use the service but my increasing age works at my memory....
     
  15. Wendi

    Wendi Registered Member

    Joined:
    Aug 8, 2008
    Posts:
    630
    Location:
    USA
    Hi Kent, thanks for relating your experience with this issue. I imagine if I uninstall and reinstall I would lose the many rules that are already in place ...or perhaps @ichito knows how to save them during an uninstall/reinstall?

    Sounds like you no longer use SS - how come?
     
  16. puff-m-d

    puff-m-d Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    5,602
    Location:
    North Carolina, USA
    Hello @Wendi ,

    There is a way to backup and restore rules but due to ...
    ...I am hesitant to reply as I may give wrong advice.

    I started using SS back in 2011 but I stopped using SS not long after Windows 10 was released. Some of the software that I alpha test requires me to turn on and use memory integrity in Windows 10 (Device security > Core isolation > Memory integrity). The SS drivers are not compatible with Windows Memory integrity and SS will not run with it enabled. Otherwise I would still be using SS. So far, the guys at SS seem to have no plans to make SS compatible.
     
  17. Wendi

    Wendi Registered Member

    Joined:
    Aug 8, 2008
    Posts:
    630
    Location:
    USA
    I see ....alpha testing is way above my pay grade! ;)
     
  18. co22

    co22 Registered Member

    Joined:
    Nov 22, 2011
    Posts:
    405
    Location:
    router
    overwriting keep rules in SSF not sure about free version
    you can exit the app and backup C:\Users\%username%\AppData\Roaming\SpyShelter folder to this work in SSF
    SSF
    have option inside app to export rule but wont export firewall rule(not sure about recent version) also
    not sure about new version but in old version it wont export application execution control rules too
    so safest wat is overwrite now during install it ask for current user or alluser
     
  19. Wendi

    Wendi Registered Member

    Joined:
    Aug 8, 2008
    Posts:
    630
    Location:
    USA
    Thank you for that really good info! - I'll try the overwrite method sometime tomorrow.
     
  20. ichito

    ichito Registered Member

    Joined:
    Jan 14, 2011
    Posts:
    1,973
    Location:
    Poland - Cracow
    Yes...installation for all users can solve problem like @puff-m-d said. I observed perhaps interresting thing - version 12.3 free is differ to 12.0 in protection area. I mean the list of monitored actions:
    - earlier it was 25 actions like on screenshots in posts #5 and #10 on the first page
    - now we have 43 actions what we can see on screenshot below
    SSfree12.3_action.jpg
    As we can see we have added
    anti-keylogging protection (actions #1-20, 55, 56, 58 )
    clipboard protection (#24)
    anti-gettext (#25)
    were removed
    firewall (#33, 48, 50, 52, 54)
    system protection (#49)
    screen protection (#35)

    One more observation according to firewall actions - although some action were removed it looks thet they are still monitored (#48, 53, 54) and proper rules are created - e.g. blocking rule for STDUViewer that was created in advanced rules creator.
    SSfree 12.3_log.jpg
     
  21. Wendi

    Wendi Registered Member

    Joined:
    Aug 8, 2008
    Posts:
    630
    Location:
    USA
    @ichito, @puff-m-d, @co22,

    I tried the overwrite method in order to change my installation from 'only my user account' to an 'all users' installation. Unfortunately, SS-Free 12.3's installer recognized my existing installation and went into 'update mode' which does not offer choice of user!

    It seems to me that this problem is due to a basic program flaw which should be addressed by the developer...
     
    Last edited: Nov 4, 2020
  22. ichito

    ichito Registered Member

    Joined:
    Jan 14, 2011
    Posts:
    1,973
    Location:
    Poland - Cracow
    Hi @Wendi
    We should be patient and wait for dev answer :) At this time my question - how did you uninstall SS Free? Using 3-d unistaleler like Revo? Did you check orphaned files (exe, dll, sys), registry entries, processes and services in autostart?
     
  23. Wendi

    Wendi Registered Member

    Joined:
    Aug 8, 2008
    Posts:
    630
    Location:
    USA
    I did not uninstall SS-Free. In order to preserve all of my SS rules I overwrote my installation with SS-Free setup (as suggested by @co22).
     
  24. ichito

    ichito Registered Member

    Joined:
    Jan 14, 2011
    Posts:
    1,973
    Location:
    Poland - Cracow
    Yoy can export own rules - chosen specific one, a few highlighted or all listed. You can do this using context menu (RMB) or icon on the top of list. I've tested succesfuly such export/import option...it just work even including firewall rules :)
     
  25. Wendi

    Wendi Registered Member

    Joined:
    Aug 8, 2008
    Posts:
    630
    Location:
    USA
    I exported 'all rules', uninstalled SS-Free and reinstalled it for all users. Then I imported the 'all rules' that I previously exported and was finally able to check the 'Early Start' checkbox! SS-Free now starts early in the bootup process, so I believe that makes the effort worthwhile. Time will tell if all of my old rules have been properly retained.

    Thanks to all for your support.
     
    Last edited: Nov 4, 2020
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.