Specifying application in internet filter dysfunctional?

Discussion in 'LnS English Forum' started by Havoc70, Jun 24, 2005.

Thread Status:
Not open for further replies.
  1. Havoc70

    Havoc70 Registered Member

    Joined:
    Jun 24, 2005
    Posts:
    4
    I've been evaluating LNS vs. Sygate for a couple of weeks now, and I must say LNS is vastly superior. However, one thing I've noticed is that the ability to open a set of ports in the internet filter rules only when a certain application is active is not working correctly, or, I'm not understanding it correctly.

    In this case, I'm talking about Bit Tornado, which is a BT client. It is configured to use a range of ports: 40000 - 40100. The rule is defined in the internet filter section and it works just fine so it's not a rule definition issue.

    However, when I specify the application "btdownloadgui.exe" in the applications setting, it sets the rule as disabled. But, the application is listed as "active" in the application filtering tab's list of active applicatoins.

    My understanding of this functionality is that since btdownloadgui.exe is showing as active, and the rule opening ports 40000-40100 is predicated upon that application being active, the checkmark next to the internet filter rule should be green, not brownish-red indicatin a disabled state.

    So, someone please correct my understanding on how this works or confirm that it is indeed a software issue. I don't want these ports to be open unless the application requiring them is active.


    Thanks!
     
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,

    Yes, your understanding is correct.

    Sometimes there are some problem with this feature if the Internet Filtering is informed too late of the activation of the rule and the packet has already been blocked.
    However, when this happen, normally the application disconnect and you no longer see it in the Application Filtering. So your case looks different.

    Are you sure you associated the right application ?
    If yes, could check if this feature is working with some other application (email client...) ?

    Thanks,

    Frederic
     
  3. Havoc70

    Havoc70 Registered Member

    Joined:
    Jun 24, 2005
    Posts:
    4
    It seems to be working OK now after a reboot. I'll keep an eye on it and if I can pin down exactly what causes the issue, I'll post again.

    Thanks for the follow up, Frederic
     
  4. Havoc70

    Havoc70 Registered Member

    Joined:
    Jun 24, 2005
    Posts:
    4
  5. Havoc70

    Havoc70 Registered Member

    Joined:
    Jun 24, 2005
    Posts:
    4
    OK. I figured out when it dies. Bit Tornado is working great. but with setiqueue it's running as a service and for LNS to figure out it's active I need to stop and restart the service then it's fine. It would be nice for LNS to be able to detect it's running without having to stop and start the service. I suspect it's because setiqueue starts before LNS does so LNS doesn't know it's active.

    So, probably not much can be done about that.
     
  6. DonKid

    DonKid Registered Member

    Joined:
    Jun 27, 2004
    Posts:
    566
    Location:
    S?o Paulo, Brazil
    My counter strike and The All Seeing Eye have the same problem. How can I fix it ?

    Best Regards,

    DonKid.
     
Thread Status:
Not open for further replies.