Sound Problem

Discussion in 'all things UNIX' started by cet, Sep 25, 2011.

Thread Status:
Not open for further replies.
  1. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    I am using Ubuntu 10.04 LTS.Suddenly the login sound stopped working.Also the sound theme does not work(sound effects).But all the other sounds such as audio preview,audio,game sounds,youtube sounds etc.work.I hear the drum sound when I log-off.
    Skype test call works but there is no sound while starting up skype.I googled but could not find any solution to my problem.Thanks in advance.
     
    Last edited: Sep 25, 2011
  2. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    Try this

    sudo lsof | grep pcm

    sudo /etc/init.d/alsa-utils restart
     
  3. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir

    Tried but it did not bring the system sounds back.
     
  4. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    sudo apt-get --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2
     
  5. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    Sorry for asking but I really do not know the commands.I only copy and paste them in the terminal.Is there any chance of losing the sound which I have now by using this command ''sudo apt-get --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2''

    If there is any chance of losing the sound I have I can stay without the login or system sounds.
     
  6. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136

    Cet,

    You are absolutely correct in being cautious, this is from Ubuntu manpage and it removes and reinistalls the sound module. I suggest you do your own study on this before proceeding further.
     
  7. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
  8. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    This is the output of the first commands.Maybe you can understand what the problem is:
    ceylan@ceylan-desktop:~$ sudo lsof | grep pcm
    [sudo] password for ceylan:
    lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/ceylan/.gvfs
    Output information may be incomplete.
    stardict 2021 ceylan mem REG 8,2 22100 266354 /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
    sudo /etc/init.d/alsa-utils restart ceylan@ceylan-desktop:~$ sudo /etc/init.d/alsa-utils restart
    sudo: /etc/init.d/alsa-utils: command not found
    ceylan@ceylan-desktop:~$ sudo /etc/init.d/alsa-utils restart
    sudo: /etc/init.d/alsa-utils: command not found
    ceylan@ceylan-desktop:~$


    I checked and the alsa-utils is installed.


    I found a similar problem here.http://forums.opensuse.org/english/...all-boot-login/435715-login-other-sounds.html
     
    Last edited: Sep 26, 2011
  9. mack_guy911

    mack_guy911 Registered Member

    Joined:
    Mar 21, 2007
    Posts:
    2,677
    have you check this

    by right clicking on sound icon and sound preferences

    also try diffrent theme sound see what outcome is o_O
     

    Attached Files:

  10. mack_guy911

    mack_guy911 Registered Member

    Joined:
    Mar 21, 2007
    Posts:
    2,677
     
    Last edited: Sep 26, 2011
  11. pabrate

    pabrate Registered Member

    Joined:
    Jan 21, 2010
    Posts:
    685
    Sound problem is the only reason why I don't use Linux.
    Tried many distros and same thing with all of them.
    Problem is, sound is working fine but only in stereo mode, can't make it to work in 5.1 mode.
    Only left and right speaker are working, the rest of them are dead.
     
  12. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    Ubuntu forum has an excellent guide on how to make 5.1 work on it, have set that up for my friend's ASUS Xonar card and it works fine. Linux is the only distro that will still run my ancient but superb Yamaha and Turtle Beach cards.
     
  13. pabrate

    pabrate Registered Member

    Joined:
    Jan 21, 2010
    Posts:
    685
    Can you post the link for it please ?
     
  14. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136

    gksu gedit /etc/pulse/daemon.conf

    This should open up the configuration file in gedit. Once open, scroll down to find the line ; default-sample-channels = 2. Remove the semicolon at the start of the line and change the line according to your surround sound configuration:

    For 5.0 channel sound: default-sample-channels = 5

    https://help.ubuntu.com/community/SurroundSound
     
  15. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    Linuxforall thanks, I tried every command and the link you have written.But all I get is command not found.
    I installed gnome alsa mixer too.
    Not having system sounds is not important because every other sound works.But it makes me frustrated not to be able to solve the computer problem.
    When I look at the installed sound programs I see pulse audio too.
     
  16. pabrate

    pabrate Registered Member

    Joined:
    Jan 21, 2010
    Posts:
    685
    Many thanks Sir :thumb:
     
  17. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    Welcome, please post feedback when you can.
     
  18. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    cet, have a look here as regards login sounds.. http://www.howtogeek.com/howto/22428/disable-login-sounds-in-ubuntu/

    You may want to install padevchooser - check the Playback tab...

    Volume Control.png
     
  19. pabrate

    pabrate Registered Member

    Joined:
    Jan 21, 2010
    Posts:
    685
    Sure will, don't know when though, but very soon, need to install it first and I can't test it in VM because different sound card is recognized in VM.

    You reckon I can test this with LiveCD ?
    Guide says I should reboot after the change in daemon.conf , and I see that as a problem for a LiveCD :)
    Is there a way to restart sound system without rebooting , or something like that ?
     
  20. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    Live CD no but live USB definitely.
     
  21. Ocky

    Ocky Registered Member

    Joined:
    May 6, 2006
    Posts:
    2,677
    Location:
    George, S.Africa
    linuxforall, hi,

    Just a question can't one simply do :-

    pulseaudio --kill
    pulseaudio --start

    or would you consider that verging on the dangerous ?

    Btw. for 5.1 default-sample-channels=6

    Nice speaker tests without looping and using default wav files..

    speaker-test -Dplug:surround51 -c6 -l1 -twav (for testing 5.1)
    speaker-test -Dplug:surround40 -c4 -l1 -twav (for testing 4 speaker sound)
    speaker-test -Dplug:front -c2 -l1 -twav (for testing stereo sound - one stereo jack)
     
  22. linuxforall

    linuxforall Registered Member

    Joined:
    Feb 6, 2010
    Posts:
    2,136
    Ocky I guess that can be done as there is no kernel level drivers to be loaded here, worth a try.
     
  23. pabrate

    pabrate Registered Member

    Joined:
    Jan 21, 2010
    Posts:
    685
    Tried the solution from the guide in VM with Ubuntu , although the name for the card found is different than in the "real" installation , problems are identical.
    Anyway, it didn't solved the problem, I can only have stereo mode, not 5.1
    I think that the problem is deeper here, maybe the config for the sound card or something.
    btw what is Stereo Duplex ?
    And what actually do I have to choose from all those mods to have 5.1 sound ?
    Tried them all of course, still "Test Sound" is showing just two speakers.

    speaker-test -Dplug:front -c2 -l1 -twav is working. I can hear the sound from left and right speaker.
    speaker-test -Dplug:surround51 -c6 -l1 -twav (5.1 test) is not working and I can't hear anything.

    In Windows it's very easy, there is "Stereo" mode and "5.1" mode , and that's it.
    Works perfect.

    Can't believe how something simple is so complicating in Linux world, ALSA, PulseAudio, config files, muted, unmuted, this and that ...
     
  24. cet

    cet Registered Member

    Joined:
    Sep 3, 2006
    Posts:
    867
    Location:
    Turkey/İzmir
    The solution was simple,I installed it and the volume was at 1%, I made it 100% now I hear the skype login event sound and I also hear the window and button sounds.But the normal sound icon on my pc was at 70%.So I guess they are different?
    BUT still no start-up sound.Lol.


    /usr/bin/canberra-gtk-play --id=”desktop-login” --description=”GNOME Login” is this the right startup command for the gnome login sound?
     
  25. vasa1

    vasa1 Registered Member

    Joined:
    May 1, 2010
    Posts:
    4,152
    I have this:
    /usr/bin/canberra-gtk-play -V -25.0 --id="desktop-login" --description="GNOME Login"
    where "Note,the -V parameter describes the volume in decibel (neg logarithm), so 0 corresponds to full volume and -50 can barely be heard."
    (from: http://ubuntuguide.net/how-to-turn-offdownup-login-sound-when-ubuntu-gnome-startup)
     
Loading...
Thread Status:
Not open for further replies.