Solution for: Error opening the file (0x40007)

Discussion in 'Acronis True Image Product Line' started by drdude, Jan 4, 2008.

Thread Status:
Not open for further replies.
  1. drdude

    drdude Registered Member

    Joined:
    Nov 16, 2007
    Posts:
    3
    Location:
    Mainz, Germany
    Greetings @ All,

    I am writing this post hoping to shed a little light on the following 0x40007 error notification message:

    Error opening the file. (0x40007), Tag = 0xF35F747B3B21FAC3 (English)
    Fehler beim Öffnen der Datei. (0x40007) Tag = 0xF35F747B3B21FAC3 (German)

    Thank the IT gods that I understand German and a HUGE thanks goes to the poster named <head-> for actually identifying the problem/solution.
    See: https://www.wilderssecurity.com/showthread.php?t=160527

    Last month December 2007 I had set up a fresh install of Acronis TI 9.1 Server for Windows build 3920 on a win 2000 AD server. I scheduled a Full bu of the D:\ drive, using the file and folder option. At the time, I ran/tested the job. It said operation completed, so I did not think to look in the -Operations Log-. Since the fUll BU finished OK, I scheduled a daily differential bu using the same file/folder method.

    The next morning I got the following e-mail notification:

    1 Information 16.11.2007 01:00 "Daily DIFF BU of D:\ drive" gestartet
    2 Warnung! 16.11.2007 01:00 Fehler beim Öffnen der Datei. (0x40007) Tag = 0xF35F747B3B21FA89
    3 Information 16.11.2007 01:00 Partition D: sperren...
    4 Information 16.11.2007 01:00 Differentielles Backup-Archiv erstellenVon: D:\In Datei: "/backup/BU_FULL_D_Drive1.tib"Komprimierung: NormalAusschluss: Durch Ausschlussmaske erfasste DateienKriterium: *.bak, *.~, *.tmp, Beschreibung: "This is the Differential daily backup of D:\"
    5 Information 16.11.2007 01:04 Operation beendet.

    This is the first time for me using TI with the email notification. I find the complete e-mail message very sparse on info compared to the back-up software I normally use. HUGE room for improvement here. Anyway, I darn near had a heart attack when I read the error message. WTF,over. Was I going to have to drive 50 miles to the remote server to solve this problem? To make things worse, under number [5.) Oeration beendet] I was not sure if the back-up was successful or not. From my TI Home version I know in English it states: Operation Completed. A clearer language should read: Operation Successful and in German Operation Erfolgreich (oder Erfolgreich beendet) Implying --without--errors.

    So here is part of the entry from <head> translated into English, plus a few added comments from me. This is the one that saved me a lot of time and money by not having to drive 50 miles!!

    Actually it is quite simple--

    The error is created during the "Source Files Selection" process. If for example you select E: and right afterwards de-select it this will cause the above mentioned error! [Check mark clicked--then unclicked]
    [​IMG]

    The reason this happens, is that the E: drive is not really de-selected in the config file! It is actually now marked as "Exclude". It looks like this in the Config file <exclude> E:\ </exclude>. Also notice the orange shadow within the box?
    [​IMG]

    The Config files are located at: C:\Documents and Settings\All Users\Application Data\Acronis\TrueImage\Scripts
    The files are called something like: 5C5DCC23-E1EE-46C0-B509-7CF1A550C598.tib.tis and are XML files.
    You can edit them at your own risk, using the free "XML Notepad 2007" (free tool from MS), Crimson Editor or use your own favorite editor.

    The following options will solve the (0x40007) problem

    Option 1--Delete the Task, Create a new one and don't click on E:\ [this also means don't make any mistakes in clicking the wrong items, or it will be
    interpreted as an exclude! How stupid is that?]

    Option 2--Edit the task. De-select everything by clicking on the box next to <My Computer> Then, very carefully go back and select all the files/folders you want to be backed up. Once again, no margin for error here! One wrong click and it will be added to the <exclude> file option!

    Option 3--Edit the config file from the above mentioned path. Your are on your own in finding out which config file and in finding the "wrongly" selected
    <exclude> file.
    [​IMG]
    Option 4--Use a different back-up software

    On a final note, guess what!! This problem still exists in the new TI Echo Server for Windows 9.5.0.8018. Oh Happy Day! I have re-created this problem on the Win 2000 AD server, a Win 2003 file server, and on Win XP Pro. Seems like a general problem probably with ALL TI versions. I have also tested this with my TI Home 9.0.0.3854 Same (0x40007) error. Use one of the options above; problem solved.

    .....Now if I could just get the multiple e-mails in the event notification to work!
     

    Attached Files:

  2. barkingburro

    barkingburro Registered Member

    Joined:
    Jan 4, 2008
    Posts:
    2
    drdude,

    After searching so long for an answer to this annoying bug, I happened to be searching a different issue today and ran across your timely post.

    You are a scholar and a gentleman. Thank you for the valuable info!
     
  3. barkingburro

    barkingburro Registered Member

    Joined:
    Jan 4, 2008
    Posts:
    2
    Well, maybe I spoke too soon. I just looked at the log after my my backup job ran overnight. I had deleted the backup archive and started fresh. Here is the log:

    The "D_drive Daily" operation started

    Cannot open archive for appending changes.

    Error opening the file. (0x40007) Tag = 0xF35F747B3B21FAC3

    Create Differential Backup Archive
    From: D:\
    To: G:\Backups
    Exclude:Files matching mask
    Match criterion:*.tib,

    Maybe this error will go away now that the base archive has been created. When I looked at the XML file for the job, I didn't see anything unusual:

    <?xml version="1.0" encoding="UTF-8" ?>
    <batch>
    <version>2.0</version>
    <display> D_drive Daily</display>
    <priority>normal</priority>
    <stage>
    <backup>
    <archive>
    <place>
    <uri>atis:folder?file:G:\Backups\</uri>
    </place>
    </archive>
    <options backup_acronis_svc="false"
    compression="normal"
    description="Daily (Mon-Sat 5am) backup of d: + 5 differentials."
    differential="true"
    fast_incremental="true"
    rotation="5">
    <filtering
    exclude_by_mask="true"
    exclude_hidden="false"
    exclude_system="false">
    <mask>*.tib</mask>
    </filtering>
    <file_backuping ignore_encryption="false" skip_security="false" />
    <speed_limit>
    <net mode="percent" value="100" />
    <disk mode="percent" value="100" />
    </speed_limit>
    </options>
    <files>
    <include>D:\</include>
    </files>
    </backup>
    </stage>
    ...
    </batch>


    Any suggestions?
     
  4. drdude

    drdude Registered Member

    Joined:
    Nov 16, 2007
    Posts:
    3
    Location:
    Mainz, Germany
    barkingburro,

    Which file did you delete and start out fresh? From reading your post it looks like you deleted the FULL BU and then ran a

    description="Daily (Mon-Sat 5am) backup of d: + 5 differentials."
    differential="true"
    fast_incremental="true"

    And that the message is caused by the DIFF not finding the FULL...no?

    Cannot open archive for appending changes.
    Error opening the file. (0x40007) Tag = 0xF35F747B3B21FAC3
    Create Differential Backup Archive

    Do you have separate tasks for each of the FULL, Diff1, Diff2, Diff3, Diff4?
    I would run the FULL manually and then see how the DIFFs react.

    br/drdude
     
Thread Status:
Not open for further replies.