Socket Spy Not Showing Up

Discussion in 'Port Explorer' started by Jason_DiamondCS, Oct 20, 2003.

Thread Status:
Not open for further replies.
  1. Jason_DiamondCS

    Jason_DiamondCS Former DCS Moderator

    Joined:
    Nov 11, 2002
    Posts:
    1,046
    Location:
    Perth, Western Australia
    This is the known work around if Socket Spy suddenly stops showing up when you click on it. This is caused by minimizing SOCKET SPY to the task bar, then some amount of time later you decide to close that window by right clicking on the taskbar button and clicking close.

    Sometimes in this situation Port Explorer saves the minimized window position to the registry, so next time you try and start Socket Spy it remembers your minimized position instead of an onscreen position.

    The fix for this is very simple.


    1) Start regedit. (Click on Start, then Run, then type in "regedit" without quotes.

    2) Browse to HKEY_LOCAL_MACHINE\SOFTWARE\DIAMOND COMPUTER SYSTEMS\PORT EXPLORER in regedit.

    3) Delete these registry keys, SocketSpyTopLeft, SocketSpyWidth, SocketSpyHeight. (simple click on them and press the delete key)


    Now all you need to do is restart Port Explorer and it should work again. Next time you close Socket Spy, close it from the X button on the Socket Spy window instead of from the taskbar button.

    This bug should be fixed in the next Port Explorer update.

    -Jason-


    Edit: Attached this registry file which will automatically repair the three keys noted above. Download this file by right-clicking on the link and doing a Save Target As... Double-click on the saved file to execute the fix. By using this file it will not be necessary to go into REGEDIT and manually delete those keys.
     

    Attached Files:

Thread Status:
Not open for further replies.