Small Business Server 2003

Discussion in 'Port Explorer' started by Vivi, Nov 13, 2004.

Thread Status:
Not open for further replies.
  1. Vivi

    Vivi Guest

    I installed Port Explorer 2.0 on a fresh install of SMS 2003.
    Immediately after log on, when the desktop is being built, I receive a DNS error.
    "Domain Name System (DNS) encountered an error and need to close"
    Then I am not able to make any outsite connection that requires a name resolution, for example I can connect with Internet Explorer by IP but not by name.
     
  2. Pilli

    Pilli Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    6,217
    Location:
    Hampshire UK
    Hi Vivi, What other security software are you running, firewall AV AT etc?
     
  3. Vivi

    Vivi Guest

    Hi Pilli,

    Thanks for the fast response.
    No AV, no AT, no security software, only the SMS 2003 distribution. This is a test machine running under VMWare.

    Vivi
     
  4. Pilli

    Pilli Registered Member

    Joined:
    Feb 13, 2002
    Posts:
    6,217
    Location:
    Hampshire UK
    Hi Vivi, you will have to await a response from DCS on this one as I am not familiar with VMWare but I know that DCS are, this may not be until Monday Perth time.

    I have run Port Explorer 2 successfully under Server 2003.

    Cheers. Pilli
     
  5. Vivi

    Vivi Guest

    Thanks.
    I confirmed it works under Windows 2003, the problem seems to be with the DNS service under SBS 2003.

    Vivi
     
  6. Dan Perez

    Dan Perez Retired Moderator

    Joined:
    May 18, 2003
    Posts:
    1,495
    Location:
    Sunny San Diego
    Hi All,

    Regarding confirmation that the issue is not evident on Windows 2003, did you have DNS Server service running on it with the default EDNS implementation? I know that some servers and some firewalls (for instance the Cisco Pix line) have trouble dealing with the Enhanced DNS implementation of Windows 2003 DNS. If you think this might be possible you might try disabling the EDNS feature by running the following from the command prompt

    dnscmd /Config /EnableEDnsProbes 0

    I believe a restart of the service will suffice but it may be necessary to reboot the server.

    I've found that the compatibility issues with EDNS are such that I always disable this feature on every deployment of a Windows/SBS 2003 Server.

    Hope this helps,

    Dan
     
  7. Vivi

    Vivi Guest

    Hi Dan Perz,

    Thank you for your help.
    Unfortunately, it did not solve.

    Vivi
     
Thread Status:
Not open for further replies.