Skype :qualité de communication fluctuante

Discussion in 'LnS French Forum' started by vince35, Jul 20, 2005.

Thread Status:
Not open for further replies.
  1. vince35

    vince35 Registered Member

    Joined:
    Apr 15, 2005
    Posts:
    55
    Location:
    France (Breizh)
    bonjour à tous

    il arrive parfois que la personne que j'appelle sous skype m'entende très mal (son haché, faible...)

    sur le site de skype, il est expliqué que le logiciel utilise utilise une plage de ports différente à chaque lancement du logiciel et que si le firewall n'autorise pas l'ensemble de cette plage la qualité de la comm. se trouve dégradée.

    C'est apparemment mon cas vu qu'il me suffit de relancer skype pour que la situation s'améliore.

    Donc, sur le site ( http://www.skype.com/help/guides/firewall.html ) il est préconisé d'autoriser à skype tous les ports TCP de 1 à 65535 (Ideally, outgoing TCP connections to all ports (1..65535) should be opened )

    Est-ce que ce n'est pas dangereux d'autoriser une telle plage de ports ?

    Bizaremment, ici ( http://support.skype.com/index.php?...a=knowledgebase&_j=subcat&_i=8'>Technical</a> ), il parle de la plage 1024 à 65535

    EDIT : sur le site de LnS, la règle proposée ne concerne que le port UDP 54977
    Cette règle permet à Skype d'utiliser le port UDP 54977
     
  2. vince35

    vince35 Registered Member

    Joined:
    Apr 15, 2005
    Posts:
    55
    Location:
    France (Breizh)
  3. Climenole

    Climenole Look 'n' Stop Expert

    Joined:
    Jun 3, 2005
    Posts:
    1,640
    Bonjour vince35 :)

    Voici les règles que j'utilise pour Skype:
    La première et la quatrième sont nécessaires.
    Les 2 autres de ping accélèrent la connection...
    (chez moi du moins.)

    En P.J. renomme le .txt en .rie

    Dit-moi si ça marche pour toi.

    :)
     

    Attached Files:

  4. vince35

    vince35 Registered Member

    Joined:
    Apr 15, 2005
    Posts:
    55
    Location:
    France (Breizh)
    merci Climenole...

    bon, mes essais ont été mouvementés :( A force de modifier les règles, LnS s'est retrouvé dans les choux et s'est mis à les appliquer n'importe comment -vu grâce au log (règles désactivés qui s'appliquent qd même, ta règle skype 4 qui s'applique alors que je lance Firefox, idem règle MSN avec skype ... alors que chaque règle est attachée à son appli. respective!)

    exemple ici surligné :
    http://img214.imageshack.us/img214/1440/log4aw.jpg

    Bizarre qd même tout ça. Du coup j'ai aussi mis le dernier driver lnsfw.sys.

    Concernant tes règles que je n'ai donc pas vraiment pu tester en profondeur, j'aurai quelques questions :

    1_ tu utilises le Port local 54271. D'ou connais-tu ce port ? c'est celui qui apparait dans le menu OPTIONS/AUDIO de skype ?

    2_ ta 4eme règle, tu mets la plage 1024-5000. Tu arrives à utiliser sans pb skype vu que dans le forum de skype, il est préconisé d'utiliser 1024 à 65535 ?

    Merci bcp ;)
     
    Last edited: Jul 21, 2005
  5. Climenole

    Climenole Look 'n' Stop Expert

    Joined:
    Jun 3, 2005
    Posts:
    1,640
    Bonjour Vince35 :)

    Le port 54271 est en effet celui indiqué dans Skype.
    Les ports locaux 1025 à 5000 <--> tous les ports distants...

    J'utilise Skype de temps en temps et je n'ai jamais eu de problème avec ces règles mais elles peuvent être modifiées si jamais cela est nécessaire.
    Je ne l'utilise pas intensivement et il se peut que certains problèmes ne se soient pas présentés jusqu'à présent.

    Note qu'il faut aussi ajuster correctement le micro de ton PC et t'assurer que les pilotes du microphone et tout le bataclan sont à jours...
    La qualité du microphone doit sans doute entrer en ligne de compte.
    Ajuste-le avec Son et Périphériques Audio dans le Paneau de Configuration.

    Considère ces règles comme expérimentales et ajuste-les en conséquence.

    Il suffit de vérifier dans le journal de L'n'S pour savoir si ça coince et où.

    Il faut aussi indiquer la L'n'S que la règles s'applique à Skype et à aucun autre programme.

    Comme tu l'as constaté, la position des règles dans la liste est importante.
    Il faut placer ces règles d'application après les règles de blocage "système".

    J'ai expérimenté plusieurs ensembles de règles basées sur celles de Phant0m
    et j'ai constaté que les changements de règles ne sont pas toujours pris en compte automatiquement mais après un redémarrage...

    J'espère que cela répond à ta question. Fait-moi savoir si Skype marche bien
    avec les règles que je t'ai proposé.

    :)

    P.S. Commentaires ;-)

    Skype needs unrestricted outgoing TCP connections to some TCP ports.

    "Unrestricted" : On reconnait bien là l'auteur de Kazaa-le-spyware-de-merde...
    Voyons la suite ...

    If you fail to connect to Skype network, it is likely that your firewall is blocking these and you need to open up some outgoing TCP connections. Note that this is about outgoing connections, not incoming connections.

    Some outgoing : quelques ports en sortie (i.e. des ports locaux...)

    In most firewalls, you have to specify a destination port or port range to open.
    There are four options for Skype to work:

    4 options : si c'est des OPTIONS alors n'importe laquelle devrait marcher.
    Sinon ce ne sont pas des options... Dac ?

    * Ideally, outgoing TCP connections to all ports (1..65535) should be opened. This option results in Skype working most reliably. This is only necessary for your Skype to be able to connect to the Skype network ...

    C'est faux. Les 2 seuls ranges acceptables sont 1024 à 5000 ou (moins acceptable 1024 à 65535...)

    ...and will not make your network any less secure.

    Je suppose que l'auteur de Kazaa est un expert en sécurité !!!

    * If the above is not possible, open up outgoing TCP connections to port 443. This will only work if you are using Skype version 0.97 or later.

    Port 443 !!! Ridicule : réservé en port distant au protocole https.
    Pas en port local outgoing...

    * If the above is not possible, open up outgoing TCP connections to port 80. Some firewalls restrict traffic to port 80 to HTTP protocol, and in this case Skype can not use it since Skype does not use HTTP. In some firewalls it is possible to open up all traffic to port 80, not just HTTP, and in this case Skype will work.

    Ridicule aussi...: réservé au protocole http en port distant.
    Pas en port local outgoing...

    Comment se fait-il que Skype est censé marcher correctement sur le seul port 80 ou 443
    mais ne serait pas capable de le faire avec le range 1024-5000 o_O

    =>> Programmé avec les pieds.Pour ce qui est des conseils de sécurité de Skype on va s'en passer...

    Voilà.
     
  6. vince35

    vince35 Registered Member

    Joined:
    Apr 15, 2005
    Posts:
    55
    Location:
    France (Breizh)
    re salut

    encore merci pour toutes tes explications

    concernant tes règles elles ont l'air de bien tourner...

    j'ai cependant remarquer une chose dans le log:

    apparemment skype utilise le port indiqué dans son interface (54271 pour toi) en TCP, et pas seulement en UDP.

    je l'ai remarqué car cette connexion entrante TCP est bloquée par ma règle "TCP Block incoming connexion"

    Tu me conseille de laisser UDP ou de mettre "TCP ou UDP" ?

    merci
     
  7. Climenole

    Climenole Look 'n' Stop Expert

    Joined:
    Jun 3, 2005
    Posts:
    1,640
    Bonjour Vince35 :)

    Laisse-le en UDP. Si tout marche au poil pas de raison de laisser entrer ce paquet en TCP hors de la gamme de ports que tu as décidé.
    C'est toi le Maître à bord : pas Skype !

    Content que ça marche pour toi.

    Bon "Skyping" :)
     
Thread Status:
Not open for further replies.