simple pre command needs some help

Discussion in 'Acronis True Image Product Line' started by superdoug3, Aug 12, 2009.

Thread Status:
Not open for further replies.
  1. superdoug3

    superdoug3 Registered Member

    Joined:
    Jun 27, 2009
    Posts:
    33
    I for one have been very impressed with ATI2009 Home edtion, I had some problems but it turned out ERUNT was not compatible with ATI2009 Restore

    All I want to do is defrag C and virus check C before doing weekly image
    I have testing my batch file many times and it always works fine.
    I was able to get my backup to work once by doing defrag as Pre command and virus check as a post command. But never again. I have tried all combinations of pre and post and ticking and unticking the boxes associated with the options screen. The ATI2009 backup works, but the pre command and post command usually fail, but not always.

    my batch file linked to my Pre command in my ATI2009 Home edition build 9796 follows

    cd "C:\"
    title Defragmenting C:\ please do not work on computer while defragging
    defrag.exe c: -f -v > "C:\Documents and Settings\Doug\Desktop\XPdefragRpt\defrag-C.txt"
    title Running Spybot - OK to work on computer
    cd "C:\Program Files\Spybot - Search & Destroy\"
    spybotsd.exe /taskbarhide /autoupdate /autocheck /autoimmunize /autofix /autoclose

    the fact that I got it to work once, is my carrot on a stick.
    I see that MANY have used a batch file in Pre command successfully, why not me. Perhaps I should reload my ATI2009, but otherwise it is working perfectly and it did work with a Batch file once.
     
    Last edited: Aug 12, 2009
  2. superdoug3

    superdoug3 Registered Member

    Joined:
    Jun 27, 2009
    Posts:
    33
    RESOLVED - thank you for search function. Need to but BAT file in system32 directory and use System32 as your working directory.
     
Thread Status:
Not open for further replies.