Shell32.dll (USB Errors)

Discussion in 'Acronis True Image Product Line' started by starsfan09, Mar 4, 2008.

Thread Status:
Not open for further replies.
  1. starsfan09

    starsfan09 Registered Member

    Joined:
    Jun 10, 2006
    Posts:
    352
    Hello guys, was wondering if anyone can help me figure this problem out. This problem only occurs when RESTORING and Image using the Acronis 11 Boot Disc. (Does not happen when using the Acronis 10 Boot Disc)

    After restoring an Image with ATI 11 Boot Disc, I can't right click to disconnect any USB device using the Icon that appears on the system tray (near the clock). When I try to disconnect the device, I get the message below in STEP 2. After clicking OK, the message goes away, and the device disappears from the "Safely Remove Hardware" screen. I have to disconnect or power off the device. I can plug the device right back up with no problems, but get the messages again when I try to disconnect the device again.
     

    Attached Files:

    Last edited: Mar 4, 2008
  2. K0LO

    K0LO Registered Member

    Joined:
    Mar 9, 2006
    Posts:
    2,591
    Location:
    State College, Pennsylvania
    Yes, this issue has been discussed extensively in this long thread. See post #106 for the quickie solution.
     
  3. starsfan09

    starsfan09 Registered Member

    Joined:
    Jun 10, 2006
    Posts:
    352
    Thanks Kolo for the solution. I searched and searched and couldn't find a thread on this matter. Probably didn't word it right. But anyways, the steps Shieber suggested worked great, and solved the problem.
    They should put out an update to take care of this minor problem, but we all know Acronis. :rolleyes: :rolleyes:

    Here's a picture of Shieber's solution that works so no one will have to search. ;)
     

    Attached Files:

  4. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello all,

    Thank you for choosing Acronis Disk Backup software

    We're going to release the special utility to fix this issue. Most probably it would be available next week.

    Thank you.
    --
    Michael Levchenko
     
  5. starsfan09

    starsfan09 Registered Member

    Joined:
    Jun 10, 2006
    Posts:
    352
    Are you saying an update is coming out soon, or a patch is coming out?

    Since I use only the Boot CD to make Backups...should I wait for an actual update to come out before using the 8053 version. I'm wanting to reinstall Windows, but I'm afraid of using this current 8053 Boot CD to make a Full Image.

    Since it causes a problem when RESTORING an image, I'm now thinking that it does NOT include these drivers in the actual image CREATED. I don't feel comfortable making an Image with 8053...and then having to run a patch AFTER restoring an image.

    Has anyone CREATED a FULL Image using the ATI 11 Boot CD...and then used the ATI 10 Boot CD to RESTORE that particular image? This would determine if the drivers are actually included in an image made by the ATI 11 Boot CD. Just thought I'd ask because I may do it IF no one has.
     
  6. starsfan09

    starsfan09 Registered Member

    Joined:
    Jun 10, 2006
    Posts:
    352
    any updates for this known issue yet? if so, where do you get it? :doubt:
     
  7. Xpilot

    Xpilot Registered Member

    Joined:
    May 14, 2005
    Posts:
    2,318
    TI 11 can recognise and work with TI 10 images. TI 10 cannot see or work with TI 11 images. So what you are proposing would not work.

    Xpilot
     
  8. starsfan09

    starsfan09 Registered Member

    Joined:
    Jun 10, 2006
    Posts:
    352
    I'm just wondering if restoring a TI 11 Boot CD Full image with the TI 10 Boot CD ...would solve this Shell32.dll error. Why can't TI 10 Boot CD recognize TI 11 images? o_O
     
  9. Bruce Mahnke

    Bruce Mahnke Registered Member

    Joined:
    May 21, 2005
    Posts:
    629
    Location:
    Woodbury, MN USA
    What Xpilot stated is true, it won’t work. True Image is backward compatible for at least one version it is said. It is not forward compatible.
     
  10. david63

    david63 Registered Member

    Joined:
    Mar 26, 2008
    Posts:
    2
    Hello, when the patch to correct this error be will available? thank you
     
  11. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello all,

    Thank you for choosing Acronis Disk Backup software

    I've contacted our Development Team and was provided with the information that the issues was recently fixed and most probably it would be included into the next build of Acronis True Image 11 Home.

    Thank you
    --
    Michael Levchenko
     
  12. starsfan09

    starsfan09 Registered Member

    Joined:
    Jun 10, 2006
    Posts:
    352
    yeah, probably the version in which they charge to upgrade to ATI 12? :mad:
     
  13. OzRon

    OzRon Registered Member

    Joined:
    Mar 10, 2006
    Posts:
    40
    Location:
    The land of Oz
    Perhaps too late to help starsfan09, but for the sake of any others still waiting for the fix to be made available...

    IMHO, and with appropriate kudos to shieber for posting the first solution, and to k0lo for mentioning it, BitBasher's post #117 (Thread: Error removing USB devices after cloning) is an even simpler solution if regedit doesn't scare you.
     
  14. shieber

    shieber Registered Member

    Joined:
    Oct 27, 2004
    Posts:
    3,710
    Thanks for the thought but forum member "Controler" first posted that he tried the generic drive device update and it appeared to fix the problem. Others tried variations (anything that causes the drive name string to be updated will work) but Controler's was method the simplest, easiest, and quickest workaround. He has a few posts in the thread "Error removing USB devices after cloning" that might help one see how he came upon the driver update fix.


    Bitbasher is probably getting closer to the cause of the problem but I still find Controler's workaround a little faster to do. But whatever you like; it's nice to have some options.

    It's curious why that registry string apparently gets truncated (losing it's proper terminator). What? ASCII Z strings? ;-)

    good luck all,
    sh

     
  15. OzRon

    OzRon Registered Member

    Joined:
    Mar 10, 2006
    Posts:
    40
    Location:
    The land of Oz
    Thank you Shieber. And apologies to Controler who deserves equal mention. I stand corrected.

    Good to see the number of people that have contributed to this. Sad to think of the cumulative time that must have been spent on it. I don't expect any software to be perfect. But it's disappointing that it took Acronis nearly a year to acknowledge/announce a fix (which is still not available to us mere mortals).

    We soldier on...
     
  16. starsfan09

    starsfan09 Registered Member

    Joined:
    Jun 10, 2006
    Posts:
    352
    Any news on this "Shell32.dll" update? Although the workaround does seem to solve the problem, (thank you Controler & BitBasher)...there should still be a fix from Acronis for this problem.
     
  17. shieber

    shieber Registered Member

    Joined:
    Oct 27, 2004
    Posts:
    3,710
    We've been waiting for the "next build" for five months.
     
  18. jfrogman

    jfrogman Registered Member

    Joined:
    Aug 16, 2004
    Posts:
    2
    An exception occurred while trying to run "shell32.dll, Control_runDLL hotplug.dll" and Acronis True Image

    There is no need for a windows repair.
    The quick solution to this is explained in the following link

    http://forums.speedguide.net/showthread.php?t=233888

    continue to update drivers for each drive (partition) until problem is resolved, start at the bottom
     
  19. shieber

    shieber Registered Member

    Joined:
    Oct 27, 2004
    Posts:
    3,710
    Yes, that thread is reporting the fix that was reported earlier in this thread. ;-)

    Also, not that you should generally be able to see which Generic Driver is "wonky" in the Device Manger listing since because it's apprarently missing the string-terminating code, oddbal characters will be included near the end of the name string.

     
Thread Status:
Not open for further replies.