Sharing specific port in automatic mode

Discussion in 'ESET Smart Security' started by kleptes, Feb 22, 2008.

Thread Status:
Not open for further replies.
  1. kleptes

    kleptes Registered Member

    Joined:
    Dec 4, 2007
    Posts:
    3
    Hello;

    I want to use ESS 3.0.621 Firewall in Automatic mode but at the same time I want to do a specific sharing. (for example sharing media to a wireless TV in my case, users may have different things)

    Automatic mode does not allow this specific sharing so to overcome this I change it to interactive mode write a specific port rule or let the system ask me first, then allow it (I tried both of them in several occasions) and change back to automatic mode. Does not work.

    I know that in interactive mode I can do it but need to allow specific port in automatic mode.

    I think made myself clear.

    Any suggestions?

    Thanx in advance
     
  2. Jdeane

    Jdeane Eset Staff

    Joined:
    Jul 18, 2007
    Posts:
    82
    Location:
    UK
    switching back to Automatic causes the firewall to ignore the rules created in Interactive mode.

    Open the Eset interface and press F5 to open the advanced menu
    navigate to the Firewall section and change the firewall to Policy mode this switches it to Automatic mode while also using the interactive rules.
     
  3. kleptes

    kleptes Registered Member

    Joined:
    Dec 4, 2007
    Posts:
    3
    Thanks I've thought about it.

    But I think in that case firewall will deny everything from my pc to out unless I wrote rules, isn't that correct.
     
  4. Jdeane

    Jdeane Eset Staff

    Joined:
    Jul 18, 2007
    Posts:
    82
    Location:
    UK
    In a nut shell:-

    Automatic mode: allows all out going and blocks incoming activity if unsolicited

    Interactive: rule based incomming and out going

    Policy mode: Automatic with incoming rules
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    If you want the firewall behave like in automatic mode, switch to the policy-based mode, enable the rule "Block all unknown inbound traffic" and disable "Block all unknown outbound traffic". These are the most general rules so any other rule you have created will take precedence over them.
     
  6. kleptes

    kleptes Registered Member

    Joined:
    Dec 4, 2007
    Posts:
    3
    Ok, this may work I feel like stupid now. :gack:
     
Thread Status:
Not open for further replies.