Serious problem with ESS 4.0 Web access protection

Discussion in 'ESET Smart Security' started by elyoh, Jan 7, 2010.

Thread Status:
Not open for further replies.
  1. elyoh

    elyoh Registered Member

    Joined:
    May 26, 2009
    Posts:
    20
    I'm experiencing an issue with ESS 4.0 which is preventing access to a bank website. There was no log entry or message indicating that ESS was the cause. I can reproduce the issue on 2 separate machines running Windows 7 x64 Professional with ESS 4.0.074.0.

    I have to add the web site to the "List of addresses excluded from filtering" in the HTTP Address management section.

    Please can someone advise as this behavious is not ideal. ESS should not be blocking access to a reputable banking site without logging the blocked connection.
     
  2. ronjor

    ronjor Global Moderator

    Joined:
    Jul 21, 2003
    Posts:
    57,802
    Location:
    Texas
    Which bank?
     
  3. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,376
    Do you have SSL scanning enabled or disabled?
     
  4. elyoh

    elyoh Registered Member

    Joined:
    May 26, 2009
    Posts:
    20
    The "SSL protocol checking" option is set to "Do not scan SSL protocol".

    Also, I was able to access the site fine up until a few days ago when ESET started blocking access.

    Thanks
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,376
    Please PM me a link to the bank website.
     
  6. elyoh

    elyoh Registered Member

    Joined:
    May 26, 2009
    Posts:
    20
    It's also occuring in EAV 4.0.474.0.
     
  7. RyanH

    RyanH Eset Staff Account

    Joined:
    Nov 9, 2009
    Posts:
    64
    Try adding the site to the allowed list:

    Open the main program window by clicking the ESET icon next to the system clock or by clicking Start →All Programs → ESET → ESET Smart Security or ESET NOD32 Antivirus.

    Press the F5 key to open the Advanced Setup window.

    From the Advanced Setup tree on the left, click Web access protection →HTTP, HTTPS → Address management.

    Select from the pull down menu, "List of allowed addresses" option.

    Click Add to individually add the addresses you want to allow users to access. For each website, be sure to either include "www." or a wildcard "*" symbol, as in "www.eset.com" or "*eset.com". Click OK to close the window and then click OK again to exit the Advanced Setup window.
     
  8. elyoh

    elyoh Registered Member

    Joined:
    May 26, 2009
    Posts:
    20
    @RyanH Thanks for that. I tried those options and it does allow access when I add an exception. But why is ESS and EAV active protection blocking access to the site? Surely it is some bug as the blocked site is a mainstream banking website! It's also wrong that ESS/EAV is blocking the site but not logging it as blocked or providing any sort of notification. It was purely chance that I discoved ESS/EAV was the cause.

    I have also found that this issue is not occuring in EAV 3.
     
  9. elyoh

    elyoh Registered Member

    Joined:
    May 26, 2009
    Posts:
    20
    It now appears this problem is fixed.
     
Thread Status:
Not open for further replies.