Self-defense Bug in ESS 6 final

Discussion in 'ESET Smart Security' started by ahmad0, Jan 21, 2013.

Thread Status:
Not open for further replies.
  1. ahmad0

    ahmad0 Registered Member

    Joined:
    Jun 16, 2012
    Posts:
    9
    Location:
    Egypt
    Hello :)

    The bug is:
    After finishing program installation.. Everything is OK with self-defense except one thing.. i.e. I can't end egui.exe & ekrn.exe processes from task manager and this is good.
    But when I open CMD and type:

    SC Config ekrn start= disabled

    It says "Success" although it should tell me "Access is denied".
    And this will cause ekrn service not to start in the next boot.
    What is the benefit of self-defense if it can't protect itself from being disabled?!
    =================

    I found this bug in the final version of ESS "6.0.306.0"
    It wasn't in the previous RC version of ESS "6.0.115.0"

    Also I found it in the last version of ESS "5.2.15.0"
    It wasn't in the previous version of ESS "5.2.9.1"

    Please, fix that..
    P.S. I'm running Windows XP SP3 updated till Jan. 2013

    Thanks. :D
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Are you able to reproduce it if you restart the computer after installation?
     
  3. ahmad0

    ahmad0 Registered Member

    Joined:
    Jun 16, 2012
    Posts:
    9
    Location:
    Egypt
    I can set it to Disabled & reset it to Auto at anytime after installation and restarting.

    What I mean is that even when self-defense is enabled, I can change the startup type of ekrn service as I want. And this is defect in self protection.
    And this wasn't found in the previous versions !!
    So, what has changed ?!!

    Thanks for replying. :)
     
    Last edited: Jan 21, 2013
  4. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Do you mean that you can reproduce the problem as follows?
    - install v6
    - run update
    - restart the computer
    - run "sc config ekrn start= disabled"
     
  5. ahmad0

    ahmad0 Registered Member

    Joined:
    Jun 16, 2012
    Posts:
    9
    Location:
    Egypt
    Oh sorry, forgive me.

    Yes, I did as you say many times ..
    - Installed the version with the problem "6.0.306.0".
    - Run Update.
    - Restart.
    - run "sc config ekrn start= disabled"
    - The same result. "SUCCESS"

    - Uninstalled the program.
    - restarted.
    - Installed the RC version "6.0.115.0"
    - Either before running update or after.
    - Either before restarting or after.
    - run "sc config ekrn start= disabled"
    - "Access is denied"

    - Uninstalled the program.
    - restarted.
    - Installed the version with the problem again "6.0.306.0".
    - Run Update.
    - Restart.
    - run "sc config ekrn start= disabled"
    - The same result. "SUCCESS"

    I kept trying since release of version 5.2.15.0 which has the same problem.

    Many many thanks.
    Be always well and safe. :)
     
  6. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Ok, check and make sure that the HIPS module was updated to v. 1065 after installation.
     
  7. ahmad0

    ahmad0 Registered Member

    Joined:
    Jun 16, 2012
    Posts:
    9
    Location:
    Egypt
    OK, I'll install the latest version "6.0.308.0"
    And check the HIPS module version and get back to you with updates.
    Because I'm running the RC version now.
    :)
     
  8. ahmad0

    ahmad0 Registered Member

    Joined:
    Jun 16, 2012
    Posts:
    9
    Location:
    Egypt
    Sorry for being late.. I have a very bad processor and a very bad internet speed, and I was waiting until doing all tests I know to be sure.

    Thanks, man.
    You showed me a new way to search in, that didn't come on my mind before.

    I found the cause from what you said..
    The cause is the version of HIPS module NOT the program itself.

    The version of HIPS module in the RC version 6 was 1052 (OK).
    The version of HIPS module in the final version 6 was 1058 (problem).
    The last version of HIPS module after updating is 1065 (OK).

    Finally, sorry for naming the post "BUG".. :oops:
    If you can rename it to "Problem with Self-Defense", this will be better.
    =====================

    One more demand:
    Why removing the option: "Show protection timeout dialog"
    Please, I used to disable this option.. Is it a similar way to do this now with the new final release?

    Thanks a lot for your patience and cooperation.. I appreciate that very much.
    :)
     
  9. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    We'll do our best to bring this option back as soon as possible.
     
  10. ahmad0

    ahmad0 Registered Member

    Joined:
    Jun 16, 2012
    Posts:
    9
    Location:
    Egypt
    Thanks a lot. :)

    The last thing I need and really, a big thank you from my heart for your time..

    Please, do you know any way to set exception for many web pages in parental control by writing them all together once, instead of writing every web page individually?

    And this was a problem in ESS v5 that doesn't exist anymore in v6 .. Was there any solution for it?
    https://www.wilderssecurity.com/showthread.php?t=326328
    It really doesn't matter to me..
    I'm just reporting a possible bug, and I want to know whether it has a solution or not.

    I wish you all the best.
    Be always well and safe.
    :)
     
    Last edited: Jan 25, 2013
Thread Status:
Not open for further replies.