Search Add-On issues !

Discussion in 'Prevx Releases' started by CloneRanger, Nov 4, 2013.

Thread Status:
Not open for further replies.
  1. CloneRanger

    CloneRanger Registered Member

    Joined:
    Jan 4, 2006
    Posts:
    4,833
    v8.0.4.24

    I got an alert from my FW that WSA wanted its Server Program to access the internet, which i allowed.

    A few seconds later my FF Add-ons page auto launched showing that the following had tried to install.

    ff-wsa.png

    Obviously it couldn't as it's incompatable. But i received NO warning that WSA was going to do that, & hence gave NO permission for it to do so.

    1 - Why ?

    2 - What's the best way to get rid of it, as i can't from my Add-ons page ?
     
  2. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
    It is part of the new web filtering, which is being discussed at length here.

    It seems you have a very old version of Firefox running; I would strongly suggest updating to the latest one, or at least one much later than v3.6.14.
     
  3. CloneRanger

    CloneRanger Registered Member

    Joined:
    Jan 4, 2006
    Posts:
    4,833
    @ TonyW

    Thanks, i realise those points, but would like an official explanation to my questions.
     
  4. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
    I don't know the answer to the incompatibility issue with an older version of Firefox, but I'm sure Joe will help here.

    As to an official answer about the filtering extension, it's been known now for some time that the new 2014 web filtering will request the installation of the extension in supported browsers as well as creating a new WRUrl folder in WRData. This is being rolled out slowly so not everyone has this yet.
     
  5. CloneRanger

    CloneRanger Registered Member

    Joined:
    Jan 4, 2006
    Posts:
    4,833
    @ TonyW

    Yeah PH should know ;)

    Anyway i don't want the Add-On, even if it was compatable. As it isn't, i want to know how to delete the entry ?

    Plus i got NO ask for it ? :thumbd:
     
  6. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
    I would've thought the 'asking' is when you're presented with the extension request; you can choose to install it or not. (I know your problem is different, but I'm referring to compatible builds.)

    By extension request, I mean that the next time you open the supported browser after the web filtering update has been downloaded automatically in the background, you should be presented with the option to install the add-on or not.
     
  7. PrevxHelp

    PrevxHelp Former Prevx Moderator

    Joined:
    Sep 14, 2008
    Posts:
    8,242
    Location:
    USA/UK
    Every browser today prompts for addons being installed so we felt it was superfluous to ask again. They will show that it is validly signed and comes from Webroot, so there shouldn't be any issue.

    I'd strongly suggest updating your Firefox build as there are considerable security improvements in the last 20+ versions.

    From the screenshot, it looks like it's already disabled so it won't load. If it is still showing in the list, I imagine that is a Firefox bug.
     
  8. CloneRanger

    CloneRanger Registered Member

    Joined:
    Jan 4, 2006
    Posts:
    4,833
    @ PrevxHelp

    As i've mentioned before, i'm very happy with FF v3.6.14. Plus some Add-ons i have don't work on much later versions !

    I already know that, & pointed it out earlier.

    It may or not be, but that's not the issue. WSA should check/confirm which version of FF i'm using, BEFORE trying to install Anything. Obviously it does not, and/or did not in this case. That's why i have a failed install showing. I asked how to remove it, & am still waiting to hear how ?
     
  9. TonyW

    TonyW Registered Member

    Joined:
    Oct 12, 2005
    Posts:
    2,634
    Location:
    UK
  10. CloneRanger

    CloneRanger Registered Member

    Joined:
    Jan 4, 2006
    Posts:
    4,833
    @ TonyW

    Thanks for the link, i'll try it.

    @ PrevxHelp

     
  11. PrevxHelp

    PrevxHelp Former Prevx Moderator

    Joined:
    Sep 14, 2008
    Posts:
    8,242
    Location:
    USA/UK
    I will see what our minimum compatibility is but I believe it is Firefox 4.0+ We haven't had any other users on Firefox 3.x as far as I'm aware so this should be a pretty rare case to run into.
     
  12. CloneRanger

    CloneRanger Registered Member

    Joined:
    Jan 4, 2006
    Posts:
    4,833
    @ PrevxHelp

    OK. Well apart from the Web Filter issue, which i don't need anyway, WSA works fine on my comp :)
     
Thread Status:
Not open for further replies.