Seagate Momentus XT problem

Discussion in 'hardware' started by DVD+R, Jun 18, 2011.

Thread Status:
Not open for further replies.
  1. DVD+R

    DVD+R Registered Member

    Joined:
    Aug 2, 2006
    Posts:
    1,979
    Location:
    The Antipodes
    I bought a Seagate Momentus Hybrid HD 500G for my Toshiba A660. At first I was doing a clean install of Windows 7 64 Professional, and it seemed to be working up to the point where you choose which drive to Install the system on. I clicked on the unpartitioned drive and then I waited.....and waited ... and waited, nothing happening except the rotating circle indicating the system was doing something. after 20 minutes still no further than this point, so i hard rebooted, and then my Toshiba dosent even start, I get past the Toshiba Bios Screen then it stays on the cursor blinking top left screen, and nothing further, It wont even let me enter bios setup, it hangs forever. Everythings back to normal when i reinstall my previous hard drive, I read elsewhere there was problems with this drive, but some people managed to get it to work, can anyone elaborate or give me some tips on how to fix this, or should I just return it to the store, and get my $155 back?
     
  2. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
    My laptop has this drive, which I am typing from. Here are some suggestion.

    1. If you have any USB dock and/or cover. Put the drive in that.

    2. Boot your Toshiba and then connect the USB Seagate Momentus Hybrid HD 500G.

    3. Is it now recognized by your computer. If yes, you have a good drive. Format it.

    4. Upgrade the firmware on the Seagate Momentus Hybrid HD 500G to the latest version SD25.

    BTW 1, you need the ACHI in BIOS to be set to on for the Seagate Momentus Hybrid HD 500G to work.

    BTW 2, I also have Windows 7 x64 on my laptop.

    BTW 3, I paid about USD 89/- for this drive about 2 months ago.
     
    Last edited: Jun 18, 2011
  3. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
  4. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
  5. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
    Last edited: Jun 18, 2011
  6. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
  7. DVD+R

    DVD+R Registered Member

    Joined:
    Aug 2, 2006
    Posts:
    1,979
    Location:
    The Antipodes
    So heres the thing, i dont have a USB dock, so next sugestion please. Also I tried to enter bios setup again,and after about 4-5 minutes, bios setup page will load, and the bios clearly shows the Seagate Hard drive ST95005620AS but when I try booting to it the system still hangs, I tried using Acronis from a backup of my other drive but the CD drive wont respond. All this time the hard drive light on the toshiba is solid, not flickering like when loading data, and a few times the cd drive will try to start but is having a huge struggle, I'll take it into the store on Monday and see if they can get this fixed, but usually they want $90 just to look at the pc, If thats the case they can Sod Off and I'll insist on a refund.
     
  8. aladdin

    aladdin Registered Member

    Joined:
    Jan 9, 2006
    Posts:
    2,986
    Location:
    Oman
    You seems to have lots of money, and maybe a trip to the nearest charity should be in works.

    Take the drive back for which you paid $155, and most probably is defective. You can buy one for $90 at Newegg.com with shipping included. You will save $65. For less than $10, including shipping you can buy a USB enclosure, and even if you want to buy a USB dock it is less than $19.

    Use your head rather than your money, and use the charity function once a while.
     
  9. DVD+R

    DVD+R Registered Member

    Joined:
    Aug 2, 2006
    Posts:
    1,979
    Location:
    The Antipodes
    Got into Windows Install, but..... it says windows cannot be installed on this disk as your bios settings are incorrect, wtf theres only 2 setting ACHI or whatever it is, and compatibility, and they both wont work
     
Loading...
Thread Status:
Not open for further replies.