Scheduled tasks in Paragon Backup & Recovery™ 10 Suite

Discussion in 'Paragon Drive Backup Product Line' started by denniz, Nov 21, 2009.

Thread Status:
Not open for further replies.
  1. denniz

    denniz Registered Member

    Joined:
    Jul 26, 2007
    Posts:
    431
    Location:
    The Netherlands
    Would it be possible to add an option to reschedule a task after it has been missed, for example when I have set a daily backup (after I've been logged on) to be run at 19:00 hours, but when I login at 20:00 hours that the scheduled task will still run and won't wait until the next day at 19:00 hours?'

    It would also be nice that during the configuration of a daily schedule there could be an option included to auto-minimize the progress window so that the backup progress goes more transparant.
     
    Last edited: Nov 21, 2009
  2. SIW2

    SIW2 Registered Member

    Joined:
    Sep 6, 2009
    Posts:
    1,572
    Hi in denniz,

    in Task Scheduler, rt click the Task, Properties>Settings

    RUN TASK IF SCH MISSED-2009-11-21_150331.jpg

    Hope it helps.
     
  3. denniz

    denniz Registered Member

    Joined:
    Jul 26, 2007
    Posts:
    431
    Location:
    The Netherlands
    Yeah, but when I do that then the scheduled task in Paragon disappears, allthough it still appears it the Windows Task Scheduler itself.

    paragon.jpg
     
  4. nice_guy

    nice_guy Registered Member

    Joined:
    Feb 15, 2006
    Posts:
    28
    same thing in B&R Free. Must be a bug.
     
    Last edited: Nov 21, 2009
  5. SIW2

    SIW2 Registered Member

    Joined:
    Sep 6, 2009
    Posts:
    1,572
    Hi denniz,

    How were you able to tick "Run task as soon as possible after Scheduled start is missed".

    It is greyed out for me - and no Edit option for Settings in Windows Task Manager.

    Did you recreate it from scratch in Task Scheduler?

    Did anybody try and see if it Paragon will run anyway - if the scheduled start time is missed?
     
  6. denniz

    denniz Registered Member

    Joined:
    Jul 26, 2007
    Posts:
    431
    Location:
    The Netherlands
    After creating the task in Paragon, in the Windows Task Scheduler I right clicked the task for Paragon and then choose Properties/Options/Settings (I have a Dutch version of Windows 7, so I don't know the exact name in the english version of Windows 7)

    I also changed the setting to configure the task for Windows 7, instead of Windows 2008/Vista.

    Doing it this way, the option wasn't greyed out for me.
     
  7. SIW2

    SIW2 Registered Member

    Joined:
    Sep 6, 2009
    Posts:
    1,572
    I just tested it. If you miss the scheduled start time - it won't run.

    If you set it up yourself - like you did in Task scheduler - then it should run , as long as it points at a script in the Paragon scripts folder.
     
  8. denniz

    denniz Registered Member

    Joined:
    Jul 26, 2007
    Posts:
    431
    Location:
    The Netherlands
    To be honest, I think it's rather silly that an advanced backup program like Paragon still has such a limited scheduler. Also I don't think it should be necessary that the end-user must resort to the Windows Task Scheduler to set more advanced options.
     
  9. SIW2

    SIW2 Registered Member

    Joined:
    Sep 6, 2009
    Posts:
    1,572
    I think we already established it is a bug /oversight of some kind. Pretty sure it is not intended to be like that.
     
  10. denniz

    denniz Registered Member

    Joined:
    Jul 26, 2007
    Posts:
    431
    Location:
    The Netherlands
    I'd like to know if Paragon is considering this as a bug also?
     
  11. Paragon_Tommy

    Paragon_Tommy Paragon Moderator

    Joined:
    Aug 10, 2009
    Posts:
    918
    I'll ask the devs to take a look at this. It's not behaving the same way for me with Windows XP, so I'd imagine it's only for Vista/7.

    XP doesn't have "Run task as soon as possible after Scheduled start is missed" it seems.
     
Loading...
Thread Status:
Not open for further replies.