Scheduled tasks do not run

Discussion in 'Paragon Drive Backup Product Line' started by Slaycock, Nov 17, 2010.

Thread Status:
Not open for further replies.
  1. Slaycock

    Slaycock Registered Member

    Joined:
    Mar 17, 2007
    Posts:
    33
    I am using Backup and Recovery Free edition. I have a backup task scheduled to run at 2:12 am. If the PC is not already on the BIOS wakes the PC at 2am.

    The scheduled task was setup to run with my id and password.

    If the PC is switched off then after booting at 2am, the scheduled task runs fine at 2:15am. If I leave the PC on overnight just idling, the scheduled task does not run.

    What do I need to do to ensure that the scheduled task runs if a leave my PC on.

    PS I bought Hard Disk manger suite for the partitioning stuff.
     
  2. JosephB

    JosephB Registered Member

    Joined:
    Jan 3, 2008
    Posts:
    310
    Slaycock,

    Is your pc set to go into Standby/Sleep Mode ? ... If so, is it not waking up from standby mode to execute your scheduled paragon backup ?

    P.S. Did my keyword syntax suggesstion make your Exec Script work o_O
     
  3. Slaycock

    Slaycock Registered Member

    Joined:
    Mar 17, 2007
    Posts:
    33
    OK. I'll turn of sleep mode and see if things improve. I've responded seperately to the other matter.
     
  4. JosephB

    JosephB Registered Member

    Joined:
    Jan 3, 2008
    Posts:
    310
    Since, you do have Sleep/Standby Mode Enabled for your pc, I think that all you should need to do is to go to the Windows Task Scheduler - Task that corressponds to your Scheduled Paragon Script and Check "On" the Option "Wake computer to run this task" (based on Win XP Task Scheduler, Vista/7's task scheduler should have a similiar option)
     
  5. Slaycock

    Slaycock Registered Member

    Joined:
    Mar 17, 2007
    Posts:
    33
    I turned off sleep/standby mode. The behaviour stayed the same. If the PC is off the pc boots and then the task runs fine. If tyhe PC is on, the task doesn't run.

    The task is set to run under my id and password so there should be no problems.
     
  6. Mech_An

    Mech_An Registered Member

    Joined:
    Mar 29, 2010
    Posts:
    855
    Slaycock,

    Please try to disable Hibernation mode separately:
    1. First go to Control Panel/System and Security/Power Options.
    2. Click on Change plan settings link of the active power plan.
    3. Click on Change advanced power settings link.
    4. Expand the Sleep tree.
    5. In the drop down box of Allow Hybrid Sleep, select Off as new setting to disable and turn off Hybrid Sleep.
    6. Set the value of the Hibernate after setting to 'Never'
    Save changes.
     
  7. Slaycock

    Slaycock Registered Member

    Joined:
    Mar 17, 2007
    Posts:
    33
    When I switched of sleep mode I made sure that the PC would be permanently awake so your request to switch of hibernate mode has already been met.

    From my other post I think that when I deleted the --graph statement from the command line something strange happened as the scheduled tasks that were edited via windows scheduler disappeared from the scheduled task list in Backup and Recovery.

    I've since added them back as scheduled tasks (original versions with --graph) and they are now running again when the PC boots at 2am.

    Haven't yet tried leaving the PC on.
     
  8. JosephB

    JosephB Registered Member

    Joined:
    Jan 3, 2008
    Posts:
    310
    I can not understand why your tasks stopped running when you removed the --graph switch.
    ..... Unless, the Free version works differently from the paid version. I am using B&R 10 Home and run without the --graph switch and run the script command line with its switches thru a 3rd party task scheduler and the script task executes and the script output is displayed in the windows console/command prompt, on a win xp pc. Perhaps, the free version does not support non-gui execution or perhaps there was a chance that a syntax error was introduced, when you removed the --graph switch ?

    .... When, you leave the PC on overnight just idling, do you leave the pc logged on to your userid with the workstation locked or are you logging off the pc. ... If you are logging off the pc, I think you either need to keep pc logged on and just lock the workstation --- OR --- under Windows Task scheduler for thr task supply a userid and a password and also "Disable/UN-Check" - the Option of "Run only if logged on" (based on win xp).
     
    Last edited: Dec 5, 2010
Loading...
Thread Status:
Not open for further replies.