Saving Firefox Passwords in Linux

Discussion in 'all things UNIX' started by Oremina, Oct 8, 2009.

Thread Status:
Not open for further replies.
  1. Oremina

    Oremina Registered Member

    Joined:
    Mar 28, 2004
    Posts:
    209
    Location:
    England
    Have had a hankering to try Linux for some time now but only decided to try it a week ago. Early days. Read up as much as I could about it on this forum, particularly Mrkvonic's brilliant website and various Linux websites (Ubuntu and Mint).

    I first installed Ubuntu 9.04, tried that for a few days then uninstalled it and replaced it by Linux Mint 7. I have been surprised to find out how much less painless it was than I expected, but there is one problem that has been driving me insane, to such an extent that I removed Mint (and immediately regretted it).

    That problem is this..... I can't make Firefox 3.5.3 remember passwords. I can find out very little about the problem on the internet and what I have seen is a bit beyond me or didn't work. Is there a simple solution that will persuade me to try again? Am I missing something simple?
     
  2. 0eighter

    0eighter Registered Member

    Joined:
    Apr 5, 2009
    Posts:
    3
    Last edited: Oct 8, 2009
  3. chronomatic

    chronomatic Registered Member

    Joined:
    Apr 9, 2009
    Posts:
    1,343
    Just use the "lastpass" add on. It will create secure passwords for each site you request. All you have to remember is one master password.
     
  4. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    8,699
    Hello,

    Thanks for the compliments.

    Do not give up too quickly. Think about how many years you've used Windows, two, three, ten? Even if you give Linux just 1% slack you give Windows, for a decade, this is 5-6 weeks of 24/7 usage.

    From what you describe, the problem seems FF related. Did you try creating a new profile? Furthermore, did you test any of the password-related addons available?

    Mrk
     
  5. Oremina

    Oremina Registered Member

    Joined:
    Mar 28, 2004
    Posts:
    209
    Location:
    England

    Thanks Oeighter. That was my very first thought. Although I certainly don't consider myself an expert on Firefox I have been using it almost exclusively since it was Firebird 0.61 - over six years ago and I do know my way round it pretty well. The default version that comes with Ubuntu 9.04 and Mint Gloria is Fx 3.0.8. Wouldn't remember passwords on either. So in both cases I updated to Fx 3.5.3 with exactly the same lack of success.

    I use Fx 3.5.3 on both my Desktop and Laptop (Vista Ultimate) and used exactly the same settings (checked time and again) on both flavours of Linux.

    I am familiar with both the URL's you quoted - neither helped here. When I submitted a password to a site, it worked but Fx didn't offer to save it for me. At the moment I'm stumped but I'll give it another try over the weekend.
     
  6. Oremina

    Oremina Registered Member

    Joined:
    Mar 28, 2004
    Posts:
    209
    Location:
    England
    Thanks chromatic, I may go the way of Lastpass or KeePassX eventually but I'll give the Fx password manager another whirl or two first. I did briefly try KeePassX (I use KeePass on my Windows machines) but it appears they aren't compatible and the thought of typing in all those complicated passwords rather than being able to import them was offputting....although I was tired.
     
  7. lewmur

    lewmur Registered Member

    Joined:
    Dec 22, 2008
    Posts:
    332
    Open FF. Click /Edit/Preferences and then the Security Tab. Check the Remember Passwords box. Problem solved.
     
  8. Oremina

    Oremina Registered Member

    Joined:
    Mar 28, 2004
    Posts:
    209
    Location:
    England
    Thanks lewmur...... not that simple I'm afraid, that was the very first thing I checked. I'm now fairly sure from the answers I've received that the problem probably is Fx based rather than Linux. I'll come back to it in a day or two and take it step by step.
     
    Last edited: Oct 8, 2009
  9. Oremina

    Oremina Registered Member

    Joined:
    Mar 28, 2004
    Posts:
    209
    Location:
    England
    I won't give up, you are quite right in that I couldn't possibly learn as much about Linux in a week as I have about Windows in a dozen years. But I've certainly had a good start on the learning curve.

    It was a fresh, new profile. I may try the password-related addons at a later stage but at the moment am determined to try and get to the bottom of my problem. I'll give it a fresh start over the weekend and try not to get too far ahead of myself.... one step at a time. I'll keep trying. After all, I have 215Gb spare on my HD, I may as well use it for something. Thanks all.
     
    Last edited: Oct 8, 2009
  10. chronomatic

    chronomatic Registered Member

    Joined:
    Apr 9, 2009
    Posts:
    1,343
    LastPass will automatically import KeePassX passwords.
     
  11. lewmur

    lewmur Registered Member

    Joined:
    Dec 22, 2008
    Posts:
    332
    Did you install FF using the repos or did you download the latest version from Mozilla? If you did the latter, it may be a question of where you put it.

    IMO,you shouldn't be looking for an addon but for the reason it isn't working the way it should. The only reason I can think of is that you don't have write permission for the folder where FF is trying to save the info. This could be because you install FF in a root folder instead of home folder. Is FF saving cookies or other info?
     
    Last edited: Oct 8, 2009
  12. Oremina

    Oremina Registered Member

    Joined:
    Mar 28, 2004
    Posts:
    209
    Location:
    England
    Problem solved. Burnt a bit of midnight oil last night and reinstalled Linux Mint. The problem was with neither Mint or Firefox. I'd got round to thinking it was something very simple that I just couldn't see and that proved to be the case. Hindsight is a wonderful thing.

    I keep something like 35 passwords in the Firefox Password Manager. A few of those are for sites that don't like Fx to store the password. In my Bookmarks folder I keep a sub-folder containing a few (rarely used) bookmarklets. One of those is a bookmarklet called "remember password" which I had almost forgotten about and which forces the password to be accepted. As luck would have it, the first couple of passwords I tried were on sites of that type so Fx didn't offer to save them and I was convinced there was a problem with Linux or Fx. This time I tried them after executing the bookmarklet and voila - success. Everything is now OK and I'm happy.

    Incidentally, the default Fx was 3.0.14 and not 3.0.8 as I stated above. I have now d/l'd Fx3.5.3 direct from Moz and that is working fine, too. (Installed with instructions found on an Ubuntu site that I googled).

    Thanks to all who answered, I may well have given up on Linux if everyone hadn't pointed out that it wasn't a Linux problem...:)
     
Loading...
Thread Status:
Not open for further replies.