Routing and Remote Access problems after de-installing NOD32 + Windows SBS 2008

Discussion in 'ESET NOD32 Antivirus' started by CTO, Oct 20, 2010.

Thread Status:
Not open for further replies.
  1. CTO

    CTO Registered Member

    Sep 3, 2010

    Okay we have some serious problem here with starting the Routing and Remote acces service on Windows 2008 SBS server.

    It all started with a corrupt patch (5418 ) from Eset NOD32 which was installed on our server. After the corrupt patch a lot of problems started with the LAN interface.
    After we removed Eset NOD32 all things started to look ok again . So we reinstalled Eset NOD32 with the new patch with the eset_fix.exe.

    Still there were problems with NOD32, losing LAN connections etc.
    We used the Eset_Uninstaller.exe from ESET to totally remove NOD32 from the server. After that the problems started with the Routing and Remote Access

    We got the error message "Unable to load c:\Windows\System32\iprtrmgr.dll" and event 201013 and 7024 ( The Routing and Remote Access service terminated with service-specific error 31 (0x1F) ).

    After going through internet we found differtent solutions which sadly didn't work

    we tried;

    Removing the Role Routing and Remote access and reinstalling it.

    Resetting the tcp ip [/B]( netsh int reset )

    Removing the registry ( HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess \RouterManagers\Ipv6 )

    Removed phantom adapters (there were none) by using the following tip:

    1 Run the command "set devmgr_show_nonpresent_devices=1"to see all the phantom devices.
    2. Opened Device Manager (Start - Run - devmgmt.msc) and select "View" menu and choose "Show Hidden Devices".
    3. Expand Network Adapters and look for any non-existing network adapters.
    4. Uninstall all the phantom adaptors except RAS Async adapter, WAN Miniport adapters, Microsoft ISATAP Adapter and Microsoft Virtual Machine Bus

    Renamed the ias.xlm and dynary.xml in c:\windows\system32\ias

    Copied the file iprtmgr.dll from another SBS 2008 computer.

    in the router.log (c:\windows\tracing\ we find:

    Error 31 occured during the router manager C initialization.
    RTRMGR is unloaded from DIM
    ServiceMain: Error 31 occured while loading router managers.
    DimUnloadRouterManagers: fAllRouterManagersStopped

    All the above solutions didn't work for us...the Routing and Remote access service still doesn't start.

    We are kinda stuck on the problem here..

    Thanks in advance,

    Last edited by a moderator: Oct 20, 2010
Thread Status:
Not open for further replies.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.