Returnil usage

Discussion in 'General Returnil discussions' started by Rilla927, Jan 17, 2011.

Thread Status:
Not open for further replies.
  1. Rilla927

    Rilla927 Registered Member

    Joined:
    May 12, 2005
    Posts:
    1,710
    Is this normal usage for Returnil when idle, no virtual mode, av disabled.
     

    Attached Files:

  2. Coldmoon

    Coldmoon Returnil Moderator

    Joined:
    Sep 18, 2006
    Posts:
    2,981
    Location:
    USA
    It depends on what is going on in the background. Your image looks to be a background scan or queue upload. Do you have anything in your upload queue? And is this constant or intermittent?
     
  3. Rilla927

    Rilla927 Registered Member

    Joined:
    May 12, 2005
    Posts:
    1,710
    No, nothing in a upload que. This is constant. It's now higher than what I posted.

    After thinking about when I first installed Returnil and then installed the rest of my apps; Returnil wasn't using that much resources, not like this.

    Something I installed is making the usage high. Probably the http scanner in G-Data.
     
    Last edited: Jan 17, 2011
  4. Coldmoon

    Coldmoon Returnil Moderator

    Joined:
    Sep 18, 2006
    Posts:
    2,981
    Location:
    USA
    Try adjusting the real time scanner for G-Data and see if that brings the CPU use down. I am not aware of any issue at this point, but it is conceivable that GD may be "following" RSS around. Also check to see if you have the following RSS option deactivated: Virus Guard > Settings > Advanced > "Automatically rescan..." and let me know if it has any effect on the CPU use.

    Mike
     
  5. Rilla927

    Rilla927 Registered Member

    Joined:
    May 12, 2005
    Posts:
    1,710
    I don't see a way to adjust the scanner. I did uncheck "Automatically rescan" and rebooted and it was normal for a few seconds and then shot back up to 52,000.

    ColdMoon see post #142 (at the bottom of page) This will help explain what I did and found.

    https://www.wilderssecurity.com/showthread.php?t=290090&page=6
     
    Last edited: Jan 17, 2011
  6. Coldmoon

    Coldmoon Returnil Moderator

    Joined:
    Sep 18, 2006
    Posts:
    2,981
    Location:
    USA
    I have updated the team on your report. From what I read in the other thread you linked to, is that the problem appears to be caused by G-Data and not RSS or the Virus Guard component.

    My initial reaction is that you may need to look for a more compatible alternative and report the problem to G-Data's support team for investigation. We will however add their AV to our QC testing program to get a better handle on the root cause.

    Mike
     
  7. cm1971

    cm1971 Registered Member

    Joined:
    Oct 22, 2010
    Posts:
    727
    This must be sort of a common thing. I looked at my own usage after seeing this thread and I'm getting similar numbers when Returnil is idle. I use Avira so it is not just G-Data.
     
  8. Coldmoon

    Coldmoon Returnil Moderator

    Joined:
    Sep 18, 2006
    Posts:
    2,981
    Location:
    USA
    Hi cm,
    Does it happen while the Virus Guard is performing a scan or rescan (ref: rescan after a cloud update)?
     
  9. cm1971

    cm1971 Registered Member

    Joined:
    Oct 22, 2010
    Posts:
    727
    I have checked it several times now and there may be slight fluctuations but it stays roughly the same so the scan or rescan doesn't seem to be a factor.
     
  10. Rilla927

    Rilla927 Registered Member

    Joined:
    May 12, 2005
    Posts:
    1,710
    Correct, I had av disbled and rescan unchecked. Private Firewall HIPS affects Returnil usage as well as G-Data. I tried it both ways. Is what I didn't post back is after the usage of Returnil going back to normal it shot right back up there.

    Returnil is not the problem just the other poorly coded garbage we try to protect our machines with.

    I ended up putting Avira Free on and it affects Returnil the same way. In virtual mode it will be between 46,000-52,000. I'm on Win 7 64bit Home Premium.
     
  11. Coldmoon

    Coldmoon Returnil Moderator

    Joined:
    Sep 18, 2006
    Posts:
    2,981
    Location:
    USA
    Try a test for me - both of you.

    Turn the resident scanner(s) off in either of the alternates you want to test this with and check the CPU use. Does it go down or remain consistent with the previous levels?
     
  12. cm1971

    cm1971 Registered Member

    Joined:
    Oct 22, 2010
    Posts:
    727
    I turned Avira off and checked and there was no difference.
     
  13. Coldmoon

    Coldmoon Returnil Moderator

    Joined:
    Sep 18, 2006
    Posts:
    2,981
    Location:
    USA
    Hello Gentlemen,
    Apologies for the delay in replying as I needed to consult with the development team to get a more accurate reply and feedback for this report. The first thing to note is that the reports are indicating MEMORY use rather than CPU use so that will be addressed below first.

    Scenario 1:
    Possible solutions:
    Returnil processes may allocate more memory in order to speed up their functioning and improve performance. You can fine tune the application's settings however to decrease memory usage, but NOTE that this is not recommended:

    1. Cleanup unneeded or already acknowledged messages in the GUI (Home-> Messages and/or Virus Guard > Log)

    2. Disable Data Collection (Virus Guard > Settings > Data Collection Policy > Do not collect and report any activity)

    In marginal resource cases, a system reboot can help to revert memory usage to initial values.

    Scenario 2:
    Steps to resolve:

    1. Be patient: Wait for reasonable time to allow any background or current operations to complete.

    2. Check to make sure the Quick or Full System Scan is not running. The most likely cause here would be a rescan on update which will initiate a Quick "rescan" with the new signatures and/or Cloud update.

    3. Disable Data Collection (Virus Guard > Settings > Data Collection Policy > Do not collect and report any activity)

    4. Disable Remote Control (Preferences > Communications tab > Remote Control). IMPORTANT NOTE! disabling the Remote Control option will remove your ability to manage your clients in a network setting so please be aware before trying.

    5. Disable Quick Scan after receiving updates (Virus Guard > Settings > Advanced section)

    6. Disable Real-time monitoring: Virus Guard > Real-time Protection and/or System Restore > Overview > Real-time Restore analysis.

    7. Clear your AutoSave List if in use (Virtual Mode > Tools > File Manager > autosave)

    In marginal resource cases, a system reboot can help to clear CPU use and return the values to a lower state.

    Mike
     
Thread Status:
Not open for further replies.