restore lost Partitiontable from true crypt HDD

Discussion in 'backup, imaging & disk mgmt' started by hotor, Apr 5, 2014.

Thread Status:
Not open for further replies.
  1. hotor

    hotor Registered Member

    Joined:
    Apr 5, 2014
    Posts:
    1
    Hello there,

    i have a external WD MyBook 3 TB HDD(WDBACW0030HBK-04). I encrypted the whole device with Truecrypt, when i got it. I used the NTFS Partition set by fabrication and didnt used windows 7 again to have the same result. When i mounted it again after two weeks, it got me the error "Wrong Password...". I restored the header as suggested from True Crypt and could mount the HDD again (Sadly it was only Partition 0), but as RAW Drive.

    So i followed:
    https://www.wilderssecurity.com/showthread.php?t=336671
    It all worked till i wanted to creater the volume with disk management from windows.
    Now the Problem. When Windows initilized the Disk, it asked me if want MBR or GPT. First i have chosen MBR, because I read in the Internet, that it can be used for devices bigger than 2TB if the BlockSize is big enough. But Windows splitted my HDD in two Partitions - one with 2 TB and one with 750GB. So i did right click-->convert to GPT. And it was one big partition again. When i wanted to mount it via TC to restore the header, there were two partitions (Partition 1 (128MB) and Partition 2 (2,7 TB). I never seen the first one, when i bought and encrypted it. I only remember a Partition 1. (Maybe i've forgotten the first one, but im qutie sure the was only one).
    So can i proceed mouting Partition 2 and restore the head or do i need a Programm which only makes a Partition 1 and not two (without windows reserved space). But which one and how. Or is my Data lost now? I've read the last post from the great dantz, but isnt there a way to still do it that way. I dont have the space copying the the data with winhex.

    I'm grateful for any suggestions/advice.

    (sry, if my english is not so good, but i dont use it very often and it still lacks a lot)

    update: Found something new fomr another forum:
    So i need to format it to MBR, but without this mrs (miccrosoft reserved 128MB Space). So maybe i should do it manually with TestDisk and add a partition with LBA 4096Kb. But which Start and End should i chose without damaging the data (true crypt)?

    ----------------------------------BIG GOOD NEW---------------------------------------------------------

    It works again! How did I do it? I've read that WD has cooporation with Acronis. So i thought they use the engine from quick formater is acronis engine. I bought Acronis Disc Director Home and deleted the old volume and created a new primary volume - of course without formating it. Acronis automaticly does the right advance formating for the 4k sectors. I had my old partition back and just needed to restore the backup header from True Crypt and wohooooooo!!! there it was :). But you can still tell me how I could have done it with TestDisk , because a proprietary program shouldn't be the only solution.

    And here is the restored partition table:

    Code:
    Analyse Disk \\.\PhysicalDrive1 - 3000 GB / 2794 GiB - CHS 45599 255 63
    Geometry from i386 MBR: head=255 sector=63
    check_part_i386 failed for partition type 07
    Current partition structure:
    Invalid NTFS or EXFAT boot
    1 * HPFS - NTFS              0   8  9 45599 161  2  732557568
    1 * HPFS - NTFS              0   8  9 45599 161  2  732557568
    
     
    Last edited: Apr 7, 2014
Loading...
Thread Status:
Not open for further replies.