Réseau local, oui mais ?

Discussion in 'LnS French Forum' started by SDKyron, Jan 21, 2008.

Thread Status:
Not open for further replies.
  1. SDKyron

    SDKyron Registered Member

    Joined:
    Jan 21, 2008
    Posts:
    17
    Voilà, comme beaucoup sur ce forum d'après la fonction recherche j'ai des petits soucis avec mon réseau et LnS.

    J'utilise LnS 2.06 avec les règles Phant0m 8.003.

    Les ordinateurs raccordés sur mon réseau se voient attribué des addresses non pas en 192.168.x.x mais 172.19.3.x, donc tout ce que j'ai fait c'est d'importer les 3 règles de partage réseau, remplacer le 192.168.x.x par le 172.19.3.x et remplacé les masques de 255.255.0.0 par 255.255.255.0 étant donné que seulement le dernier nombre change.

    Malheureusement rien n'y fait, ca ne fonctionne pas, LnS coupé tout va bien, LnS en fonction, je ne vois plus aucun pc à partir d'aucun poste, dans ce cas précis, 2 PC, tous les 2 avec la même configuration et règles pour LnS.

    J'ai essayé pendant des heures sans succès, un peu d'aide me serait bien utile.

    Edit: Je pourais ajouter un screenshot du log mais ca n'aiderait pas beaucoup je pense, tout ce que ca dit c'est que la dernière règles "Block all other packet" bloque tout...
     
  2. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Avant de l'installer, édite le fichier ForceConfig.ini.

    Networking=No >> Networking=Yes

    :)
     
  3. SDKyron

    SDKyron Registered Member

    Joined:
    Jan 21, 2008
    Posts:
    17
    Alors ca c'est de l'aide rapide, wow, une petite question ensuite j'essaye ca, vu que les règles sont déjà installée, je fais comment :)
     
  4. SDKyron

    SDKyron Registered Member

    Joined:
    Jan 21, 2008
    Posts:
    17
    Bon ben, c'est bizzare, ca ne marche pas, je ne comprends pas très bien, tout semble correct, j'ai bien réinstallé les règles avec Nerworking=Yes mais rien n'y fait.

    J'ai toujours ce log:
    Block: All other packets
    Type: ETH
    Address: FF:FF:FF:FF:FF:FF
    Additional: Type Ethernet:0054

    Aussi j'ai vu quelque part que celà pouvait avoir un rapport avec l'UPnP port 1900, si c'est le cas comment ajouter une règle qui ne transforme pas le pc en journée porte ouvertes, sachant que je susi un tout nouvel utilisateur et pas du tout familié avec ce système de règles, je ne sais pas du tout comment faire pour qu'elle soit correcte et sécurisée...
     
    Last edited: Jan 21, 2008
  5. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Bonjour,

    Je te conseille de laisser le masque en 255.255.0.0, j'ai déjà constaté qu'en mettant 255.255.255.0 quand on n'utilise que 192.168.0.x ça pose problème parfois.

    Le paquet que tu mentionnes ressemble à du NetBEUI (alors que le partage doit se faire en utilisant NetBios sur TCP/IP). Quel est la version de Windows utilisée ?

    Cordialement,

    Frédéric
     
  6. SDKyron

    SDKyron Registered Member

    Joined:
    Jan 21, 2008
    Posts:
    17
    Je suis sous windows xp pro, et l'autre pc est lui sous vista ultimate (j'ai pas encore eu le courage de passer sous vista moi même).
     
  7. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Ok, netbeui n'est normalement pas installé par défaut sous XP (et donc Vista), donc ça doit être autre chose.

    Frédéric
     
  8. SDKyron

    SDKyron Registered Member

    Joined:
    Jan 21, 2008
    Posts:
    17
    Je viens de remettre 255.255.0.0 comme vous me le conseillez mais rien n'y fait, je n'y comprends rien, tout semble correct pourtant :/

    Ah oui aussi de temps en temps je recois un autre log que celui que j'ai décris plus haut, mais c'est bcp plus rare:

    Rule: Block: All other packets
    Type: UDP
    Address: local.gateway
    Additional: Ports Dest:SSDP/UPnP Src: 50002 (ou 49252)
     
    Last edited: Jan 22, 2008
  9. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Les 2 PCs sont sous XP et les 2 ont Look 'n' Stop, c'est bien cela ?
    Vérifier si ça marche lorsque seulement l'un des 2 Look 'n' Stop est actif.
    Egalement vérifier si juste décochant la case Filtrage Internet (mais en laissant Look 'n' Stop lancé) ça marche (en quittant complètement j'ai compris que ça marchait, donc ce test est intermédiaire).

    Frédéric.
     
  10. SDKyron

    SDKyron Registered Member

    Joined:
    Jan 21, 2008
    Posts:
    17
    PC1 est sous XP, PC2 est sous Vista. Les 2 ont LnS.
    En décochant la case filtrage internet tout fonctionne parfaitement.
     
  11. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Et si la case n'est décochée que sur le PC1 ?
    puis que sur le PC 2 ?

    Merci,

    Frédéric
     
  12. SDKyron

    SDKyron Registered Member

    Joined:
    Jan 21, 2008
    Posts:
    17
    PC2 décoché ne change rien, PC1 ne le voit toujours pas d'où mon incompréhension.

    Je ne peux pas vérifier l'autre option n'étant pas chez moi à l'instant, mais la grosse priorité étant de toutes façon que PC1 puisse accéder au PC2.
     
  13. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Il faudrait essayer le jeu de règles standard sur le PC1 (+ importer les règles de partage sur 172....) pour voir si le même problème se pose.

    Laisser le PC2 décoché pour faire le test.

    Frédéric
     
  14. SDKyron

    SDKyron Registered Member

    Joined:
    Jan 21, 2008
    Posts:
    17
    Bon ben, il "semble" que ca fonctionne avec le jeu standard et les règles de partage.
    Que dois-je changer pour pouvoir utiliser les règles Phant0m alors ?

    Efit: ok bon ben là c'est le top, juste après avoir sélectionné les règles par défaut + partage ca marchait, et là, plus rien...
     
    Last edited: Jan 22, 2008
  15. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Et qu'indique le journal de Look 'n' Stop sur le PC1 juste après avoir constaté que ça ne marche pas ?

    C'est curieux, en général il n'y a pas ce genre de soucis avec les règles de partage.
    Avez-vous une configuration réseau particulière ? si j'ai bien compris, les 2 PCs ne sont pas co-localisés ?

    Frédéric
     
  16. SDKyron

    SDKyron Registered Member

    Joined:
    Jan 21, 2008
    Posts:
    17
    Internet -> modem -> Switch -> PC1
    ------------------------------> PC2

    Sur le PC1 j'ai toujours la même erreur citée dans le premier post.
    Lorsque je clique droit sur la ligne du log dans le PC2 il me propose d'écrire une règle à propos de l'UPnP 1900

    UDP: Any other UDP Packet
    Type: UDP
    Address: 239.255.255.250
    Additional: Ports.... Src: 49493
     
  17. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Activer la journalisation pour rule '+NetBIOS'
     
  18. SDKyron

    SDKyron Registered Member

    Joined:
    Jan 21, 2008
    Posts:
    17
    J'ai pas trop compris comment "activer la journalisation" pour la règle +NetBios alors du coup je me suis dit, désactivons là pour une seconde, et hop, tout fonctionne comme sur des roulettes.
    La question étant est-ce bien résonnable de la désactiver, ne pourrais-je simplement pas la modifier pour que le réseau passe, oui mais comment o_O

    Une fois la règles +NetBios désactivée voici ce que mon log me dit:

    Rule: Block all other packets
    Type: UDP
    Address: local.gateway
    Additional: Ports Dest:SSDP/UPnP Src: (un port entre 49160 et 50002)

    Click droit sur ces lignes me propose de créer une règle ouvrant le port 1900 server.

    Et aussi

    Rule: Block: All other packets
    Type: ETH
    Address: FF:FF:FF:FF:FF:FF
    Additional: Type Ethernet: (0026 ou 0054)

    Voilà donc comme ceci avec Phant0m + +NetBios désactivé tout fonctionne parfaitement, je n'ai même plus besoin des règles de partage, mais bien entendu, j'ai +NetBios de désactivé et aucune idée de l'impact sur la sécurité, ne serait-il pas possible de ne désactiver +NetBios uniquement que pour les IP 172.19.3.1-5 ?
    Il y a aussi cette offre d'ouvrir le port 1900 server qui me tracasse, pourquoi me le proposer et si c'est à faire comment en faire une règle sécurisée.

    Cerise sur le gateau: LnS activé et réglé comme expliqué ici sur PC1 et PC2, tout fonctionne parfaitement et dans les 2 sens.

    Edit: Est ce que le fait de laisser +NetBios activé mais de rajouter une règle comme ceci, permettrait à mon réseau de fonctionner, et la règle suivante est-elle correcte ?

    http://img7.uploadhouse.com/fileuploads/1124/1124022481966b8bf228c4ef20a7696365472c9.jpg

    J'extrapole complètement mais bon, on ne sait jamais...
     
    Last edited: Jan 23, 2008
  19. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    • Rule: Block: All other packets
      Type: ETH
      Address: FF:FF:FF:FF:FF:FF
      Additional: Type Ethernet: 0026

    Inbounds ou Outbounds ou deux sens?

    • Rule: Block: All other packets
      Type: ETH
      Address: FF:FF:FF:FF:FF:FF
      Additional: Type Ethernet: 0054

    Inbounds ou Outbounds ou deux sens?
     
  20. SDKyron

    SDKyron Registered Member

    Joined:
    Jan 21, 2008
    Posts:
    17
    Et bien euh... c'est ce qui est indiqué dans le log, aucune indication n'y est faite de la direction, j'avoue ne pas trop comprendre là. Si le U/D sont pour UP/Down c'est UP :)
     
  21. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Import importable règles fichier 'NetBEUI-Outbound.rie', .. Cette règle voir
    Type Ethernet: 0026 ?
     

    Attached Files:

    Last edited: Jan 23, 2008
  22. SDKyron

    SDKyron Registered Member

    Joined:
    Jan 21, 2008
    Posts:
    17
    Pardon ?
     
  23. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
  24. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Est-ce que cette règle est bien une règle qui autorise les paquets (le sens interdit non actif) ?
    Si oui, alors le fait de la supprimer ne devrait rien changer
    Si non, alors désactiver le sens interdit sur cette règle.
    Désactiver une règle qui autorise des paquets, ne nuit pas à la sécurité (au contraire ça y contribue ;) ), donc rien de plus à faire à mon avis.
    Ces paquets ne sont pas liés au problème de partage, vous pouvez les bloquer sans les afficher (en créant une règle spécial avec effectivement un clic droit puis en sélectionnant le sens interdit et en supprimant l'attribut journal: le ! ou !!), de manière à alléger le journal.

    C'est quand même bizarre ces paquets, il y a forcément un logiciel ou une couche réseau qui les génère.
    Peut être est-ce de l'IPX ? est-ce que ce protocole est installé ?
    Pourriez-vous faire une copie d'écran de la boite de dialogue où on voit les protocoles et services associés à la carte résau ?
    Si ça marche comme cela autant laisser comme c'est.
    Mais j'aimerais bien comprendre si cette règle +NetBios autorise ou bloque les paquets. Et si elle les autorise c'est assez mystérieux.

    Frédéric
     
  25. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    '+NetBIOS' rule is set to block without logging by default, and only that which hasn't been permitted by existing configured Networking rules. It would be interesting to have rule '+NetBIOS' set for logging and have log file or Look 'n' Stop - 'Log' screen capture of the '+NetBIOS' packet blockings.
     
Thread Status:
Not open for further replies.