Replacing Primary drive with Home-partition size and bootup problems

Discussion in 'Acronis True Image Product Line' started by sweetnlowe, Aug 3, 2006.

Thread Status:
Not open for further replies.
  1. sweetnlowe

    sweetnlowe Registered Member

    Joined:
    Aug 3, 2006
    Posts:
    5
    Hello,

    I've been backing my entire C: - 80 GB SATA drive on my laptop using Acronis True Image Home to an external USB Hard Drive. I do full backups once a week and differential daily. I'm trying to do a restore on a new 120 GB SATA drive. Since it's a laptop I can only have one hard drive in there at a time, so I use the Acronis Restore Disk while my External Hard drive is plugged in.

    However I encountered 2 problems:
    1.) I can't seem to use the entire 120 GB partition, it keeps wanting to create an 80 GB partition which I then can't extend since it's the primary one.

    2.) For some reason after the restore if the USB drive is plugged in during boot up, the computer attempts unsuccessfully to boot up on the USB drive and displays the NTLDR missing message. If the USB drive is not plugged in during bootup, it boots off the internal drive perfectly.

    I've been searching the forums for awhile now and haven't really seen anything that addresses these issue, so any ideas would be welcome.

    Thank you,

    Aaron
     
  2. sweetnlowe

    sweetnlowe Registered Member

    Joined:
    Aug 3, 2006
    Posts:
    5
  3. Xpilot

    Xpilot Registered Member

    Joined:
    May 14, 2005
    Posts:
    2,318
    There is a valid way of resizing the partition to a new drive at the time of doing a restore but as you have already done the restore this is the cheap and cheerful method. With you new drive in place open True Image and select the Manage Secure Zone wizard. Create a secure zone to use up the unallocated space. Now, using the same wizard, remove the secure zone and you will be given the choice to allocate the freed space to your partition which brings it into use. The whole job only takes a few minutes.

    You could change the boot order in the BIOS so that the computer does not try to boot from a USB device before the main hard drive. Though, as you have found, leaving it disconnected until you want to use it also does the job.
     
  4. sweetnlowe

    sweetnlowe Registered Member

    Joined:
    Aug 3, 2006
    Posts:
    5
    Thanks for the reply and the additional method to increase the partition size.

    The BIOS boot order doesn't matter as when the USB drive is connected, it is being read as the C: Drive and my internal hard drive is being read as the D: drive. When they are read like that the boot order is irrelevant. I've even tried disabling booting to the External Hard drive in my BIOS, but it still errors on bootup if the USB drive is connected.

    Disconnecting my USB drive every time I reboot the machine is not the preferred solution.

    Thanks
     
  5. Xpilot

    Xpilot Registered Member

    Joined:
    May 14, 2005
    Posts:
    2,318
    How very odd! Never come across the like. However have you tried changing the drive letter assigned to the USB drive in Windows disk management? That should do the trick.
    I have been pondering how the USB drive aquired the C designation two possibilities occur to me. At one time it was used to make a clone of C drive or it was used as an actual C drive before being put into a USB enclosure.
     
  6. sweetnlowe

    sweetnlowe Registered Member

    Joined:
    Aug 3, 2006
    Posts:
    5
    Well I can't really change the letter. When I boot up with it connected, I can't boot. When I boot up without it connected and boot up, it adds the USB drive as drive E like it should. I suppose I can try to reassign it to G and then back to E to see if that works. When my restore is done I will try that. To my knowledge the external hard drive has never been used to boot from. However when I booted up on the Acronis Restore Disk, that's when I first noticed it being recognized as the C drive and it wanting to restore the image onto my E drive (internal drive).

    Thanks again for the reply
     
  7. sweetnlowe

    sweetnlowe Registered Member

    Joined:
    Aug 3, 2006
    Posts:
    5
    I figured it out. I've never seen it before but there was a setting in the BIOS that specifically set the primary and secondary drives. This is a separate setting from the boot order. Evidently when I booted up with the new drive in there and the USB it got switched. dunno why, but I'm back up and running.

    Thanks for your help!
     
Thread Status:
Not open for further replies.