[Réglé]Pb avec Ftp Serv-U 5.0 et lns 2.05 Béta 3

Discussion in 'LnS French Forum' started by kamui, Mar 12, 2004.

Thread Status:
Not open for further replies.
  1. kamui

    kamui Registered Member

    Joined:
    Aug 19, 2003
    Posts:
    218
    Location:
    France
    Hi All ,

    J'ai monter un server ftp via serv-u 5.0 (avec dns dynamique no-ip.com) , les visiteurs n'arrivent pas à se connecter à mon ftp (timeout .......)quand look n stop est activé :(

    J'ai mis le port 25001 à la place du 21 .

    et mon serveur ftp en passif je lui est mis les plages 25002-25010.

    je passe derrière un modem routeur adsl speedtouch 510v4,j'ai bien Natter les ports (25000-25010),.

    les visiteurs arrivent à se connecter quand lns n'est pas activer ;) mais quand lns est activé sa foire :( .

    voici ma régle pour serv-u 5.0

    http://kamui.kenshiro.free.fr/servu.rie

    Merci d'avance ;)
     
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Re:pb avec mon serveur Ftp et lns

    Bonjour,

    La règle semble correcte à première vue.

    Comme 2 applis sont associées à la règles, est-ce que la coche rouge (à gauche de la règle) se transforme bien en vert quand le serveur FTP est actif ?

    Ensuite, quand un client essaye de se connecter, et que ça ne marche pas, qu'indique le journal de Look 'n' Stop ? il doit montrer des paquets qui devraient permettre de comprendre ce qu'il se passe.

    Etes-vous sûr que les clients se connectent en mode passif ?

    Frédéric
     
  3. kamui

    kamui Registered Member

    Joined:
    Aug 19, 2003
    Posts:
    218
    Location:
    France
    Re:pb avec mon serveur Ftp et lns

    oui quand mon serveur est désactivé c bien en marron et sa passe en vert quand ils tournent ;).

    par contre je ne sais pas si les clients se connectent en passif ou non car c ceux qui sont derrière un firewall comme moi qu'ils doivent se connecter en passif non o_O. :rolleyes:

    ah oui j'ai oublier de vous préciser que j'utilise phantom rules 5 ;)

    au niv des paquets faut que je vérifie ,j'avais pas fais gaffe ;)

    je vais vous tenir en courant ;)

    Merci @++
    Kamui
     
  4. kamui

    kamui Registered Member

    Joined:
    Aug 19, 2003
    Posts:
    218
    Location:
    France
    Re:pb avec mon serveur Ftp et lns

    je v tester avec la béta 03 pour voir ce que sa donne ;)
     
  5. kamui

    kamui Registered Member

    Joined:
    Aug 19, 2003
    Posts:
    218
    Location:
    France
    Re:pb avec mon serveur Ftp et lns

    Bonsoir Fred ,

    Sa marche avec la version 2.05 béta 3 :cool: , mais partielement ,je m'explique , les clients ne peuvent pas se connecter quand je configure le FTP en SSL/TLS o_O , quels est le port SSL déjà ??

    par défaut c 443 il me semble :rolleyes: mais j'aimerais le changer hors je n'ai pas la possibilité de changer le port ssl via Serv-U 5.0 :(

    ++
     
  6. kamui

    kamui Registered Member

    Joined:
    Aug 19, 2003
    Posts:
    218
    Location:
    France
    Re:pb avec Ftp Serv-U 5.0 et lns 2.05 Béta 3

    pour les connexion ssl/tsl ,j'ai cette erreur pour mon ftp via le test en ligne de bullet proof

    Trying to connect to x.x.x.x (x.x.x.x):25001 ...
    431 Unable to negotiate secure command connection.

    Error : Cannot connect to remote host "x.x.x.x:25001".

    :-(
     
  7. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Re:pb avec mon serveur Ftp et lns

    Bonjour,

    Je ne suis pas sûr que ce soit la 2.05b3 qui ait résolu le problème initial. L'important c'est que ça marche.
    En ce qui conceren les connexions FTP via SSL, je ne sais pas bien comment ça marche ni quels sont les ports impliqués.
    443 c'est https non ?

    Frédéric
     
  8. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Re:pb avec Ftp Serv-U 5.0 et lns 2.05 Béta 3

    Et le journal de Look 'n' Stop, il dit quoi ?

    Sans Look 'n' Stop ça marche correctement ?

    Merci,

    Frédéric
     
  9. kamui

    kamui Registered Member

    Joined:
    Aug 19, 2003
    Posts:
    218
    Location:
    France
    Re:pb avec Ftp Serv-U 5.0 et lns 2.05 Béta 3

    http://rhinosoft.com/kbsearch.asp?prod=su

    sa marche pas non plus san lns :( (le journal m'indique rien)

    la base de connaisance de serv-u me conseille de désactiver le nat o_O
    http://rhinosoft.com/kbsearch.asp?prod=su

    "NOTE: if your FTP Client can connect with a regular session, but not with SSL enabled then we would recommend checking if there are any NAT enabled device between the FTP Client and Serv-U. The NAT translation is not able to understand the encrypted data being sent between the client and server and thus corrupts the data connection. Currently the only work arounds are to disable the NAT functionality or move Serv-U or the FTP Client in front of the NAT enabled device."

    plz help ;)

    pour le ssl c bien le 443

    http://www.zdnet.fr/builder/web_design/conception_site/0,39021086,39117651-2,00.htm

    ;)
     
  10. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Re:pb avec Ftp Serv-U 5.0 et lns 2.05 Béta 3

    Pour la connexion avec SSL, je ne sais pas répondre.

    Si quelqu'un a la solution, il peut poster ici (même si c'est un peu hors-sujet ;) ).

    Frédéric
     
  11. kamui

    kamui Registered Member

    Joined:
    Aug 19, 2003
    Posts:
    218
    Location:
    France
    Re:pb avec Ftp Serv-U 5.0 et lns 2.05 Béta 3

    *puppy*

    en fait ct tous cons les gars , ce sont les client qui sont mal configurés et non mon serveur ftp :cool: , fallait juste coché deux case dans les options de flash xp ,que j'avais oublier de cocher :p


    pour se connecter à mon serveur ftp ( en ssl/tls), faut paraméter son flash xp comme ci dessous (les truc entourés se sont les deux cases que j'avais oublier de cocher) :D


    http://kamui.kenshiro.free.fr/fxp.png


    http://kamui.kenshiro.free.fr/fxp2.png

    :cool:


    c'était vraiment HS, rien as voir avec Lns ;) désolé pour le dérangement Fred :D

    @++
    kamui
     
  12. hubereevez

    hubereevez Guest

    et c'est normal que les ports 25001 à 25010 soiet open, nan?
    lns 2.05b3 : par contre la case passe pas en vert si je mets appli dans la règle o_O
    a+
    hubhub
     
  13. kamui

    kamui Registered Member

    Joined:
    Aug 19, 2003
    Posts:
    218
    Location:
    France
    vi c normal ,ils sont ouvert si et seulement si tu lance ton serveur ftp ;) , dans la partie "application de ta régle serv u" as tu bien autoriser "
    servuadmin.exe" et "servudaemon.exe" o_O? pour que sa bascule en vert o_O o_O

    +++
     
  14. Bobby12541

    Bobby12541 Guest

    il est préférable de redémarré la machine si tu ajoute des applications dans le filtrage de certaines rules car apparement parfois elles sont pas correctement détecté mais je ne sais pas pkoi.
     
Thread Status:
Not open for further replies.