Recent NoScript change preventing noscript element display?

Discussion in 'other software & services' started by TheWindBringeth, Jul 2, 2014.

Thread Status:
Not open for further replies.
  1. TheWindBringeth

    TheWindBringeth Registered Member

    Joined:
    Feb 29, 2012
    Posts:
    2,084
    Recently I noticed, at this forum, that the quick reply box was no longer visible when javascript is disabled via NoScript. I just quickly looked into this and my preliminary findings are:

    1) There is a <textarea style="display:none"></textarea><noscript><textarea></textarea></noscript> arrangement whereby the later textarea should be visible when javascript is disabled.
    2) WRT to NoScript, when this site isn't trusted... and even when the "Hide <noscript> elements" setting is disabled and its underlying preference is manually set to false... that second textarea isn't shown. Checking some local html files, I also see <noscript> elements not being displayed when NoScript is supposedly disabling javascript for them.
    3) If I completely disable the NoScript extension, and disable javascript through FF preference, the <noscript> elements are displayed as expected.

    So ATM I'm thinking this is a NoScript related issue, and probably one that was triggered by a recent update. I'm not sure if <noscript> elements are just being interferred with, or whether NoScript is effectively enabling javascript for pages at some level and that is why the <noscript> elements aren't processed.

    Could someone using NoScript 2.6.8.31 (preferably with FF30.0 as that is what I'm using) check for and confirm what I'm describing? Thanks.
     
  2. bo elam

    bo elam Registered Member

    Joined:
    Jun 15, 2010
    Posts:
    3,768
    Location:
    Nicaragua
    I dont see what you described with Firefox 30 and NoScript 2.6.8.28 (that's what I am using now) but after upgrading (sandboxed) to version 2.6.8.31, the only way to see the reply box is to allow wilderssecurity.com.

    So you are right, this changed during a recent update. Personally this doesnt really bother me since I white listed Wilders. FWIW, I have less that ten sites in my white list, Wilders is one of them.:)

    Bo
     
  3. KeyPer4Life

    KeyPer4Life Registered Member

    Joined:
    Dec 18, 2013
    Posts:
    974
    Using NoScript 2.6.8.31 with Pale Moon browser. Have javascript enabled in browser.
    The Reply box at Wilders is visable without having wilderssecurity.com whitelisted in NoScript.
     
  4. TheWindBringeth

    TheWindBringeth Registered Member

    Joined:
    Feb 29, 2012
    Posts:
    2,084
    Thanks for the feedback. FWIW, and with FF30.0, I tried with surrogates disabled and that didn't resolve the issue. I also tried the next most recent release available via AMO (2.6.8.29) and the problem didn't appear. So I think either .30 or .31 brought it.
     
  5. MrBrian

    MrBrian Registered Member

    Joined:
    Feb 24, 2008
    Posts:
    6,032
    Location:
    USA
    From http://noscript.net/changelog:
     
  6. bo elam

    bo elam Registered Member

    Joined:
    Jun 15, 2010
    Posts:
    3,768
    Location:
    Nicaragua
    Nice.:)

    Bo
     
  7. TheWindBringeth

    TheWindBringeth Registered Member

    Joined:
    Feb 29, 2012
    Posts:
    2,084
    Thanks for taking the time to point that out MrBrian. It appears to resolve the issues that I was seeing :)
     
  8. MrBrian

    MrBrian Registered Member

    Joined:
    Feb 24, 2008
    Posts:
    6,032
    Location:
    USA
    You're welcome :).
     
Loading...
Thread Status:
Not open for further replies.