Reboot & shutdown with LnS will last 2-3 minutes, without LnS 2 sec.

Discussion in 'LnS English Forum' started by El_Nebuloso, Oct 3, 2007.

Thread Status:
Not open for further replies.
  1. El_Nebuloso

    El_Nebuloso Registered Member

    Joined:
    Mar 26, 2007
    Posts:
    25
    Hello,
    I have a reboot and shutdown problem with Look’n’Stop.
    The reboot and the shutdown will last 2-3 minutes !
    When I deinstall LnS, the reboot and shutdown will last 2 seconds.
    When I install LnS again, I have to wait for 2-3 minutes for a reboot :/

    I read the "Look 'n' Stop v2.06 shutdown hang issue fix", but there is no effect on my reboot/shutdown times.

    My reg-data is...

    [HKEY_CURRENT_USER\Control Panel\Desktop]
    "AutoEndTasks"="1"
    "MenuShowDelay"="20"
    "PowerOffActive"="0"
    "PowerOffTimeOut"="0"
    "WaitToKillAppTimeout"="1000"

    Sometimes, when I tried to use "Reg Keys" = "Per User", there is only a problem with the shutdowntime. The reboot is fast. Then I used "Reg Keys" = "Common to all users", and reboot/shutdown will last 2-3 minutes.

    Any ideas ?

    El Nebuloso
     
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
  3. El_Nebuloso

    El_Nebuloso Registered Member

    Joined:
    Mar 26, 2007
    Posts:
    25
    Hi Frederic,

    I downloaded the "UPHClean.exe" and installed it, but it takes no effect (reboot still at 2-3 min.).

    When I manually stop Look 'n' Stop before rebooting, the time till reboot is 2 sec.

    The startup typ I am using: System.
    Then I used: Service

    ...and the time till reboot is 2 sec. :)

    Then I deinstalled the "UPHClean.exe" and the reboot and shutdown are still taking effect after 2 sec. :)

    So it seems to be, that startup typ "System" is not the right one for me.

    But... I still wonder about that, because I used startup typ "Service" before and it takes no effect about the bad reboot and shutdown times... :doubt:

    Thanks,
    El Nebuloso
     
  4. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Hi,

    Ok, thanks for the information.
    I've no idea so far what could be the issue, and why starting Look 'n' Stop as a service would solve the issue (I would have expected the opposite).

    If the problem appears again, and if it is again systematic/reproducible, I would like to know if manually stopping Look 'n' Stop before the shutdown or the reboot helps.

    Thanks,

    Frederic
     
  5. El_Nebuloso

    El_Nebuloso Registered Member

    Joined:
    Mar 26, 2007
    Posts:
    25
    Hi Frederic,

    it is not the first time that this happens after installing Windows XP.
    In the last 2 month I installed XP for 5 or 6 times and the problem always appears.
    Next time I will set it to "service" first.


    Manually stopping Look 'n' Stop before the shutdown or the reboot ALLWAYS helps !

    Thanks,
    El Nebuloso
     
  6. Climenole

    Climenole Look 'n' Stop Expert

    Joined:
    Jun 3, 2005
    Posts:
    1,640
    Hi El_Nebuloso :)

    Are you sure the slow shutdown is related to LnS instead of the programs checked by LnS...

    May be a maintenance of your Wxp will solve the problem:
    (chkdsk with the /R switch + disk cleanup + defrag...)

    BTW in how many times Wxp is booting ?
    If it's more than 30 seconds you have to fix this too.

    Some hints: SHUTDOWN WORKS, BUT IT’S REAL SLOW

    Hope this help. Let us know.

    :)
     
  7. El_Nebuloso

    El_Nebuloso Registered Member

    Joined:
    Mar 26, 2007
    Posts:
    25
    Thx Climenole,

    I am very sure about the fact, that the slow shutdown is related to LnS.
    I tested it for a couple of hours with new installed wxp.

    The problem begins after installing LnS and it ends when I manually exit LnS or I deinstalled it.

    Maintenance of wxp will not solve the problem, because it happens after formating the harddisc and a clean/fresh install of wxp.

    Wxp is booting in about 20 sec.

    Thanks,
    El Nebuloso
     
  8. Climenole

    Climenole Look 'n' Stop Expert

    Joined:
    Jun 3, 2005
    Posts:
    1,640
    Hi El_Nebuloso :)

    Yes it is: after a new installation you must run a chkdsk /R to lock the bad sector of your hard disk ...

    You have to update the drivers and so on...


    There's also some issues from the services configuration. I'm just answering a similar question in the french forum...

    Send me a copy of the services list

    Start | Run | Services.msc

    Remove the columns "descriptions" and "open a session as ..."

    second tool bar, 6 th icon : export...

    :)
     
  9. El_Nebuloso

    El_Nebuloso Registered Member

    Joined:
    Mar 26, 2007
    Posts:
    25
    Hi Climenole,

    this it not so easy for my, because my english is not got enough to tell you all what I've been tested so far.

    - There are no bad sectors on my harddiscs.
    - I've tested on clean wxp install with sp2 ( no extra drivers )
    - I've tested on clean wxp install with sp2 and with all patches since sp2 ( nvidia 163.71 driver installed )
    - I've tested on clean wxp install with sp2 and with all patches since sp2 AND all beta patches since sp2 ( nvidia 163.71 driver, samsung 245b driver installed )
    - I've tested on clean wxp install shinked with nLite with all patches since sp2 AND all beta patches since sp2 ( nvidia 163.71 driver, samsung 245b driver installed )
    - I've tested on my old ( 2 month ago ) wxp installation ( older nvidia and lg 1950 driver installed )

    Services:
    I think there are nearly 40 services on the clean wxp install with sp2 ( no extra drivers ) and down to the nLite installation there are only 7 services.

    I don't know what the correct translations are, but the services that are running are ... :

    - Design
    - Ereignisprotokoll
    - Look'n'Stop Service
    - Netzwerkverbindung
    - Plug & Play
    - Remoteprozeduraufruf (RPC)
    - Windows Audio

    Please remember:
    ALL of the installations above have the same behavior.
    After installing LnS 2.06 the reboot/shutdown will last for 2-3 minutes.
    When I manually exit LnS, the reboot/shutdown starts immediately.
    After deinstalling LnS the reboot/shutdown starts immediately.

    Thanks for your help,
    El Nebuloso
     
  10. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Hi El_Nebuloso,

    It looks like you or someone or something had already tweaked those settings, for "WaitToKillAppTimeout", if you re-installed Windows, should be with value of 2000 now, you should check anyways and change if not set for 2000, unless you already tried?


    I'm curious is "WaitToKillServiceTimeout" in there also? If so what is its value? and the "HungAppTimeout" also...?
     
  11. El_Nebuloso

    El_Nebuloso Registered Member

    Joined:
    Mar 26, 2007
    Posts:
    25
    Hi Phant0m,

    if tested the registry settings only in:

    - clean wxp install shinked with nLite with all patches since sp2 AND all beta patches since sp2 ( nvidia 163.71 driver, samsung 245b driver installed )
    - on my old ( 2 month ago ) wxp installation ( older nvidia and lg 1950 driver installed )

    I have not tested the registry settings on a clean wxp installation.

    El Nebuloso
     
  12. Climenole

    Climenole Look 'n' Stop Expert

    Joined:
    Jun 3, 2005
    Posts:
    1,640
    Hi El_Nebuloso

    English is not my native language ... and I don't care!

    :D

    7 services ? Impossible!
    nLite ? You're looking for trouble !

    :rolleyes:

    Don't translate this. Just send me the list.

    :)
     
  13. Phant0m

    Phant0m Registered Member

    Joined:
    Jun 7, 2003
    Posts:
    3,684
    Location:
    Canada
    Yes, one of nLite purposes is to Tweak, but as Climenole already mentions..., nLite can be problem for couple different reasons.

    It's obvious to me that your system has been improperly tweaked, manually or through a program such as nLite, to me it seems pretty obvious once you restore to the original registry settings that reflects how the system performs it's shutdown, it should correct the slow shutdown problem.
     
  14. El_Nebuloso

    El_Nebuloso Registered Member

    Joined:
    Mar 26, 2007
    Posts:
    25
    Ok,

    here is my further proceeding:

    As I said before, the startup typ "Service" works for me.
    I will take the LnS registry settings as they are now and will generate with AutoIt a install of LnS, which uses this registry settings.

    I think, this will solve my problem in the future.

    Thanks to all,
    El Nebuloso
     
Thread Status:
Not open for further replies.