Real-time file system protection disables itself each restart

Discussion in 'ESET NOD32 Antivirus' started by Don64, Nov 8, 2008.

Thread Status:
Not open for further replies.
  1. Don64

    Don64 Registered Member

    Joined:
    Nov 8, 2008
    Posts:
    3
    Everytime I restart my computer I have to re-enable real-time file system protection. Here's some more info.

    This has happened since a previous version for me (3.0.650) but continues to after updating to the latest version today.

    Steps:
    1) Reboot computer
    2) See 2 tip balloons from the system tray - one from Windows saying that NOD32 is disabled and one from NOD32 saying that real-time file system protection is disabled
    3) Open NOD32 go to preferences and click the checkbox to enable real-time file system protection and press OK
    4) Go back to preferences and find that the checkbox has UNCHECKED itself
    5) Go to the "Protection status" tab in NOD32 and click the link in the sentence that says: "Automatic startup of the real-time file system protection is disabled. The computer is not protected against threats. The real-time file system protection can be started from here: Start real-time file system protection"
    6) It gets enabled, the balloons go away, and the checkbox appears checked in the preferences like it should.
    7) Restart computer - go back to step 2 and loop forever


    Anyone seen this before? What can I do?

    EDIT: I am using Windows XP x64 and NOD32 x64
     
  2. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Do you have UAC disabled? Have you tried reinstalling EAV to make sure correct permissions are set for the ESET registry key and all its subkeys?
     
  3. Don64

    Don64 Registered Member

    Joined:
    Nov 8, 2008
    Posts:
    3
    Yes, UAC is disabled. I have tried re-installing.
     
  4. proactivelover

    proactivelover Registered Member

    Joined:
    Apr 7, 2006
    Posts:
    840
    Location:
    Near Wilders Forums
    winxp 64bit does not have UACo_O
    uninstall your current version Eset Antivirus
    Delete these registry key
    HKEY_CURRENT_USER\Software\ESET
    HKEY_LOCAL_MACHINE\SOFTWARE\ESET
    then install v3.0.672(64bit edition) and tell us
     
  5. Marcos

    Marcos Eset Staff Account

    Joined:
    Nov 22, 2002
    Posts:
    14,374
    Of course, I overlooked that ;)
     
  6. Don64

    Don64 Registered Member

    Joined:
    Nov 8, 2008
    Posts:
    3
    Thanks proactivelover. I uninstalled and deleted the registry keys then restarted and re-installed. Now it's working fine.
     
Thread Status:
Not open for further replies.