Problems with VMware, poor mouse and windows movement

Discussion in 'sandboxing & virtualization' started by aigle, Aug 20, 2007.

Thread Status:
Not open for further replies.
  1. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    After trying VirtualBox. I tried VMware server.
    Everything is Ok but I am not hapy at al with AMware as movement of mouse and windows is not at all smooth in VM. I installed VMware tools thinking that it will cure the issue but no improvement. I don,t see even an option in vmware tools for Mouse or graphics. Do I need to run tools on start up or just instaling them is enough.

    I have tried VMware player and did not notice such issues with that. Also no such issues with VirtualBox. I wonder if it is due to the ram. I have 512 MB( running XP Home SP2), assigned 256 MB to the VM.

    Any adice will be welcome.

    Thanks
     

    Attached Files:

  2. Alphalutra1

    Alphalutra1 Registered Member

    Joined:
    Dec 17, 2005
    Posts:
    1,160
    Location:
    127.0.0.0/255.0.0.0
    Glad you got the tools installed.

    Now, I have found it to be a great improvement using the tools in the guest OS, so maybe something isn't done right.

    First off, you will need to check your /etc/X11/xorg.conf (this is the file that configures the xserver which is basically your GUI, then you add on something like kde, gnome, pekwm, etc to control windows that it is displaying).

    The configuration file is quite complex and such, but inside it, the drivers for your mouse and video card are defined. These should be vmmouse and vmware respectively. To check to make sure they are in their, run these commands:

    cat /etc/X11/xorg.conf | grep vmmouse

    If nothing is displayed, then you will need to edit it and correct it. Edit /etc/X11/xorg.conf with your favorite editor (you will need to be root). Then, go to the section that is similar to:

    Section "InputDevice"

    # Identifier and driver

    Identifier "Mouse1"
    Driver "mouse"
    ...
    And change the driver to "vmmouse"

    Next for the video, do:

    cat /etc/X11/xorg.conf | grep vmware

    If nothing comes up, then you will need to change the video card driver as well. Again, open up /etc/X11/xorg.conf as root with your favorite editor, then find a section similar to:

    Section "Screen"
    Identifier "Screen 1"
    Device "ATI Rage"
    Monitor "Dell"
    DefaultDepth 24
    ....

    Whatever word is in the "Device" section, you will need to go and edit it, so since mine is "ATI Rage", I will go to this part of my xorg.conf:

    Section "Device"
    Identifier "ATI Rage"
    Driver "r128"
    #VideoRam 16384
    # Insert Clocks lines here if appropriate
    EndSection

    Then change the Driver to "vmware"

    You should restart x.org, then you should be good to go.

    Cheers,

    Alphalutra1
     
  3. Pedro

    Pedro Registered Member

    Joined:
    Nov 2, 2006
    Posts:
    3,502
    Hey Alphalutra1 :)
    What does "| grep" do? "cat /etc/X11/xorg.conf" will show everything, does "| grep vmmouse" filter the word or?
     
  4. Alphalutra1

    Alphalutra1 Registered Member

    Joined:
    Dec 17, 2005
    Posts:
    1,160
    Location:
    127.0.0.0/255.0.0.0
    http://bama.ua.edu/cgi-bin/man-cgi?grep 1 ;)

    If you type man grep in the command line it should tell you, but from it's man page description

    Essential, cat prints the entire contents of /etc/X11/xorg.conf to stdout (the terminal), but the "|" pipes the output from the terminal to the program grep which searches for any occurences of the word "vmmouse" and prints out the lines that contain it. Oh, the joy of the command line :D

    Cheers,

    Alphalutra1
     
  5. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    Thanks a lot. Seems monitor is already VMware but mouse is not.
    Here is my confi file as txt.
     

    Attached Files:

  6. Pedro

    Pedro Registered Member

    Joined:
    Nov 2, 2006
    Posts:
    3,502
    Alphalutra1, thank you!
    He's saying change "mouse" to "vmmouse". Using vim, type

    vim /etc/X11/xorg.conf

    then locate this section, press "i" to edit, then change the word, press Esc, then type ZZ to save and exit. (ZZ in capital letters, as in SHIFT ZZ)
    An Extremely Quick and Simple Introduction to the Vi Text Editor
     
  7. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    Ya, I login as root, opened xorg.conf via kwrite, changed mouse Driver to vmmouse and rebooted. Now realy the mouse movements is fine. Seems I have done it right, though through a wrong way.
    But still windows movement is very bad. Basically when I drag a window/ file/ icon etc it lags behind the mouse and the movement is jerky. It feels so bad.
    Scrolling is poor too.

    Anything I can do to improve this. Thanks
     
  8. Alphalutra1

    Alphalutra1 Registered Member

    Joined:
    Dec 17, 2005
    Posts:
    1,160
    Location:
    127.0.0.0/255.0.0.0
    I don't think you can do anything else, you are just seeing the performance hit taken when running things in a virtual machine. The lack of RAM is one issue, but then again so is the emulation. If you think this is slow, try out qemu without kqemu (makes you want to quite after 5 minutes and that's in command line only :p )

    Cheers,

    Alphalutra1
     
  9. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    Thanks Alpha, I think I have to wait until I get some more ram.
    Thanks for the help.
     
  10. acknsyn

    acknsyn Registered Member

    Joined:
    Aug 10, 2007
    Posts:
    27
    Try lowering screen resolution or color depth. There is also trick to allocate more video memory to vm machine but I dont recall the command.
     
  11. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    Thanks but unfortunately I have uninstalled it.
     
  12. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    I just installed PCLinuxOS in a trial of VMware workstation and everything worked well. So it,s basically just a flaw/ deficiency in VMware server itself.
     
  13. Longboard

    Longboard Registered Member

    Joined:
    Oct 2, 2004
    Posts:
    3,187
    Location:
    Sydney, Australia
    @Aigle et al

    One thing I found running distros and PCBSD in VmWare on XPHome host was to cut back on any running services, my CPU was hitting 100% and really s l o w i n g things down.

    Watch with Task Manager or Process explorer.
    Process explorer is useful for suspending whatever you might not need: realtime scanners and other 'front-end' services(particularly with auto-updates and any other scheduled tasks)/AV/FDISR etc etc etc.
    This produced spectacular changes in performance
    Virtual box was even more sensitive.
    The settings in VMWorkstation allow you to keep any VMs and iso files off "C"

    My current trials in VMs:
    PCLinuxOS
    PCBSD
    Ubuntu
    Sabayon
    Mint
    Mandriva
    DreamLinux
    Freespire

    Mepis and SuSe on the list.

    AS much as it may be an 'issue' some of the commercial releases are also on the list

    The Virtual HW and network set-up is almost flawless with all these
    Heh: by now I've almost got the install and the vmtools to a fine art.
    Terminal commands and configs are next: you guys are well ahead :cool:

    From what I read the actual install to dual boot and real HW is not always so easy. :)

    I was amazed to find my ISP maintains a free "File Library" for dls that is not part of monthly usage , there are nearly all the utd distros CD and DVD iso's there and they will mirror by request. Love it; almost a free lunch! :D

    These Linux threads have been a boost for me.
    Searching the fora there is good, some replies a bit ott for newbs like moi: come here and get good advice.

    MrK, AlphaUltra, and ice to blame :D

    I'm afraid that I have some db applications for business that will not run in Linux so M$ may hae to stay protem. :doubt:

    Thanks :thumb:
     
  14. aigle

    aigle Registered Member

    Joined:
    Dec 14, 2005
    Posts:
    11,047
    Location:
    Saudi Arabia/ Pakistan
    Thanks Longboard.
    Yes, I post linux threads here as I know there are many folks to help esp Mrk, Alpha, Iceni etc.
     
  15. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    8,696
    Hello,
    This is a very interesting thead! I love it.
    Quick advice = change the default "ps/2" mouse to "ExplorerPS/2"
    I found this to improve the mouse scrollability and response.
    Save the xorg.conf, restart the windows manager.
    Mrk

    P.S. Perdo, kudos on that tip, most newbies simply reboot after getting suck inside the vi ... :)
     
  16. Pedro

    Pedro Registered Member

    Joined:
    Nov 2, 2006
    Posts:
    3,502
    I'll forgive the misspell :p , non intentional but incorrect! :D There are saints with that name!

    You know, funny thing about vi(m), i really was about to reboot once. A guy can get stuck if he doesn't know how to exit without saving. I was forced to learn, i had no video driver working. Then no net. I had to learn, and i'm glad i did. Along the way i learned other unrelated stuff, derived from my poor searches (when we don't know, we don't even know what to look for..o_O ).

    Now that i know the basics, vim has its logic - a mode to edit, and a mode to issue commands.
     
Loading...
Thread Status:
Not open for further replies.