Problems with interactive filtering mode

Discussion in 'ESET Smart Security v4 Beta Forum' started by jhjm32087, Feb 19, 2009.

Thread Status:
Not open for further replies.
  1. jhjm32087

    jhjm32087 Registered Member

    Joined:
    Feb 19, 2009
    Posts:
    10
    I'm unable to use any type of connection to the internet, while I have interactive filtering enable. Although, once I change to Automatic Filtering for my firewall. Everything works correctly. btw, I have removed and reinstalled through the Add/remove programs. Any ideas?

    Windows Vista x64
    Marvell Yukon 10.51.1.9 drivers
     
  2. agoretsky

    agoretsky Eset Staff Account

    Joined:
    Apr 4, 2006
    Posts:
    4,032
    Location:
    California
    Hello,

    Are you using the beta test (v4.0.068.0) or the release candidate (v4.0.226.0) build of ESET Smart Security v4?

    Regards,

    Aryeh Goretsky
     
  3. jhjm32087

    jhjm32087 Registered Member

    Joined:
    Feb 19, 2009
    Posts:
    10
    I'm currently using the ESET Smart Security RC1 4.0.226.0
     
  4. agoretsky

    agoretsky Eset Staff Account

    Joined:
    Apr 4, 2006
    Posts:
    4,032
    Location:
    California
    Hello,

    If you switch the Filtering Mode from Interactive to Learning and then attempt to access the Internet, do you receive any prompts from ESET Smart Security that a new rule has been created?

    Regards,

    Aryeh Goretsky
     
  5. jhjm32087

    jhjm32087 Registered Member

    Joined:
    Feb 19, 2009
    Posts:
    10
    I change the option, but still no luck. I was using Smart Security version 3.0. Later, I upgrade to the beta 1 and had this problem appearing. Although, If I do revert back to 3.0 the problem does not exist.
     
  6. agoretsky

    agoretsky Eset Staff Account

    Joined:
    Apr 4, 2006
    Posts:
    4,032
    Location:
    California
    Hello,

    I noticed that there are slightly newer drivers (v10.66.4.3) here on Marvell's web site. Could you try uninstalling ESET Smart Security 4.0.226.0, upgrading your drivers and then perform a clean install of ESET Smart Security v4.0.226.0 and retest?

    Regards,

    Aryeh Goretsky
     
  7. jhjm32087

    jhjm32087 Registered Member

    Joined:
    Feb 19, 2009
    Posts:
    10
    I already updated the driver to the latest version, which you linked. Thank you very much. Although the problem still keeps happening. I noticed in the network Connections, if I click on a process for example firefox.exe and right click allow. The connection works but does not display the allow/create rule dialog box, which should appear in the interactive filtering mode.
     
  8. eisefr

    eisefr Registered Member

    Joined:
    Nov 23, 2004
    Posts:
    153
    Location:
    Germany
    Firewall doesn't work here either.
    Same problems as with the beta 1!

    This is a RC ??

    Oh well.

    I think I will stay on version 3 then !

    Firewall there works perfect at least.
     
  9. get_it

    get_it Registered Member

    Joined:
    Aug 28, 2007
    Posts:
    99
    Hi,

    I am having a problem with the firewall in ESET Smart Security 4.0.266.0, particularly when im using P2P software such as, UTorrent, StrongDC and Limewire.

    When downloading or uploading, with the firewall enabled, in interactive mode (my preferred mode), i have noticed that my computer becomes very sluggish, i.e. applications load very slowly, changing between windows takes very long .etc
    However when i disable the firewall my computer becomes much more responsive.

    I have tried changing the settings of the firewall testing each filtering mode with different P2P applications, but the result is still the same. Using the standard Win XP firewall my computer runs normally, and i do not have this issue.

    The computer i am using has a fresh installation of Windows XP Pro SP3 (x86) all updates and latest device drivers. ESET Smart Security 4.0.266.0 is the only security software installed.

    I also had this very same problem when using ESET Smart Security 3.0.684.

    My system consists of:
    CPU: AMD Athlon 3000 xp
    RAM: 1024 MB
    HDD: 200GB
    MB: Asus A7n8x-e deluxe
    Network: Dual LAN, On board, Marvell Yukon and Nvidia NForce

    Any help will be greatly appreciated.
    Thank you.
     
  10. comma dor dash

    comma dor dash Registered Member

    Joined:
    Jun 5, 2005
    Posts:
    146
    Interactive mode doesn't work with me either. Win7 x64.

    Initially, a rule editor window does pop up. You can create an allow rule (allow outgoing traffic of opera.exe to port 80 at any address). However, when you restart opera this rule is somehow not applied and the browser cannot properly connect to the internet. I "feel" that it has something to do with DNS requests. No rule editor window pops-up and asks me to allow DNS requests. There is also no window asking me to allow connection to other ports than port 80. Can it be that Eset will not ask for the creation of further rules once a single rule has been created?

    Anyway...at the moment the firewall component seems to be broken. Unfortunately, I am not aware of any good alternatives.
     
  11. GaryRW

    GaryRW Registered Member

    Joined:
    May 14, 2005
    Posts:
    141
    Location:
    OH, USA
    Toggle to detail view of rules and you will see 2 DNS rules listed in the shaded default set. You can toggle these rules off, but can't send them to the log. I have turned these off and create new tighter DNS rules using the defined DNS Servers Zone and breakout the periodic ICMP from OpenDNS. You can log these created rules if desired.
     
Thread Status:
Not open for further replies.