Problems w/Dell's Vista Image partitions

Discussion in 'Acronis Disk Director Suite' started by Dirk_Knight, Jun 24, 2007.

Thread Status:
Not open for further replies.
  1. Dirk_Knight

    Dirk_Knight Registered Member

    Joined:
    Jun 24, 2007
    Posts:
    2
    Hi,

    This is kind of long, but I wanted to include all the necessary detail. My brand new Dell Dimension E520 came with Vista Home Premium pre-installed on the 250GB hard drive. The drive was set up as a single partition. This does not suit my needs, so I attempted to use the built-in Vista Disk Manager utility to set up new partitions. It didn't work.

    To be clear, the drive actually arrived with three partitions on it; the C: NTFS partition where the OS was installed, a D: NTFS partition labelled Recovery, and an inaccessible, unlabelled EISA partition. I have not attempted to make any changes to or remove the D: and EISA partitions. The C: partition encompasses 224GB of the 250GB (theoretical capacity) drive, so that is where the changes need to occur.

    I first shrank the C: partition, using the Disk Management utility, but it would only shrink by about 110 GB, despite having only 36.8 GB in use. That's including the Page File. This left me with a C: drive of about 120GB, most of which was empty. Repeating the process would not shrink the partition more than another 1GB, or so.

    So, I tried moving moving the Page File to the new partition created on the freed up space, defragging C:, rebooting and trying again. No change. Hours of research on MS KB, Technet, Google, and several calls to Dell later, there's still no change.

    Despite the mixed reviews, I downloaded Acronis Disk Director (ADD, nice acronym), created the bootable Rescue Disc, and tried that. It can't even see the physical drive, let alone the partitions on it. It sees my external USB drive, but not the internal SATA drive. So, figuring I have nothing to lose, I installed ADD in Vista and ran it there. Same thing. It doesn't even see the drive. I have not been able to find any other reports of this particular problem.

    I don't really see this as an Acronis problem, though. There's clearly something wrong with the image Dell is using to set these machines up. Whether it's their fault or Microsoft's would be hard to prove, but sizing an existing partition is not one of the known issues with Vista, so I believe it's Dell's fault. But it's a situation Acronis should be aware of.

    So, since Dell refuses to take any responsibility for this, or offer any assistance, I'm currently planning on returning the machine. If I have to struggle this much to overcome this one problem that shouldn't exist, how many others are lurking in the background? I see no reason why I should I be stuck with a defective OS on a brand new machine.

    So, at this point, I don't expect much, but I'll take any suggestions,
    advice, or commentary anyone cares to offer, and hope this serves as a warning to other folks in the market for a new machine.

    Thanks!
     
  2. Bostski

    Bostski Registered Member

    Joined:
    Jun 5, 2007
    Posts:
    2
    I just wrote a lengthy reply to someone else about two weeks of utter frustration trying to partition my C drive just like you. To make it short, I found a webpage which talked about a different program but gave me the idea to try this. Right click the Disk Director Suite 10 program and select "run as administrator" then try to partitioin it. It worked on my new Dell which is running Vista Ultimate but hopefully this will work. It seems to be a Windows problem/issue and not a Dell problem.
     
  3. Dirk_Knight

    Dirk_Knight Registered Member

    Joined:
    Jun 24, 2007
    Posts:
    2
    Thanks very much! It appears that that might work, if I purchase the full version of ADD. (Apparently the trial version doesn't really let you try anything. I HATE that! Don't waste my time with downloads that are no better than screenshots.) At least, when run that way it can see the drive and it let me set up a split of the partition, even though it wouldn't Commit the change.

    Now that I've seen that, I think all three companies have a share of the blame. The OS definitely has some issues, but Dell's image has more than a stock, off-the-shelf installation does. And, Acronis should have known their app needed to be run that way and A) told the users and B) set it up to run that way by default (assuming that can be done under Vista). I haven't even found the Groups and Users setup utility, yet, so I can't add myself to the admins group. Another research item.

    Thanks, again.
     
  4. aoz

    aoz Registered Member

    Joined:
    Jun 8, 2005
    Posts:
    223
    I just bought a new tablet PC, toshiba, with vista. Trhing t move partitions, etc, but from the boot cd of DD. That's another issue.

    regarding vista, it does indeed have quirks; I'm learning it as I go along, including hte "run as administrator" quirks.
    overall, it does seem improved from xp, but learning it has its own quirks.
    anyway, I have a couple other threads on the c: partition issue.

    good luck with your endeavor.
    nick
     
  5. John2222

    John2222 Registered Member

    Joined:
    Sep 27, 2005
    Posts:
    140
    I ran into the same problem with a new Dell pc. Same configuration as yours. I wanted to shrink the C: partition down to about 50gb and make the rest a large data partition.

    The problem is not Dell's. It is the Windows Vista restore points, which are significantly changed/enhanced from XP. Bottom line is that there are large chunks of unmovable "restore points" which include much more file data used to allow a more robust System Restore to a previous restore point. In XP I believe the Restore point was just basically a registry roll-back. Now in Vista it includes system file roll-backs as well.

    You can control the default size (which is 15% of the volume!) using vssadmin command (Google for more info).
    for example:

    vssadmin Resize ShadowStorage /On=C: /For=C: /MaxSize=5GB

    If you really want to temporarily eliminate the unmovable chunks, I would:

    First, one should have a good verified image backup (such as Ghost 12 or True Image 10) before trying anything with System Restore.

    1. Temporarily disable System Restore to remove ALL restore points.
    2. Run complete defrag using PerfectDisk or Diskeeper (also offline defrags with them).
    3. Then using a Vista certified partition manager or the Vista partition tools, shrink the partition size.
    4. Finally re-enable System Restore. Create a new restore point.

    You should be able to create a new partition now.

    http://www.google.com/search?&q=vssadmin vista
     
Thread Status:
Not open for further replies.