Problems compiling snapapi module in kernel 2.6.19.1

Discussion in 'Acronis True Image Product Line' started by argaldo, Dec 29, 2006.

Thread Status:
Not open for further replies.
  1. argaldo

    argaldo Registered Member

    Joined:
    Dec 29, 2006
    Posts:
    1
    Hi, i get this errors when trying to compile the snapapi module (from Acronis TrueImage Server Linux 9.1) in a 2.6.19.1 kernel:

    obtusa:/var/lib/dkms/snapapi26/0.7.10/build# make KERNELRELEASE=2.6.19.1 -C /usr/src/linux SUBDIRS=/var/lib/dkms/snapapi26/0.7.10/build modules
    make: Entering directory `/usr/src/linux-2.6.19.1'

    WARNING: Symbol version dump /usr/src/linux-2.6.19.1/Module.symvers
    is missing; modules will have no dependencies and modversions.

    CC [M] /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.o
    /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.c: In function ���cleanup_snapshot���:
    /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.c:614: error: void value not ignored as it ought to be
    make[1]: *** [/var/lib/dkms/snapapi26/0.7.10/build/snapapi26.o] Error 1
    make: *** [_module_/var/lib/dkms/snapapi26/0.7.10/build] Error 2
    make: Leaving directory `/usr/src/linux-2.6.19.1'

    The system is a Debian etch and gcc version is gcc version 4.1.2 20061028 (prerelease) (Debian 4.1.1-19)
     
  2. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
  3. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
    Hello argaldo,

    Would like to let you know that this issue was fixed in build 3883 of Acronis True Image 9.1 Server for Linux.

    Please log in to your account and download the latest build from the "Product Update" section. To get access to updates you should first register your software.

    Thank you.
    --
    Aleksandr Isakov
     
Thread Status:
Not open for further replies.