Problème d'upload en FTP

Discussion in 'LnS French Forum' started by basile, Mar 13, 2007.

Thread Status:
Not open for further replies.
  1. basile

    basile Registered Member

    Joined:
    May 8, 2004
    Posts:
    28
    Bonjour à toutes et à tous

    Je me suis aperçu que je ne peux plus uploader de fichier vers un site FTP dont je m'occupe (avec Dreamweaver 3, configuré en mode passif), chez Free.
    Que ce soit avec Dreamweaver 3 ou Filezilla: même punition pour l'upload sur le serveur: pourtant les deux logiciels se connectent parfaitement et affichent le répertoire du serveur distant comme du local

    Pour débroussailler le terrain, j'utilise cette configuration d'essai:

    Je suis sous Win XP SP2, parefeu intégré désactivé
    Mon FAI est Orange et ma Livebox est une Inventel:
    1) j'ai ouvert tous les ports de 1 à 65535 en TCP et UDP et crée une DMZ pour mon unique ordi;
    2) le parefeu est sur minimum.

    Les essais prouvent que LoknStop est en cause: désactivé, l'upload est possible pour x fichiers, activé il est bloqué.

    J'ai pourtant installé de longue date la règle FTP_data.rie, qui marchait jusqu'ici parfaitement.
    J'ai même ajouté une règle pour le port 21: à ce moment là, l'upload se fait pour le premier fichier, mais bloque dès le second.

    Pour affiner le diagnostic, j'ai demandé à un ami de me placer les fichiers en cause: il n'a eu aucun problème pour faire le transfer donc cela ne vient pas du serveur de Free.

    Ma question: dans cette configuration minimale, que faire pour que LNS autorise l'upload de fichiers en FTP (puisque le download se fait sans pb)?

    Merci d'avance pour vos conseils
     
  2. basile

    basile Registered Member

    Joined:
    May 8, 2004
    Posts:
    28
    Toujours dans la même configuration que ci-dessus, j'ai été obligé de désactiver LNS pour poster mon premier fil.

    Donc le HTTP parait aussi touché, toujours en upload.

    Dans l'intervalle j'ai téléchargé la version B6 de LNS, mais c'est pareil.

    Cela vous aide-t-il dans la compréhension des causes?

    Dois-je installer le patch XPSP2? (cela marchait bien sans ça..)
     
  3. basile

    basile Registered Member

    Joined:
    May 8, 2004
    Posts:
    28
    Bon, apparemment le pb est résolu au deuxième essai, sans bien comprendre pourquoi !

    J'ai réinstallé les règles standard + règle FTP_20: échec ..

    J'ai réinstallé les règles évokuées + règle FTP_20: c'est tout bon en upload FTP et HTTP ..
     
  4. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Bonjour,

    C'est curieux, normalement rien n'aurait du changer entre les 2 jeux de règles pour ce problème de FTP. De plus le jeu de règles évolué est censé être plus restrictif.

    Etes-vous sûr que l'interface réseau est toujours bien sélectionnée dans les options, et que votre adresse IP est bien affichée dans la page d'accueil ?

    La prochaine fois que cela se reproduit, il faudrait consulter la page Journal pour voir ce qui a été bloqué.

    Cordialement,

    Frédéric.
     
  5. basile

    basile Registered Member

    Joined:
    May 8, 2004
    Posts:
    28
    Avec du retard, dont vous voudrez bien m'excuser; merci Frédéric pour votre réponse.

    Mais tout était normal: l'adresse IP et ma carte Ethernet est bien cochée.

    De toutes façons, tout marche maintenant OK ...
     
  6. Dude76

    Dude76 Registered Member

    Joined:
    Feb 28, 2007
    Posts:
    9
    Perso pour filezilla il m'a fallu ouvrir 2 ports:les 20 (ftp-data) et 22(ssh).
    LnS a la bonne idée d'offrir l'option de n'ouvrir les ports que lorsque certains logiciel (FileZilla dans ce cas) sont lancés ^^
     
Thread Status:
Not open for further replies.