Problème (bug?) de priorité des règles >LnS 2.04

Discussion in 'LnS French Forum' started by Quantic Tarantin, Jan 19, 2004.

Thread Status:
Not open for further replies.
  1. Voila; LnS est installé sur mon PC, tt marche impec, et tt et tt.. mais il y à qndmême un petit problème; pour que ma connection sans fil marche, un logciel se mettant au démarrage doit pouvoir accéder au serveur DNS du routeur.. et la regle 'avancée' par défaut de LnS me bloque tt les paquets UDP ('UDP : Bloque le reste') ..donc imposible d'accéder à internet tant que le logiciel n'a pas établi la connection 'sécurisée' avec le routeur..
    J'ai donc créé une regle

    'UDP : Autoriser la résolution des noms (DNS)'
    -Type: IP
    -protocole: UDP
    -Internet>>PC et PC>>Internet
    =>Source PC>>net / Destination net>>PC
    Ip : Adresse: égale a mon @
    UDP port: entre 1024 et 5000
    =>Destination PC>>net / Source net>>PC
    Ip : Adresse: (adresse de mon routeur, 10.0.0.1
    UDP port: égal 53

    Jusque la tout va bien, je mets la regle avant 'UDP:Bloque le reste', je l'applique, et tout marche..mais voila , depuis qq jours, le bug!
    même si la regle du DNS est avant, activée, avec l'option 'ne pas vérifier les regles suivantes si le paquet correspond', c'est la regle 'bloquer le reste' (située après) qui s'applique! je suis obligé de "secouer" la regle du DNS (descendre une fois, monter une fois, puis "appliquer") pour que celle si s'active (on la foit dans le log et tout marche)
    ..j'aimerai savoir comment régler ce problème...
     
  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Bonjour,

    Ce qui peut se passer c'est que dans la règle l'adresse IP du PC pour satisfaire le critère "égale a mon @" ne soit pas mise à jour, pour une raison inconnue.
    Essayez d'autoriser toutes les adresses IP pour voir si le problème disparait.
    Si oui, ensuite il faudrait regarder dans la console l'état du PC, connecté ou pas, pour voir si tout est bien Ok.

    Frédéric
     
  3. L'adresse IP de la carte WiFi de mon PC est fixe..donc pas de mise à jour nécessaire, et c'est bien la bonne vu qe cela marche qnd je ..'secoue' LnS (héoui.. :doubt: )
    Donc cela ne vient pas de la ..merci qndmême...
     
  4. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Ok.

    Ca ressemblait pourtant bien à un problème de ce type.
    Donc la case "connecté à Internet" est bien cochée dans l'onglet d'accueil dès que Look 'n' Stop est lancé ?

    Essayez la version 2.05b1 et si le problème est reproduit avec cette version, ouvrez la console (case à cocher dans les options) et faites un copier/coller (avec la souris) de l'ensemble de la fenêtre vers la fenêtre.

    Frédéric
     
  5. gkweb

    gkweb Expert Firewall Tester

    Joined:
    Aug 29, 2003
    Posts:
    1,932
    Location:
    FRANCE, Rouen (76)
    quelle regle bloque les paquets qd la regles DNS n'est pas prise en compte ?
    Parce ce que ca pourrait etre TCP, en effet DNS utilise prioritairement UDP mais ds certains cas passe par TCP.
    Si c'est ton probleme, change "UDP" ds ta regle par "UDP & TCP".
     
Thread Status:
Not open for further replies.