Problem with Ubuntu Linux , can't recognize wireless card.

Discussion in 'other software & services' started by Metal425, Aug 15, 2007.

Thread Status:
Not open for further replies.
  1. Metal425

    Metal425 Registered Member

    Joined:
    Mar 20, 2007
    Posts:
    188
    Location:
    Southern California
    Well, awhile ago I installed Ubuntu Linux, but It couldn't recognize my wireless card. I tried doing the ndiswrapper, but It went way over my head, since I was a new Linux user, I'm thinking of dumping vista, and going back to linux, if I could get my wireless network card to work. Could anyone help me?
    I have a Belkin F5D8010 wireless card.

    Thanks for reading,
    Matt
     
  2. wilbertnl

    wilbertnl Registered Member

    Joined:
    Dec 29, 2004
    Posts:
    1,850
    Location:
    Tulsa, Oklahoma
    The command lspci or lsusb would give you information about the chipset on the Belkin card. (is that a pci card or a usb card?)
    Knowing which chipset you are dealing with is the first step to get it working under linux.
    Try the command sudo lspci of sudo lsusb in a console and let us know what you found out.
     
  3. Alphalutra1

    Alphalutra1 Registered Member

    Joined:
    Dec 17, 2005
    Posts:
    1,160
    Location:
    127.0.0.0/255.0.0.0
    Thing I found when learning linux/BSD is that the best thing to do is to go straight into it even though the stuff seems hard and over your head. To tell you the truth, I learned a ton when I was forced to use ndiswrapper to get my wireless card working (I now have a nice cat5 cable running through the attic to my room which is nice too :p ).

    However, I think nowadays ubuntu has some fancy-smancy GUI tool that does all of the work and hides the cool stuff from the user, which I guess is good for you until you fell like learning more.

    Another thing about linux/BSD is that you get all of your information from the project's web page, forums, and if that fails then google. You will need to get used to searching and doing a lot of research on your own, otherwise people may not be so kind to you and just tell you to do it yourself.

    Here is a guide I found on how to get your card up and running with ndiswrapper from google. It should work. If not, go to the ubuntu forums (very helpful place), and they should set you straight pretty quickly

    ----edit----

    Did some research on your card for you, and it is the airgo chipset. Someone at ubuntu found using the netgear drivers with ndiswrapper worked better see this post: http://ubuntuforums.org/showthread.php?t=270102

    Cheers,

    Alphalutra1
     
  4. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
    just run this command
    /sbin/lspci or this if that doesn't work lspci

    look at the output of the line Network controller: then look that up at ubuntuforums in the tutorial section or networking section. make sure you uninstall the ndiswrapper you have already installed because there's a high chance it won't work unless you follow a tutorial exactly.


    you can use this to get WPA working if you want -
    http://ubuntuforums.org/showthread.php?t=202834

    you can follow this if you're unsure, i think it will work.
    http://ubuntuforums.org/showthread.php?t=262465
     
  5. Mrkvonic

    Mrkvonic Linux Systems Expert

    Joined:
    May 9, 2005
    Posts:
    8,695
    Hello,

    First, you can try lspci | grep "network" to get only network.

    Second, when you bought your wireless, you got some CD with drivers on it, right? Well, if your brand is normal, which is sounds like it is, the drivers should be on the CD, even for generic linux kernels, maybe even only as sources.

    Try above, and if that does not work, come back here / ubuntuforums.org and write down the exact error code you get.

    Mrk
     
Loading...
Thread Status:
Not open for further replies.