Problem with Software Restriction Policies

Discussion in 'other security issues & news' started by wearetheborg, Feb 23, 2011.

Thread Status:
Not open for further replies.
  1. wearetheborg

    wearetheborg Registered Member

    Joined:
    Nov 14, 2009
    Posts:
    667
    Win 7 Pro

    I activated SRP, and here are my addtional rules:
    Code:
    %HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRoot%
    %HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProgramFilesDir%
    C:\Program Files (x86)
    C:\swsetup
    C:\Windows
    Now, I cannot start Local Security Policies from the control panel, same with the terminal. I have to browse to the file in the windows directory and launch it from there.

    How do I fix that?
     
  2. Greg S

    Greg S Registered Member

    Joined:
    Mar 1, 2009
    Posts:
    1,039
    Location:
    A l a b a m a
    Just guessing, you have it too strict which I think is a good thing. Mine is setup that way. When it's too strict, the shortcut.lnk's are blocked in the start menu. If that is the case, you have to add rules for the shortcuts in the start menu.

    Untitled.png

    You could take the time to be more specific with the path but I didn't. Other alternative would be to remove the .lnk extension in SRP.
     
  3. Martijn2

    Martijn2 Registered Member

    Joined:
    Jul 24, 2006
    Posts:
    321
    Location:
    The Netherlands
    I would follow this advice ;)
     
  4. wearetheborg

    wearetheborg Registered Member

    Joined:
    Nov 14, 2009
    Posts:
    667

    Thanks.
    How do I remove .lnk extension in SRP? In win XP, there was an option to specify filename extensions, but I could not find that in win 7 :blink:
     
  5. J_L

    J_L Registered Member

    Joined:
    Nov 6, 2009
    Posts:
    8,516
    Check Designated File Types.
     
Loading...
Thread Status:
Not open for further replies.