problem with home network

Discussion in 'LnS English Forum' started by loli22, Sep 22, 2009.

Thread Status:
Not open for further replies.
  1. loli22

    loli22 Registered Member

    Joined:
    Sep 6, 2008
    Posts:
    92
    i just setup a home network, windows 7 for the laptop and xp64 for workstation, i downloaded the trial lns with the rule "File sharing on a local network" file from lns website, import it into the firewall, everything is perfect until i decided to modified the three rules imported, because there're other machines within the home network and i dont want them to access my machines, so i had to edit the rules and give the exact IP adress for the source and for the destination ( both machines got static adress) and bingo, no more sharing, when i disable the firewall or use the imported rules at their original form the sharing's back.

    any help guys

    PS: i attached the log file.
     

    Attached Files:

  2. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Probably you entered the IP address of the machines to be allowed on left side of the dialog box.
    They have to be entered on the right side (Destination PC>>Net, Source Net>>PC).

    FYI: the raw packet content is not useful for this kind of case. It's better to include the standard log file, or eventually the raw log file (log files contain decoded packets, and rules that have detected packets like in the log tab; the raw packet content doesn't give rules, and it requires a manual complicated decoding).

    Regards,

    Frederic
     
  3. loli22

    loli22 Registered Member

    Joined:
    Sep 6, 2008
    Posts:
    92
    my laptop got 192.168.1.3

    workstation got 192.168.1.2

    i configured the laptop this way:

    left side: "Equals my @"
    right side: "Equals" 192.168.1.2

    for the workstation:

    left side: "Equals my @"
    right side: "Equals" 192.168.1.3

    i then tried to invert left and right side but still the same (nothing)

    for the log file (sorry for being sarcastic) lns reminded me "graphic equalizer" in windows media player 12, i found only the raw packet file.
     
  4. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    There is an "Log file" checkbox in the option tab.
    This will create a copy of what is displayed into the Log tab to a file.

    Maybe you need to allow some broadcast packets (to 192.168.255.255), for the UDP sharing rule.
    Packets to this IP address are allowed with the default sharing rules, but are no longer allowed if you force the IP address to be 192.168.1.2 or 3.

    The content of the log should help to verify if the problem is there.

    Regards,

    Frederic
     
  5. loli22

    loli22 Registered Member

    Joined:
    Sep 6, 2008
    Posts:
    92
    here's the layout

    laptop: windows 7 x32
    lns: 2.07 beta1
    IP: 192.168.1.3

    workstation: xp64
    lns: 2.06p4
    IP: 192.168.1.2

    the situation is when i start both machines, i need first to disable lns so they can see each others, basically i cant see the laptop's icon in the workstation's "my network places" and vice versa, and after they see each other, i fire up lns and then:
    i can connect from workstation to laptop but not from laptop to workstation.

    i attached the log files and the rules i'm using wich are the same for both machines.

    big thx m8


    PS: please change 002.log to 002.rls
     

    Attached Files:

  6. cqpreson

    cqpreson Registered Member

    Joined:
    May 18, 2009
    Posts:
    348
    Location:
    China
    In my opinion,on your workstation,you should add a rule to allow the packets whose port is 137-139 UDP.From your log file,I find your NetBios is open.But you block the packets of NetBios service.
    On your laptop,you may allow the packets whose port is 1900 and 67-68 UDP.They are both the ports which your services want to use.
     
  7. loli22

    loli22 Registered Member

    Joined:
    Sep 6, 2008
    Posts:
    92
    137-139 UDP are already open
     
  8. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    From workstation.log, the problem seems to be the local port range for the rule "TCP: Share 1".
    The range is 1024-5000, and it should be 49152-65535.

    So just edit this rule to edit the ports.
    You can do it on both machines.

    Regards,

    Frederic
     
  9. loli22

    loli22 Registered Member

    Joined:
    Sep 6, 2008
    Posts:
    92
    i gave up, i do motion graphic for living, not networking
     
  10. Frederic

    Frederic LnS Developer

    Joined:
    Jan 9, 2003
    Posts:
    4,354
    Location:
    France
    Since it was working with the unmodified sharing rules (if I've properly understood), why not just using this configuration ?

    Of course, if you want to allow some computers for some protocols and exclude other computers, you have to do networking, especially with a packet filter.

    Regards,

    Frederic
     
Thread Status:
Not open for further replies.