Problem with FD-ISR?

Discussion in 'FirstDefense-ISR Forum' started by silver0066, Dec 20, 2006.

Thread Status:
Not open for further replies.
  1. silver0066

    silver0066 Registered Member

    Joined:
    Dec 31, 2004
    Posts:
    929
    I just noticed a new message on the bottom of the boot screen when I press F1 stating in red:

    "$ISR FILE NOT FOUND"

    Everything is working okay and C:\$IRS is there and First Defense works okay.

    Has anyone else experienced this? Any suggestions?

    Many thanks,
     
  2. Meriadoc

    Meriadoc Registered Member

    Joined:
    Mar 28, 2006
    Posts:
    2,642
    Location:
    Cymru
    If something like a defrag program moves that file you can have that message.
     
  3. silver0066

    silver0066 Registered Member

    Joined:
    Dec 31, 2004
    Posts:
    929
    Is there anyway to correct it? I use Perfect Disk v7 and did an offline defrag recently. It seens the error message started right after that.
     
  4. Peter2150

    Peter2150 Global Moderator

    Joined:
    Sep 20, 2003
    Posts:
    17,041
    Reboot into windows and start up the GUI. Then enable and disable preboot, and see if that fixes it.

    Pete
     
  5. silver0066

    silver0066 Registered Member

    Joined:
    Dec 31, 2004
    Posts:
    929
    Thanks Pete, that did the trick.

    Silver
     
  6. Longboard

    Longboard Registered Member

    Joined:
    Oct 2, 2004
    Posts:
    3,187
    Location:
    Sydney, Australia
    Perfect disc never did this to me but it could be possible if some data was moved.
    AIR, PD recognises and does not fiddle with the FDISR files.

    The same error can occur after resizing partitions: the data points on the drive may/can get moved and FDISR cant "find itself" on the HD until reboot.
     
  7. jwcca

    jwcca Registered Member

    Joined:
    Dec 6, 2003
    Posts:
    716
    Location:
    Toronto
    This also happened to me after I deleted a snapshot which still had PG (Process Guard) installed. The procguard.sys was locked and couldn't be deleted. The deleted snapshot did not appear in either the FD GUI or the boot-time list of snapshots.
    I checked the logs in C:\$ISR\$LOGS\ISR deleting snapshot errors.log
    (a copy for history) and saw:
    --------------------------------------
    12/27/2006 14:28:34.875 1500 CMD> REMOVE "W2K SP4 with hdwe"
    12/27/2006 14:28:34.875 0 Received "unanchor 3" from client 2
    12/27/2006 14:28:34.875 0 Snapshot 3 unanchored
    12/27/2006 14:28:34.875 0 Received "isrcopy" from client 2
    12/27/2006 14:28:34.875 0 RSS is installed
    12/27/2006 14:28:34.875 0 C:\$ISR\0\ISRCopy2K.exe \\.\pipe\isrpipe0
    12/27/2006 14:28:34.921 0 ISRCopy started
    12/27/2006 14:28:36.921 1542 [67247714]Removing snapshot "W2K SP4 with hdwe"
    12/27/2006 14:28:37.984 0 Received "size 3 -99" from client 2
    12/27/2006 14:28:37.984 0 Size of 3 changed to -99
    12/27/2006 14:28:46.359 1545 Deleted 1.34 Gb (11195 files, 618 dirs); Errors 32; 9 seconds
    12/27/2006 14:28:46.359 0 Received "delete 3" from client 2
    12/27/2006 14:28:46.390 0 Error - Removing C:\$ISR\3: The directory is not empty.
    12/27/2006 14:28:46.390 0 Snapshot 3 deleted
    12/27/2006 14:28:46.390 0 Error - Request returned -123
    12/27/2006 14:28:46.390 0 Received "reanchor 3" from client 2
    12/27/2006 14:28:46.390 0 Error - Request returned -201
    12/27/2006 14:28:46.390 1623 Internal FirstDefense-ISR error - please notify your Technical Administrator
    12/27/2006 14:29:16.312 0 Client 2 disconnected
    12/27/2006 14:29:16.343 0 Snapshot 3 reanchored
    12/27/2006 14:30:41.203 0 Received "config keeplogs 88888888" from client 1
    -----------------------------------------
    then in a subsequent log:
    -----------------------------------------
    12/29/2006 14:17:31.765 10 FirstDefense-ISR Service [Professional Version 1.10.173] started
    12/29/2006 14:17:31.890 0 Error - Unable to read info for snapshot 3
    12/29/2006 14:17:31.906 0 SetActive changed to 0
    12/29/2006 14:17:32.312 0 $ISRBIN location = 15558327
    12/29/2006 14:17:32.312 84 Pre-boot Check ... OK
    -----------------------------------------
    I added an empty snapshot using the original name and no longer got the error message "$ISR FILE NOT FOUND"

    so there are at least 2 ways for this to happen, and 2 ways to fix it.

    Jim
     
  8. Longboard

    Longboard Registered Member

    Joined:
    Oct 2, 2004
    Posts:
    3,187
    Location:
    Sydney, Australia
    @JWC & silver

    Yeah,

    There are a couple of threads here where there have been errors with various utilities and combos that protect them selves and might produce similar errors.

    Many app monitors, HIPS, sandbox type apps seem to be associated with errors.

    PrevX never caused a problem yet (?good thing or not :blink: )
    GesWall seem OK

    @JW Clements: what did you do with PG?
     
  9. Peter2150

    Peter2150 Global Moderator

    Joined:
    Sep 20, 2003
    Posts:
    17,041
    I always had to disable PG when copying, but then I discovered even disabled it was causing errors when copying to archives. Thats when I said bye bye to PG
     
  10. rabosr

    rabosr Registered Member

    Joined:
    Feb 11, 2007
    Posts:
    7
    Can't install FD-ISR. Every time I try it comes up with message it "can't fine old $ISRBIN. I am at a lose to find a solution. Have uninstalled and reinstalled the program several times and now it won't even install because of the above message.
     

    Attached Files:

  11. Peter2150

    Peter2150 Global Moderator

    Joined:
    Sep 20, 2003
    Posts:
    17,041
    I'd send the info you showed to Raxco (or the other vendors, depending on where you bought it) techsupport.

    Pete
     
  12. ErikAlbert

    ErikAlbert Registered Member

    Joined:
    Jun 16, 2005
    Posts:
    9,455
    FYI, I believe that this is the latest version : "PerfectDisk 8 build 50". (I still got it free)
     
Thread Status:
Not open for further replies.