Problem: Win 7, Java 64-bit, Smart Security 64-bit

Discussion in 'ESET Smart Security' started by swillows, May 9, 2011.

Thread Status:
Not open for further replies.
  1. swillows

    swillows Registered Member

    Joined:
    May 9, 2011
    Posts:
    1
    I have the following installed on my development machine:
    -Windows 7 64-bit
    -ESET Smart Security 64-bit
    -Java SE 6 Update 25 64-bit
    -Eclipse 3.6 64-bit
    -JBoss 5.1 with:
    * Our application
    * TestNG (Implementation-Version: 5.9-200903311355)


    I started up JBoss and it seems to be running fine. However, when I started testing our application using TestNG, my machine hung. Initially, all Windows and UI elements became unresponsive, and then eventually the mouse cursor froze as well. The only way to rectify the situation was to do a hard reboot.

    I performed various memory and system tests, and my hardware was fine. I tried adding the java.exe and javaw.exe executables to the anti-virus exclusion list, but the problem occurred again. I tried disabling the Smart Security firewall, anti-virus and anti-spam protection, but the problem occurred again. I have also reproduced this error with the latest Smart Security Beta.

    Then, I uninstalled Smart Security and ran the testing process again, and it finished correctly. I repeated the test process multiple times and at no point did my machine hang. I then reinstalled Smart Security and ran the testing process again, and my machine hung. I have also reproduced this error on another machine in our office with identical hardware specifications and the same software installed.

    There seems to be an issue with Java, Smart Security and Windows 7. I have seen at least one other case (on another forum) of this occurring. Unfortunately, I was unable to find the link to that thread again.

    Anyone have any advice? Is this a known issue?

    --Shaun
     
  2. MattJN

    MattJN Former ESET Support Rep

    Joined:
    Feb 19, 2010
    Posts:
    149
    Hello,

    Please try the following to see if it makes a difference:

    1. Reset the firewall rules on the machine(s).

    2. Switch the firewall mode to Interactive mode (Click Setup Personal firewall in the main menu on the left and then click Switch to interactive filtering mode in the Personal firewall area).

    3. Retest your application. Your ESET Personal firewall will prompt you to allow or deny each connection that is not defined by an existing rule. To create the rules you need, select the Remember action (create rule) check box in the dialog window and click Allow for each box that appears; there may be serveral prompts before functionality returns with the firewall enabled.

    Once everything works to your satisfaction, switch the firewall mode back to Automatic mode (with exceptions).

    Hope that helps.

    Thanks,

    Matt
     
Thread Status:
Not open for further replies.