Problem shutting down windows

Discussion in 'other software & services' started by AnthonyG, Dec 18, 2004.

Thread Status:
Not open for further replies.
  1. AnthonyG

    AnthonyG Registered Member

    Joined:
    Aug 3, 2004
    Posts:
    614
    Receintly in the last 3-4 weeks a very annoying problem has occured when shutting down my machine and that is when i go to shut down windows. A unable to end bar comes up for "XPCOM:eventviewer".

    I wait until the bar has counted down and then click end, my machine still does not switch off but i wait another minute or two then the same XPCOMeventviewer cant end message comes up. It will come up about eight times and i have to end the process eight times before i can switch the machine off. So with that problem it takes about 15 minutes to actually turn my machine off.

    Can i ask does anyone know what the problem is and what this XPCOM is and how i can remove it.

    Thanks
     
  2. Notok

    Notok Registered Member

    Joined:
    May 28, 2004
    Posts:
    2,969
    Location:
    Portland, OR (USA)
    Can you go to Start > Control Panel > Administrative Tools > Event Viewer and find what it's saying there when you shut down? (this may be easiest to do if you reboot and go there first thing. Look for any red dots with white 'X's in them, especially, also yellow triangles with exclamation points. Double click them to see the full alert.)
     
  3. Blackspear

    Blackspear Global Moderator

    Joined:
    Dec 2, 2002
    Posts:
    15,115
    Location:
    Gold Coast, Queensland, Australia
  4. AnthonyG

    AnthonyG Registered Member

    Joined:
    Aug 3, 2004
    Posts:
    614
    Thanks, i shut down my computer and then had a look at my event viewer but nothing was there.

    After a bit of googling though i have came across someone with the same problem but i dont understand the advice that was given, could someone put it in lamens terms so i can fix this problem

    Thanks for your help
     
  5. AnthonyG

    AnthonyG Registered Member

    Joined:
    Aug 3, 2004
    Posts:
    614
    I have kept browsing and found a link describing the xpcom event receiver in mozilla

    http://www.xulplanet.com/tutorials/xultu/xpcom.html

    It also seems to be what has been causing my firefox problems (ive been having problems with using firefox receintly too)

    From what people have said there possibly seems to be some sort of compatibility problem between mcafee (i use mcafee virusscan home 9) and mozilla (i use firefox)

    Can someone give me some help as i didnt know that this was also messing up my internet browsing too.

    Thanks.
     
  6. AnthonyG

    AnthonyG Registered Member

    Joined:
    Aug 3, 2004
    Posts:
    614
    Does anyone know of help for this problem as like i have said it is not only causing problems with my shutting down of windows but once when this problem occurs Firefox crashes, then is sluggish and no other browsers will work, i.e Internet Explorer, Maxthon, Opera all cease to work until i restart windows, but then it just happens again.

    So i definitlely need some help with this, as i have tried other browsers but non compare to Firefox.

    Thank you
     
  7. Jae

    Jae Guest

    I have had a similar problem, although I find the annoying part is not while shutting down, it is when my internet freezes on me. I find that my internet freezing is correlated to my use of Firefox. In addition, I use McAfee as well... So perhaps FireFox and McAfee just do not work together well fro some reason... if you find any solutions, besides using IE, let me know... <removed>gmail.com

    Removed email address for posters protection-Ron
     
    Last edited by a moderator: Jan 12, 2005
  8. bigc73542

    bigc73542 Retired Moderator

    Joined:
    Sep 21, 2003
    Posts:
    23,873
    Location:
    SW. Oklahoma

    I use mozilla 1.7.5 browser and mcafee and have no compatability problems
     
  9. Motor_Head

    Motor_Head Guest

    I don't use McAfee, but I do get this problem whenever I have used Firefox.
     
  10. Rita

    Rita Infrequent Poster

    Joined:
    Jun 28, 2004
    Posts:
    6,863
    Location:
    wilds of wv
    Hi Anthony
    I have the same problem except first it's panda,then it finaly shuts down and then it's aol dial.exe.I probaly shouldnt do it but I just click end now instead of waiting as you said ten minutes to shut down.
     
  11. maja

    maja Registered Member

    Joined:
    Feb 2, 2005
    Posts:
    1
    Hi Antony,

    I am using firefox too and have the same problem with xpcom event.exe you are discribing. I am just klicking on "end now".
    The problem came up after I installed xp sp2 new on my computer. Before I had xp sp2 too and was using firefox as well and had no problem?!? the only difference I can see is that before I was using AntiVir and now Sophos.
    Hmm, guess it's not really going to help you........
     
    Last edited: Feb 2, 2005
  12. Tam1

    Tam1 Guest

    Just to add a "ME TOO" to this thread

    Get exactly the same..

    I DO use Mozilla 1.7.5
    I DO use McAfee V9
    I DO use XP SP2

    If i see a solution i'll be sure to point you to it ... but it's very annoying!
     
  13. Tam1

    Tam1 Guest

    Just to add to my last post,

    I have an almost identical set-up on my laptop, except it uses Corporate Sohpos AV instead of McAfee and it has no problems...
     
  14. HandsOff

    HandsOff Registered Member

    Joined:
    Sep 16, 2003
    Posts:
    1,946
    Location:
    Bay Area, California
    this is just an ignorant suggestion since this is my very first Firefox flight, however, if you have the problem while shutting down the computer, would it help if you shut McAfee down first, then shut down firefox? sure you would be vulnerable for two seconds, but i think i might be worth the chance.


    Also would it make a difference to change your default browser? (under tools, options) in firefox and pretty similar place in IE 6. j

    - HandsOff
     
  15. Tam1

    Tam1 Guest

    What I've started doing - which appears to fix the issue is:

    1) When ready to shut-down the PC - Close ALL programs.
    2) Open up task manager
    3) Select processes
    4) Find FireFox.exe in the process list (usually using about 50Mb of memory)
    5) Highlight FireFox.exe
    6) Click "End Process"
    7) Shut-down the PC without a problem.

    It does seem that even when you have closed FireFox the process is still running on the PC.

    Anyone else finding this?
     
  16. HandsOff

    HandsOff Registered Member

    Joined:
    Sep 16, 2003
    Posts:
    1,946
    Location:
    Bay Area, California
    Very interesting Tam1. I havent resolved my shutdown issue yet, but going through the proccesses might yeild something.

    Sidebar: If you get annoyed trying to shut something down with the task manager, but the task manager won't do it, download a free program from DCS called Taskman+. It's really cool making an annoying program stop. One example is when you try to copy a file from a floppy that is unreadable. My computer will attempt to read the stupid file till the cows come home...anyway, try it, it's free and satisfying...just like me!


    - HandsOff
     
  17. Carrok

    Carrok Guest

    I have this problem when Firefox accesses a Quicktime Video File, or when Thunderbird tries to download a large e-mail file. I've been searching for solutions, and as you've all realized, no one has any. I'm just going to un-install every trace of every mozilla product from my computer, and then re-install them all.
     
  18. Carrok

    Carrok Guest

    Well, just spent an hour or so removing every trace of Mozilla from my computer, and re-installing them, and the problem remains. I really wish they would just fix this damn problem. I've been having it for months, and it's really getting old.
     
  19. iceni60

    iceni60 ( ^o^)

    Joined:
    Jun 29, 2004
    Posts:
    5,116
  20. HandsOff

    HandsOff Registered Member

    Joined:
    Sep 16, 2003
    Posts:
    1,946
    Location:
    Bay Area, California
    One thing, Carrok,

    I'm not clear on if you are saying that after removing all of the firefox components, your system shut down correctly, and then after you reinstalled firefox the problem came back, or you are saying that ever since you first installed firefox you have had the problem, and even un and re installing firefox did not help?

    You see, I have had to refuse to shut down problem and have been attacking from the other angle, that it is something other than firefox.

    I've had about the same success as you have, so far, but it really hasn't bothered me that much as in my case every thing runs fine, but when i try to shut down, it restarts instead. I either leave it running, or I tell it to shut down and wait for it to save my settings and get out of windows, then kill the power befor it can start again. Not exactly smooth, but it works.

    When I feel like another dose of aggravation I will either work at it again or read some EULA's.


    - HandsOff
     
  21. Udon

    Udon Guest

    Same problem with w2k + FireFox + (ZoneAlarm)

    I had similar problem for the first time this morning.
    What I did yesterday before sleeping was
    - Let ZoneAlarm block any internet connection while screen saver is working.
    - Left Firefox browser running
    - Left PC power on
    This morning I found my computer is running very slow. Task manager reported 100% CPU power is being used.
     
  22. JRCATES

    JRCATES Registered Member

    Joined:
    Apr 7, 2005
    Posts:
    1,203
    Location:
    USA
    It could very well be something as simple and as silly as a plug in.

    Firefox continually crashed on me the other day because I went to http://www.nfl.com and the page required REAL PLAYER plug ins to view a portion of the page, and I had the plug ins but DID NOT have Real Player installed on my machine any longer. Once I deleted the Real Player plug ins from the Firefox folder, I could surf to nfl.com and every other wsite without any problem. But until I did that, the browser would crash every time I tried to visit that page (with Microsoft's "Dr. Watson" error reporting message wanting to report the error)
     
  23. ravin

    ravin Registered Member

    Joined:
    May 2, 2003
    Posts:
    241
    Location:
    South Carolina
    I have posted a link below that may or may not solve some of the shutdown problems that some of you are having. please read the link page as it does discuss AV's not releasing, printers not releasing etc. I have and currently use it in a network environment for slow processes not finishing. it helps. and can be unistalled if you no longer want it.

    http://support.microsoft.com/default.aspx?scid=kb;en-us;837115
     
  24. HandsOff

    HandsOff Registered Member

    Joined:
    Sep 16, 2003
    Posts:
    1,946
    Location:
    Bay Area, California

    Hi Ravin-

    Good information and good utility to have on hand. It would be an especially good choice if one observed memory leakage occurances. I just happened onto a Blog by Mark Russinovich discussing some SysInternals software and a kernal debugger. It actually looks pretty simple. Still, my computer doesn't seem quite broken enough for me to do it...yet. If you want to look at the blog and the software discussed they are:

    http://www.sysinternals.com/Blog/

    http://www.sysinternals.com/files/notmyfault.zip
    http://www.sysinternals.com/Utilities/LiveKd.html
    http://www.microsoft.com/whdc/devtools/debugging/default.mspx


    ...and let me know how it turns out!


    - HandsOff
     
  25. Shrek

    Shrek Guest

    This should light a fire under Window's butt at closing time:

    Leave Windows XP to handle something like shutting down, and it will likely take its own sweet time about it. Here are some things you can do to light a fire under XP at quitting time:
    - Start Menu / Run... / Regedit / press ENTER
    - Go to HKEY LOCAL MACHINE\SYSTEM\CurrentControlSet\Control
    - Double-click the entry called WaitToKillServiceTimeout (or create it as a REG_SZ string value if it's not there)
    - Set its value to something lower than the default of 20,000 (I chose 1000)
    - Go to HKEY CURRENT USER\Control Panel\Desktop
    - Find the entry called AutoEndTasks (or create it as a REG_SZ string value if it's not there)
    - Set the value to 1
    - In the same list of entries, look for WaitToKillAppTimeout
    - I gave mine a value of 2000
    - Also in the same list, there should be one called HungAppTimeout, which I gave a value of 2500.

    I came across this tweak sometime ago and have used it on numerous occassions with success.
     
Loading...
Thread Status:
Not open for further replies.