Problem Patching uxtheme.dll

Discussion in 'other software & services' started by huntnyc, Aug 1, 2007.

Thread Status:
Not open for further replies.
  1. huntnyc

    huntnyc Registered Member

    Joined:
    Nov 10, 2004
    Posts:
    976
    Location:
    Brooklyn, USA
    Ran Multipatcher 5.5 on my XP Pro setup and all seemed well but when I restored an image (that had the patched dll), Windows did not load the patched dll but put back the original unpatched uxtheme.dll.

    Is there something I can do to remedy this so when I restore an image I won't have this happen and the patched dll will be in place. Thanks a lot.

    Gary
     
  2. argus tuft

    argus tuft Registered Member

    Joined:
    Sep 20, 2006
    Posts:
    280
    Location:
    Australia
    Did you put a patched uxtheme.dll in %windir%\system32\dll cache?

    If windows detects that uxtheme is patched, it will replace it with the one in dll cache (I'm pretty sure it will, anyway.)
     
  3. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
  4. huntnyc

    huntnyc Registered Member

    Joined:
    Nov 10, 2004
    Posts:
    976
    Location:
    Brooklyn, USA
    No, but I think I will try that and see if that works. Thanks a lot.

    Gary
     
  5. huntnyc

    huntnyc Registered Member

    Joined:
    Nov 10, 2004
    Posts:
    976
    Location:
    Brooklyn, USA
    One more thing - keep a copy of my i386 folder containing XP on a separate partition on my primary hard drive. Could this also pose a problem with the uxtheme.dll being replaced from that location?

    WSFuser,

    I am glad you have not seen this problem but I wonder why. Wish I could get this sorted so i could use some nice themes and be confident restoring images that uxtheme.dll would not be reset. Thanks again.

    Gary
     
  6. huntnyc

    huntnyc Registered Member

    Joined:
    Nov 10, 2004
    Posts:
    976
    Location:
    Brooklyn, USA
    Also, if the patch works correctly, does this change the modify date and/or size of uxtheme.dll? Thanks.

    Gary
     
  7. huntnyc

    huntnyc Registered Member

    Joined:
    Nov 10, 2004
    Posts:
    976
    Location:
    Brooklyn, USA
    Had to use the manual method of changing the uxtheme.dll file but it works now. I restored the image that had the modified dll file just fine. Guess the Multipatcher program was not working on my laptop for osme reason. Thanks again for your help.

    Gary
     
  8. WSFuser

    WSFuser Registered Member

    Joined:
    Oct 7, 2004
    Posts:
    10,632
    @huntnyc - the reason I dont have the problem is simple: I have SFC/WFP disabled.

    However, Im glad you got your problem sorted.
     
  9. huntnyc

    huntnyc Registered Member

    Joined:
    Nov 10, 2004
    Posts:
    976
    Location:
    Brooklyn, USA
    Thanks for your response WSFuser. If I do have future problems, will think about disabling WFP.

    Gary
     
Loading...
Thread Status:
Not open for further replies.