Problem installing TrueImageServer9.1_d_en.i686 on Linux

Discussion in 'Acronis True Image Product Line' started by biggyL, Aug 21, 2007.

Thread Status:
Not open for further replies.
  1. biggyL

    biggyL Registered Member

    Joined:
    Apr 29, 2006
    Posts:
    7
    Hello Acronis team,

    I've downloaded your trial version for linux - TrueImageServer9.1_d_en.i686
    Now I'm trying to install it on my new gentoo installation and I'm getting
    "Acronis True Image Server Setup failed to build kernel modules. Consult /var/log/trueimage-setup.log and /var/lib/dkms/snapapi26/0.7.10/build/make.log for error messages."

    in /var/lib/dkms/snapapi26/0.7.10/build/make.log:

    DKMS make.log for snapapi26-0.7.10 for kernel 2.6.22-gentoo-r2 (i686)
    Tue Aug 21 21:14:21 Local time zone must be set--see zic manual page 2007
    make: Entering directory `/usr/src/linux-2.6.22-gentoo-r2'
    find: `/linux': No such file or directory
    CC [M] /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.o
    /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.c:36:27: error: linux/ioctl32.h: No such file or directory
    /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.c:205: warning: 'kmem_cache_t' is deprecated
    /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.c: In function 'cleanup_snapshot':
    /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.c:614: error: void value not ignored as it ought to be
    /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.c: In function 'sa_cache_emlist_init':
    /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.c:781: error: 'SLAB_KERNEL' undeclared (first use in this function)
    /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.c:781: error: (Each undeclared identifier is reported only once
    /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.c:781: error: for each function it appears in.)
    /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.c: In function 'sa_cache_emget':
    /var/lib/dkms/snapapi26/0.7.10/build/snapapi26.c:815: error: 'SLAB_ATOMIC' undeclared (first use in this function)
    make[1]: *** [/var/lib/dkms/snapapi26/0.7.10/build/snapapi26.o] Error 1
    make: *** [_module_/var/lib/dkms/snapapi26/0.7.10/build] Error 2
    make: Leaving directory `/usr/src/linux-2.6.22-gentoo-r2'

    If I try to build the module manually I get:
    # dkms build -m snapapi26 -v 0.7.10 --config /boot/config-2.6.22-gentoo-r2 --arch i686 --kernelsourcedir /usr/src/linux-2.6.22-gentoo-r2

    Preparing kernel 2.6.22-gentoo-r2 for module build:
    (This is not compiling a kernel, only just preparing kernel symbols)
    Storing current .config to be restored when complete
    Running Generic preparation routine
    make mrproper......
    using /boot/config-2.6.22-gentoo-r2
    make oldconfig......
    make prepare-all....(bad exit status: 2)

    Building module:
    cleaning build area....
    make KERNELRELEASE=2.6.22-gentoo-r2 -C /usr/src/linux-2.6.22-gentoo-r2 SUBDIRS=/var/lib/dkms/snapapi26/0.7.10/build modules....(bad exit status: 2)

    Error! Bad return status for module build on kernel: 2.6.22-gentoo-r2 (i686)
    Consult the make.log in the build directory
    /var/lib/dkms/snapapi26/0.7.10/build/ for more information.


    I've seen on the forum that you can send new snapapi26_modules-0.7.x.noarch.rpm to solve this problem.

    Please help.
     
  2. biggyL

    biggyL Registered Member

    Joined:
    Apr 29, 2006
    Posts:
    7
    Hello All,


    Since I've got no response from acronis support on this forum,
    could someone send me snapapi26_modules-0.7.19-1.noarch.rpm to lkolchin@gmail.com so I could install trial version on latest Gentoo server?
     
  3. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
  4. techepet

    techepet Registered Member

    Joined:
    Oct 17, 2007
    Posts:
    1
    I also need the new snapimodule please can you send it to me. Thanks
     
  5. drogonx

    drogonx Registered Member

    Joined:
    Oct 27, 2007
    Posts:
    1
    i have the same problem.

    installing trial version for linux - TrueImageServer9.1
    on Suse 10.3.

    pleace send me a newer snapapi modul for Suse 10.3.

    thanks

    drogonx
     
  6. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
  7. dacorsa

    dacorsa Registered Member

    Joined:
    Oct 31, 2007
    Posts:
    2
    same problem here with debian sid... i can't install...

    can you send me a PM or email dacorsa@infinito.it.

    thanks
     
  8. Acronis Support

    Acronis Support Acronis Support Staff

    Joined:
    Apr 28, 2004
    Posts:
    25,885
Thread Status:
Not open for further replies.