Port forwarding rules on router instead of ESET SS?

Discussion in 'ESET Smart Security' started by am_dew, Feb 27, 2008.

Thread Status:
Not open for further replies.
  1. am_dew

    am_dew Registered Member

    Joined:
    Dec 27, 2005
    Posts:
    33
    I just installed a Linksys router. I download bit torrents from time to time and would like to offload the port forwarding responsibility to the router instead of having ESET handle it. How would I go about doing this? I use ESET SS in "interactive mode". How will ESET SS know that, after I set my router up properly to allow port forwarding on the selected ports, that all is OK and it should not prompt me to allow or deny the traffic?
     
  2. nickster_uk

    nickster_uk Registered Member

    Joined:
    Feb 14, 2006
    Posts:
    190
    Hi..

    you can use the following site to help you set up port forwarding on your router:
    http://portforward.com/english/routers/port_forwarding/routerindex.htm

    All you need to do is select your make and model router, then choose the application you want to configure and it will show you what to do in a step by step process with screenshots.

    As for ESS, with my current config which is interactive mode, when I use utorrent to download music sets, I don't have to forward a port in it as such. All I do is load the torrent and ESS asks for access, I placed a check in temporary allow access and click allow. I don't think it's too wise to permanently allow access without asking but that is upto you...but having to click the temp box and click allow isn't really an inconvenience as such.

    Also, set your torrent client to use a dynamic port which if memory serves me correct is anything between 49152-65535.

    Hope that helps :)
     
  3. am_dew

    am_dew Registered Member

    Joined:
    Dec 27, 2005
    Posts:
    33
    Thanks nickster. THis does help, but something bothers me in one of the screenshots for my router:

    http://portforward.com/english/routers/port_forwarding/Linksys/WRT54G/WRT54G3.jpg

    It shows that the firewall is disabled, yet the web page as a whole (http://portforward.com/english/routers/port_forwarding/Linksys/WRT54G/BitTornado.htm) makes no mention of disabling it so perhaps that is a mistake.

    Are you only prompted once then by ESS when downloading a torrent? Not prompted by each request from peers to access?
     
  4. nickster_uk

    nickster_uk Registered Member

    Joined:
    Feb 14, 2006
    Posts:
    190
    Hmm that does look a little weird but I have no experience of Linksys routers so i'm not sure what to suggest.

    Perhaps the best thing to do is run a couple of comprehensive port scans on your system with ESS firewall temporarily disabled to see if anything is getting past the router. If they all come back that your system is secure, then it may just be the way the router interface behaves.

    As for the torrent question, as long as you place a check in the box to temporarily remember the option, that will take care of all incoming and outgoing connections to your torrent client until you close the program and reopen it to start again or continue a download.
     
  5. shansmi

    shansmi Registered Member

    Joined:
    Feb 19, 2008
    Posts:
    130
    this varies router to router even if they are all linksys. on the linksys website you can search their knowledge base for exact instructions to port forward on your router. I have also see some stuff on either port 113 or 139 off the portscan websites that detail how to do it on several different router types......


    the rules are pretty simpe though... if blocking open ports by port forwarding, you just pick an IP at the high end of the DHCP range for hosts (usually it is a class C network with 254 hosts) but the router/switch only has 4-8 ports....pick an IP in the 250 range and use it as a destination IP...the rule will look something like this in your routing table to forward port 113:

    SrcIP Port DestIP Port
    *.*.*.* 113 192.16.0.250 113

    This works if the.250 IP is not used i.e. the request will still get through the router but it will be sent to a phantom host......

    hope this helps....
     
Thread Status:
Not open for further replies.